summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-11-17 14:13:50 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-12-01 07:25:10 +0000
commit4383f6ec880dc1b2db4760216ea1d1a96fcd9cf2 (patch)
treeac24c791951d6861cb419ab1b02d273d30be6d84
parentaed413df1ee31aad6f67eca405ed01d82d628fc7 (diff)
downloadmeta-boot2qt-4383f6ec880dc1b2db4760216ea1d1a96fcd9cf2.tar.gz
ostree: Add TLS support
Change-Id: I2cbfe533a8ce58d337f77f013b0da47a6a91681e Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend28
-rw-r--r--recipes/ostree/ostree.bb8
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend b/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend
new file mode 100644
index 0000000..bc3d1ff
--- /dev/null
+++ b/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend
@@ -0,0 +1,28 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# Remove this recipe when openembedded-core/meta/recipes-support/libsoup/
24# will be updated to 2.50.0 version or above.
25PV = "2.50.0"
26
27SRC_URI[md5sum] = "9a84d66e1b7ccd3bd340574b11eccc15"
28SRC_URI[sha256sum] = "1e01365ac4af3817187ea847f9d3588c27eee01fc519a5a7cb212bb78b0f667b"
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index c4a6f69..bc13ac2 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -41,7 +41,13 @@ S = "${WORKDIR}/git"
41DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz" 41DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
42RRECOMMENDS_${PN} += "gnupg" 42RRECOMMENDS_${PN} += "gnupg"
43 43
44EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no" 44EXTRA_OECONF = "--with-dracut \
45 --without-selinux \
46 --without-libarchive \
47 --with-grub2=no \
48 --enable-gtk-doc-html=no \
49 --with-soup \
50 --enable-libsoup-client-certs"
45 51
46do_configure_prepend() { 52do_configure_prepend() {
47 cd ${S} 53 cd ${S}