summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-11-09 16:01:03 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-11-19 06:49:25 +0000
commit679567dfdc6709417f57f0497252a4315d9b3a19 (patch)
tree4f5c77b65624c7093fac0f643b984f27418f218a
parent2d904c40918688065bd040c988241ecf1e1e571d (diff)
downloadmeta-boot2qt-679567dfdc6709417f57f0497252a4315d9b3a19.tar.gz
Use Systemd as the init system
Remove sysvinit from distro features and add Systemd as the default init system. Add necessary service files to all recipes that need them. Change-Id: I9cd4c0239fe16f35145bd3bed08e27196f30ee82 Reviewed-by: Gatis Paeglis <gatis.paeglis@theqtcompany.com> Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--conf/distro/b2qt.conf8
-rw-r--r--conf/distro/include/emulator.conf2
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb8
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service9
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb8
-rw-r--r--recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmount.service9
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher.bb12
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher/b2qt.service10
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher/qtlauncher.service10
-rw-r--r--recipes/adbd/adbd.bb13
-rw-r--r--recipes/adbd/files/adbd.service11
-rw-r--r--recipes/ostree/ostree.bb8
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb2
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb1
-rw-r--r--recipes/systemd/systemd_%.bbappend26
-rw-r--r--recipes/virtualbox/mount-vboxsf/mount-vboxsf.service12
-rw-r--r--recipes/virtualbox/mount-vboxsf_4.3.30.bb11
17 files changed, 146 insertions, 14 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index f31a9d7..f006cf6 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -39,11 +39,17 @@ SYSVINIT_ENABLED_GETTYS = ""
39 39
40DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs webengine" 40DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs webengine"
41POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" 41POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch"
42DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" 42DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio sysvinit"
43 43
44# use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10 44# use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10
45DISTRO_FEATURES += "gstreamer" 45DISTRO_FEATURES += "gstreamer"
46 46
47DISTRO_FEATURES += "systemd"
48VIRTUAL-RUNTIME_init_manager = "systemd"
49VIRTUAL-RUNTIME_initscripts = ""
50PREFERRED_PROVIDER_udev ?= "systemd"
51PREFERRED_PROVIDER_udev-utils ?= "systemd"
52
47PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo" 53PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo"
48PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native" 54PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native"
49 55
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index 28be593..34b2029 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -32,7 +32,7 @@ MACHINE_EXTRA_RRECOMMENDS += "\
32PREFERRED_PROVIDER_virtual/egl = "qtglesstream-dummy-client" 32PREFERRED_PROVIDER_virtual/egl = "qtglesstream-dummy-client"
33PREFERRED_PROVIDER_virtual/libgles2 = "qtglesstream-dummy-client" 33PREFERRED_PROVIDER_virtual/libgles2 = "qtglesstream-dummy-client"
34 34
35KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest" 35KERNEL_MODULE_AUTOLOAD += "snd-intel8x0 vboxguest vboxsf"
36 36
37DISTRO_FEATURES_remove = "webengine opengl" 37DISTRO_FEATURES_remove = "webengine opengl"
38 38
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb
index 15fe3c0..ea31e21 100644
--- a/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy.bb
@@ -29,6 +29,7 @@ inherit qt5-module
29SRC_URI = " \ 29SRC_URI = " \
30 git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \ 30 git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \
31 file://emulatorproxyd.sh \ 31 file://emulatorproxyd.sh \
32 file://emulatorproxy.service \
32 " 33 "
33 34
34SRCREV = "89ca944fae7106a55803ddce6fd84447685b61e5" 35SRCREV = "89ca944fae7106a55803ddce6fd84447685b61e5"
@@ -41,9 +42,14 @@ DEPENDS = "qtbase qtsimulator"
41do_install_append() { 42do_install_append() {
42 install -m 0755 -d ${D}${sysconfdir}/init.d 43 install -m 0755 -d ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/ 44 install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/
45
46 install -m 0755 -d ${D}${systemd_unitdir}/system
47 install -m 0644 ${WORKDIR}/emulatorproxy.service ${D}${systemd_unitdir}/system/
44} 48}
45 49
46INITSCRIPT_NAME = "emulatorproxyd.sh" 50INITSCRIPT_NAME = "emulatorproxyd.sh"
47INITSCRIPT_PARAMS = "defaults 97 10" 51INITSCRIPT_PARAMS = "defaults 97 10"
48 52
49inherit update-rc.d 53SYSTEMD_SERVICE_${PN} = "emulatorproxy.service"
54
55inherit update-rc.d systemd
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service
new file mode 100644
index 0000000..d48ed41
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-proxy/emulatorproxy.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=QtSimulator Proxy Daemon
3After=systemd-user-sessions.service
4
5[Service]
6ExecStart=/usr/bin/emulatorproxyd
7
8[Install]
9WantedBy=multi-user.target
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb
index 622363d..038c972 100644
--- a/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd.bb
@@ -29,6 +29,7 @@ inherit qt5-module
29SRC_URI = " \ 29SRC_URI = " \
30 git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \ 30 git://codereview.qt-project.org/tqtc-boot2qt/emulator;branch=${BRANCH};protocol=ssh \
31 file://sdcardmountd.sh \ 31 file://sdcardmountd.sh \
32 file://sdcardmount.service \
32 " 33 "
33 34
34SRCREV = "89ca944fae7106a55803ddce6fd84447685b61e5" 35SRCREV = "89ca944fae7106a55803ddce6fd84447685b61e5"
@@ -41,9 +42,14 @@ DEPENDS = "qtbase qtsimulator"
41do_install_append() { 42do_install_append() {
42 install -m 0755 -d ${D}${sysconfdir}/init.d 43 install -m 0755 -d ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/sdcardmountd.sh ${D}${sysconfdir}/init.d/ 44 install -m 0755 ${WORKDIR}/sdcardmountd.sh ${D}${sysconfdir}/init.d/
45
46 install -m 0755 -d ${D}${systemd_unitdir}/system
47 install -m 0644 ${WORKDIR}/sdcardmount.service ${D}${systemd_unitdir}/system/
44} 48}
45 49
46INITSCRIPT_NAME = "sdcardmountd.sh" 50INITSCRIPT_NAME = "sdcardmountd.sh"
47INITSCRIPT_PARAMS = "defaults 97 10" 51INITSCRIPT_PARAMS = "defaults 97 10"
48 52
49inherit update-rc.d 53SYSTEMD_SERVICE_${PN} = "sdcardmount.service"
54
55inherit update-rc.d systemd
diff --git a/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmount.service b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmount.service
new file mode 100644
index 0000000..1171089
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-emulator-sdcardmountd/sdcardmount.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=QtSimulator SD Card Mount Daemon
3After=systemd-user-sessions.service
4
5[Service]
6ExecStart=/usr/bin/sdcardmountd
7
8[Install]
9WantedBy=multi-user.target
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher.bb b/recipes-qt/b2qt-addons/b2qt-launcher.bb
index 98de916..ab02d97 100644
--- a/recipes-qt/b2qt-addons/b2qt-launcher.bb
+++ b/recipes-qt/b2qt-addons/b2qt-launcher.bb
@@ -29,6 +29,8 @@ inherit qmake5 sdk-sources
29SRC_URI = " \ 29SRC_URI = " \
30 git://codereview.qt-project.org/tqtc-boot2qt/launcher;branch=${BRANCH};protocol=ssh;sdk-uri=5.5/Boot2Qt/sources/b2qt-launcher \ 30 git://codereview.qt-project.org/tqtc-boot2qt/launcher;branch=${BRANCH};protocol=ssh;sdk-uri=5.5/Boot2Qt/sources/b2qt-launcher \
31 file://b2qt-startup.sh \ 31 file://b2qt-startup.sh \
32 file://qtlauncher.service \
33 file://b2qt.service \
32 " 34 "
33 35
34SRCREV = "e824e206f28eb20bcb6f1d9064990f5e927261f4" 36SRCREV = "e824e206f28eb20bcb6f1d9064990f5e927261f4"
@@ -42,11 +44,15 @@ DEPENDS = "qtbase qtdeclarative \
42do_install_append() { 44do_install_append() {
43 install -m 0755 -d ${D}${sysconfdir}/init.d 45 install -m 0755 -d ${D}${sysconfdir}/init.d
44 install -m 0755 ${WORKDIR}/b2qt-startup.sh ${D}${sysconfdir}/init.d/ 46 install -m 0755 ${WORKDIR}/b2qt-startup.sh ${D}${sysconfdir}/init.d/
45}
46 47
47FILES_${PN} += "${sysdir}/init.d/b2qt-startup.h" 48 install -m 0755 -d ${D}${systemd_unitdir}/system
49 install -m 0644 ${WORKDIR}/qtlauncher.service ${D}${systemd_unitdir}/system/
50 install -m 0644 ${WORKDIR}/b2qt.service ${D}${systemd_unitdir}/system/
51}
48 52
49INITSCRIPT_NAME = "b2qt-startup.sh" 53INITSCRIPT_NAME = "b2qt-startup.sh"
50INITSCRIPT_PARAMS = "defaults 30" 54INITSCRIPT_PARAMS = "defaults 30"
51 55
52inherit update-rc.d 56SYSTEMD_SERVICE_${PN} = "qtlauncher.service b2qt.service"
57
58inherit update-rc.d systemd
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/b2qt.service b/recipes-qt/b2qt-addons/b2qt-launcher/b2qt.service
new file mode 100644
index 0000000..f941f91
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-launcher/b2qt.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=B2Qt user application
3After=systemd-user-sessions.service
4ConditionPathExists=/usr/bin/b2qt
5
6[Service]
7ExecStart=-/usr/bin/appcontroller /usr/bin/b2qt
8
9[Install]
10WantedBy=multi-user.target
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher/qtlauncher.service b/recipes-qt/b2qt-addons/b2qt-launcher/qtlauncher.service
new file mode 100644
index 0000000..7658ca8
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-launcher/qtlauncher.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=B2Qt Launcher Demo
3After=systemd-user-sessions.service
4ConditionPathExists=!/usr/bin/b2qt
5
6[Service]
7ExecStart=-/usr/bin/appcontroller /usr/bin/qtlauncher --applications-root /data/user/qt
8
9[Install]
10WantedBy=multi-user.target
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index c372755..e32311e 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -38,6 +38,7 @@ SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https;br
38 file://Makefile.adbd \ 38 file://Makefile.adbd \
39 file://adb-init \ 39 file://adb-init \
40 file://defaults \ 40 file://defaults \
41 file://adbd.service \
41 " 42 "
42 43
43S = "${WORKDIR}/git" 44S = "${WORKDIR}/git"
@@ -57,15 +58,21 @@ do_compile() {
57do_install() { 58do_install() {
58 install -m 0755 -d ${D}${bindir}/ 59 install -m 0755 -d ${D}${bindir}/
59 install -m 0755 ${WORKDIR}/git/adb/adbd ${D}${bindir}/ 60 install -m 0755 ${WORKDIR}/git/adb/adbd ${D}${bindir}/
61 install -m 0755 ${WORKDIR}/adb-init ${D}${bindir}/
60 62
61 install -m 0755 -d ${D}${sysconfdir}/init.d 63 install -m 0755 -d ${D}${sysconfdir}/init.d
62 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/ 64 ln -s ${bindir}/adb-init ${D}${sysconfdir}/init.d/
65
66 install -m 0755 -d ${D}${systemd_unitdir}/system
67 install -m 0644 ${WORKDIR}/adbd.service ${D}${systemd_unitdir}/system/
63 68
64 install -m 0755 -d ${D}${sysconfdir}/default 69 install -m 0755 -d ${D}${sysconfdir}/default
65 install -m 0755 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd 70 install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd
66} 71}
67 72
68INITSCRIPT_NAME = "adb-init" 73INITSCRIPT_NAME = "adb-init"
69INITSCRIPT_PARAMS = "defaults 96" 74INITSCRIPT_PARAMS = "defaults 96"
70 75
71inherit update-rc.d 76SYSTEMD_SERVICE_${PN} = "adbd.service"
77
78inherit update-rc.d systemd
diff --git a/recipes/adbd/files/adbd.service b/recipes/adbd/files/adbd.service
new file mode 100644
index 0000000..f8ee77d
--- /dev/null
+++ b/recipes/adbd/files/adbd.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=ADB Server Daemon
3After=network.target
4
5[Service]
6Type=forking
7ExecStart=/usr/bin/adb-init start
8ExecStop=/usr/bin/adb-init stop
9
10[Install]
11WantedBy=multi-user.target
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index 96931f1..acd8305 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -25,7 +25,7 @@ SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees."
25LICENSE = "LGPL-2.1" 25LICENSE = "LGPL-2.1"
26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
27 27
28inherit autotools pkgconfig 28inherit autotools pkgconfig systemd
29 29
30SRC_URI = " \ 30SRC_URI = " \
31 git://github.com/GNOME/ostree.git;tag=v2015.9 \ 31 git://github.com/GNOME/ostree.git;tag=v2015.9 \
@@ -36,6 +36,12 @@ S = "${WORKDIR}/git"
36 36
37DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz" 37DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
38 38
39PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
40PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
41
42SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
43FILES_${PN} += "${systemd_unitdir}/system/"
44
39EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no" 45EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no"
40 46
41do_configure_prepend() { 47do_configure_prepend() {
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
index 9aad8df..47b7716 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
@@ -41,7 +41,7 @@ RDEPENDS_${PN} += "\
41 ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-dev gstreamer1.0-plugins-base-dev", "", d)} \ 41 ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-dev gstreamer1.0-plugins-base-dev", "", d)} \
42 icu-dev \ 42 icu-dev \
43 libxslt-dev \ 43 libxslt-dev \
44 udev-dev \ 44 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-dev", "udev-dev", d)} \
45 tslib-dev \ 45 tslib-dev \
46 hunspell-dev \ 46 hunspell-dev \
47 libcap-dev \ 47 libcap-dev \
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index de36975..1af3a6b 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -35,4 +35,5 @@ RDEPENDS_${PN} = "\
35 htop \ 35 htop \
36 ntp \ 36 ntp \
37 connman-client \ 37 connman-client \
38 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \
38 " 39 "
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..be5517d
--- /dev/null
+++ b/recipes/systemd/systemd_%.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_install_append() {
24 # remove login from tty1
25 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
26}
diff --git a/recipes/virtualbox/mount-vboxsf/mount-vboxsf.service b/recipes/virtualbox/mount-vboxsf/mount-vboxsf.service
new file mode 100644
index 0000000..7c7211f
--- /dev/null
+++ b/recipes/virtualbox/mount-vboxsf/mount-vboxsf.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=QtSimulator Shared Mount Point
3After=systemd-user-sessions.service
4
5[Service]
6Type=oneshot
7RemainAfterExit=yes
8ExecStart=/usr/bin/mount-vboxsf.sh start
9ExecStop=/usr/bin/mount-vboxsf.sh stop
10
11[Install]
12WantedBy=multi-user.target
diff --git a/recipes/virtualbox/mount-vboxsf_4.3.30.bb b/recipes/virtualbox/mount-vboxsf_4.3.30.bb
index 171ba7e..e84e227 100644
--- a/recipes/virtualbox/mount-vboxsf_4.3.30.bb
+++ b/recipes/virtualbox/mount-vboxsf_4.3.30.bb
@@ -26,6 +26,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35
26 26
27SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2 \ 27SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2 \
28 file://mount-vboxsf.sh \ 28 file://mount-vboxsf.sh \
29 file://mount-vboxsf.service \
29 " 30 "
30 31
31SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd" 32SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd"
@@ -40,12 +41,18 @@ do_compile() {
40do_install() { 41do_install() {
41 install -m 0755 -d ${D}${bindir}/ 42 install -m 0755 -d ${D}${bindir}/
42 install -m 0755 mount.vboxsf ${D}${bindir}/ 43 install -m 0755 mount.vboxsf ${D}${bindir}/
44 install -m 0755 ${WORKDIR}/mount-vboxsf.sh ${D}${bindir}/
43 45
44 install -m 0755 -d ${D}${sysconfdir}/init.d 46 install -m 0755 -d ${D}${sysconfdir}/init.d
45 install -m 0755 ${WORKDIR}/mount-vboxsf.sh ${D}${sysconfdir}/init.d/ 47 ln -s ${bindir}/mount-vboxsf.sh ${D}${sysconfdir}/init.d/
48
49 install -m 0755 -d ${D}${systemd_unitdir}/system
50 install -m 0644 ${WORKDIR}/mount-vboxsf.service ${D}${systemd_unitdir}/system/
46} 51}
47 52
48INITSCRIPT_NAME = "mount-vboxsf.sh" 53INITSCRIPT_NAME = "mount-vboxsf.sh"
49INITSCRIPT_PARAMS = "defaults 33" 54INITSCRIPT_PARAMS = "defaults 33"
50 55
51inherit update-rc.d 56SYSTEMD_SERVICE_${PN} = "mount-vboxsf.service"
57
58inherit update-rc.d systemd