summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-01-26 14:31:26 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-01 11:41:11 +0000
commit6f87a493623e7ef70bd43f2eac235c36a455c5e5 (patch)
tree1549a1864d729f52d31ede77df6cc3b4c76bdd31
parent4cee85ecd6cf356f9cef28cf042065204ad5baff (diff)
downloadmeta-boot2qt-6f87a493623e7ef70bd43f2eac235c36a455c5e5.tar.gz
Move qt5 sdk creation bits to new bbclass
Change-Id: I6d00c21fa04e77db60c7c48ad6ba10eacad00b42 Reviewed-by: David Schulz <david.schulz@theqtcompany.com> Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--classes/populate_b2qt_qt5_sdk.bbclass (renamed from recipes-qt/meta/b2qt-sdk.inc)23
-rw-r--r--recipes-qt/meta/files/qmake.conf12
-rw-r--r--recipes-qt/meta/files/qplatformdefs.h2
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb5
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb5
5 files changed, 19 insertions, 28 deletions
diff --git a/recipes-qt/meta/b2qt-sdk.inc b/classes/populate_b2qt_qt5_sdk.bbclass
index 4a3a00b..78ad457 100644
--- a/recipes-qt/meta/b2qt-sdk.inc
+++ b/classes/populate_b2qt_qt5_sdk.bbclass
@@ -20,27 +20,26 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
25
26inherit populate_b2qt_sdk populate_sdk_qt5_base 23inherit populate_b2qt_sdk populate_sdk_qt5_base
27 24
28SRC_URI = " \
29 file://qmake.conf \
30 file://qplatformdefs.h \
31 "
32S = "${WORKDIR}"
33
34SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" 25SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs"
35SDK_MKSPEC = "devices/linux-oe-generic-g++" 26SDK_MKSPEC = "devices/linux-oe-generic-g++"
36SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" 27SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri"
37SDK_DYNAMIC_FLAGS = "-O. -pipe -g" 28SDK_DYNAMIC_FLAGS = "-O. -pipe -g"
38 29
39create_sdk_files_append () { 30create_sdk_files_append () {
40 # Install the toolchain user's generic device mkspec 31 # Create the toolchain user's generic device mkspec
41 install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} 32 install -d ${SDK_MKSPEC_DIR}/${SDK_MKSPEC}
42 install -m 0644 ${WORKDIR}/qmake.conf ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} 33 cat > ${SDK_MKSPEC_DIR}/${SDK_MKSPEC}/qmake.conf <<EOF
43 install -m 0644 ${WORKDIR}/qplatformdefs.h ${SDK_MKSPEC_DIR}/${SDK_MKSPEC} 34include(../common/linux_device_pre.conf)
35exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri)
36include(../common/linux_device_post.conf)
37load(qt_config)
38EOF
39
40 cat > ${SDK_MKSPEC_DIR}/${SDK_MKSPEC}/qplatformdefs.h <<EOF
41#include "../../linux-g++/qplatformdefs.h"
42EOF
44 43
45 # Fill in the qdevice.pri file which will be used by the device mksspec 44 # Fill in the qdevice.pri file which will be used by the device mksspec
46 static_cflags="${TARGET_CFLAGS}" 45 static_cflags="${TARGET_CFLAGS}"
diff --git a/recipes-qt/meta/files/qmake.conf b/recipes-qt/meta/files/qmake.conf
deleted file mode 100644
index b5962dc..0000000
--- a/recipes-qt/meta/files/qmake.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1#
2# qmake configuration for using yocto-built b2qt toolchain
3#
4
5include(../common/linux_device_pre.conf)
6
7# Load device-specific qmake.conf part, if any
8exists(../../oe-device-extra.pri):include(../../oe-device-extra.pri)
9
10include(../common/linux_device_post.conf)
11
12load(qt_config)
diff --git a/recipes-qt/meta/files/qplatformdefs.h b/recipes-qt/meta/files/qplatformdefs.h
deleted file mode 100644
index e10ebcf..0000000
--- a/recipes-qt/meta/files/qplatformdefs.h
+++ /dev/null
@@ -1,2 +0,0 @@
1
2#include "../../linux-g++/qplatformdefs.h"
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
index 6b95276..124adbe 100644
--- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
+++ b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
@@ -22,7 +22,10 @@
22 22
23DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" 23DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
24 24
25require b2qt-sdk.inc 25LICENSE = "QtEnterprise"
26LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
27
28inherit populate_b2qt_qt5_sdk
26 29
27TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" 30TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
28TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ 31TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
index 43f29b3..eb114cd 100644
--- a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
+++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
@@ -22,7 +22,10 @@
22 22
23DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain" 23DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
24 24
25require b2qt-sdk.inc 25LICENSE = "QtEnterprise"
26LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
27
28inherit populate_b2qt_qt5_sdk
26 29
27TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" 30TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
28TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target" 31TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target"