summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-08-11 10:46:41 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-08-11 08:58:47 +0000
commit8556798b4ec9e703deb398c09d88e68c2af4cd54 (patch)
treea51736056a6c6b0e999c3e99777aaaf58da00d27
parent8c13aef478448114a8fe0ac112e26b59d7ad03d4 (diff)
downloadmeta-boot2qt-8556798b4ec9e703deb398c09d88e68c2af4cd54.tar.gz
Remove all *.ci.local network addresses
The dot-local addresses cause problems with mDNS lookups, replace all with *.intra.qt.io aliases that are now available. Task-number: QTBUG-60153 Change-Id: I60e2e06440ca088d1194615849bf7792c16df362 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--classes/internal-build.bbclass26
-rw-r--r--recipes-qt/qt5-addons/installer-framework_2.0.3.bb2
-rwxr-xr-xscripts/upload.sh2
3 files changed, 15 insertions, 15 deletions
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass
index ecee863..0f12a78 100644
--- a/classes/internal-build.bbclass
+++ b/classes/internal-build.bbclass
@@ -30,24 +30,24 @@
30python enable_internal_build () { 30python enable_internal_build () {
31 import socket 31 import socket
32 try: 32 try:
33 socket.gethostbyname('yocto-cache.ci.local') 33 socket.gethostbyname('yocto-cache.intra.qt.io')
34 except: 34 except:
35 return 35 return
36 36
37 e.data.setVar('ENABLE_QTQUICKCOMPILER', "1") 37 e.data.setVar('ENABLE_QTQUICKCOMPILER', "1")
38 e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH") 38 e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.intra.qt.io/sstate-caches/${DISTRO_CODENAME}/PATH")
39 e.data.setVar('PREMIRRORS', "\ 39 e.data.setVar('PREMIRRORS', "\
40 ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ 40 ftp://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
41 http://.*/.* http://yocto-cache.ci.local/sources/ \n \ 41 http://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
42 https://.*/.* http://yocto-cache.ci.local/sources/ \n \ 42 https://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
43 bzr://.*/.* http://yocto-cache.ci.local/sources/ \n \ 43 bzr://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
44 cvs://.*/.* http://yocto-cache.ci.local/sources/ \n \ 44 cvs://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
45 git://.*/.* http://yocto-cache.ci.local/sources/ \n \ 45 git://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
46 gitsm://.*/.* http://yocto-cache.ci.local/sources/ \n \ 46 gitsm://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
47 hg://.*/.* http://yocto-cache.ci.local/sources/ \n \ 47 hg://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
48 osc://.*/.* http://yocto-cache.ci.local/sources/ \n \ 48 osc://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
49 p4://.*/.* http://yocto-cache.ci.local/sources/ \n \ 49 p4://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
50 svn://.*/.* http://yocto-cache.ci.local/sources/ \n \ 50 svn://.*/.* http://yocto-cache.intra.qt.io/sources/ \n \
51 ") 51 ")
52} 52}
53 53
diff --git a/recipes-qt/qt5-addons/installer-framework_2.0.3.bb b/recipes-qt/qt5-addons/installer-framework_2.0.3.bb
index 03cba46..0ea0ec4 100644
--- a/recipes-qt/qt5-addons/installer-framework_2.0.3.bb
+++ b/recipes-qt/qt5-addons/installer-framework_2.0.3.bb
@@ -33,7 +33,7 @@ LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33 33
34inherit bin_package native 34inherit bin_package native
35 35
36SRC_URI = "http://ci-files02-hki.ci.local/packages/jenkins/opensource/ifw/installer-framework/installer-framework-build-stripped-linux-x64.7z" 36SRC_URI = "http://ci-files02-hki.intra.qt.io/packages/jenkins/opensource/ifw/installer-framework/installer-framework-build-stripped-linux-x64.7z"
37 37
38SRC_URI[md5sum] = "08beb5450c3938fcfd1b380f6aaec75d" 38SRC_URI[md5sum] = "08beb5450c3938fcfd1b380f6aaec75d"
39SRC_URI[sha256sum] = "91bfef896db58f28e4c2c6db437b958101a59e87aa880c38b6ddc40ebe6c38e6" 39SRC_URI[sha256sum] = "91bfef896db58f28e4c2c6db437b958101a59e87aa880c38b6ddc40ebe6c38e6"
diff --git a/scripts/upload.sh b/scripts/upload.sh
index cb94719..4f4e1a8 100755
--- a/scripts/upload.sh
+++ b/scripts/upload.sh
@@ -32,7 +32,7 @@ set -x
32set -e 32set -e
33 33
34RELEASE=$(grep PV ../sources/meta-qt5/recipes-qt/qt5/qt5-git.inc | grep -o [0-9.]*) 34RELEASE=$(grep PV ../sources/meta-qt5/recipes-qt/qt5/qt5-git.inc | grep -o [0-9.]*)
35UPLOADPATH=QT@ci-files02-hki.ci.local:/srv/jenkins_data/enterprise/b2qt/yocto/${RELEASE}/ 35UPLOADPATH=QT@ci-files02-hki.intra.qt.io:/srv/jenkins_data/enterprise/b2qt/yocto/${RELEASE}/
36UPLOADS="\ 36UPLOADS="\
37 tmp/deploy/images/${MACHINE}/b2qt-${PROJECT}-qt5-image-${MACHINE}.7z \ 37 tmp/deploy/images/${MACHINE}/b2qt-${PROJECT}-qt5-image-${MACHINE}.7z \
38 tmp/deploy/sdk/b2qt-x86_64-meta-toolchain-b2qt-${PROJECT}-qt5-sdk-${MACHINE}.sh \ 38 tmp/deploy/sdk/b2qt-x86_64-meta-toolchain-b2qt-${PROJECT}-qt5-sdk-${MACHINE}.sh \