diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-06-07 14:31:54 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-19 09:49:08 +0000 |
commit | b5957b4d81a0dbe2c0c55e783d6ce0ee97f34fcd (patch) | |
tree | 76d666bd0137c779cbd583355fb5bcae3b13b2bc | |
parent | a753af07a43f4750cb403f5b35b59850e7081fe7 (diff) | |
download | meta-boot2qt-b5957b4d81a0dbe2c0c55e783d6ce0ee97f34fcd.tar.gz |
subversion: Add -P to CPPFLAGS
see https://gcc.gnu.org/gcc-5/porting_to.html
we need to stop the preprocessor from generating the #line directives
or we run into issues like
| checking for apr_int64_t Python/C API format string...
| configure: error: failed to recognize APR_INT64_T_FMT on this platform
| Configure failed. The contents of all config.log files follows to aid
debugging
| ERROR: oe_runconf failed
Rightly subversion should be fixed but lets leave that to subversion
folks
Taken from oe/fido, since this has not been applied in dizzy.
Task-number: QTBUG-53862
Change-Id: I107fbfd63ec8f61e6af94becb7bbecb8aafef0a8
Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
-rw-r--r-- | recipes/subversion/subversion_1.8.9.bbappend | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/subversion/subversion_1.8.9.bbappend b/recipes/subversion/subversion_1.8.9.bbappend new file mode 100644 index 0000000..adc5f26 --- /dev/null +++ b/recipes/subversion/subversion_1.8.9.bbappend | |||
@@ -0,0 +1,26 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | inherit pythonnative | ||
24 | |||
25 | CPPFLAGS += "-P" | ||
26 | BUILD_CPPFLAGS += "-P" | ||