diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-01-24 16:22:48 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-23 08:18:30 +0000 |
commit | d781ca1c5b9fdcfcf6b16493b933da8b049fe346 (patch) | |
tree | 8da9df904affc6526bb72143a88e66eee79ae21f | |
parent | 1671b84741ad5a4b4daacf48178841921d779c44 (diff) | |
download | meta-boot2qt-d781ca1c5b9fdcfcf6b16493b933da8b049fe346.tar.gz |
Add support for iMX8
Provides support for Toradex Apalis iMX8 and
NXP i.MX 8QMax LPDDR4 validation board.
Use Beta2 release from meta-fsl-bsp-release
Task-number: QTBUG-64714
Change-Id: I0d1edec66f7d64aaeda823c4d6bd675209ae787c
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
-rwxr-xr-x | b2qt-init-build-env | 3 | ||||
-rw-r--r-- | meta-boot2qt-distro/conf/bblayers.conf.fsl-imx8.sample | 55 | ||||
-rw-r--r-- | meta-boot2qt-distro/conf/distro/include/apalis-imx8.conf | 62 | ||||
-rw-r--r-- | meta-boot2qt-distro/conf/distro/include/imx8qmlpddr4arm2.conf | 67 | ||||
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx8/oe-device-extra.pri | 5 | ||||
-rw-r--r-- | scripts/manifest.xml | 10 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 3 |
7 files changed, 203 insertions, 2 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index cb57b61..5b2d630 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -106,6 +106,9 @@ get_groups() { | |||
106 | all) | 106 | all) |
107 | PROJECT_GROUPS="external" | 107 | PROJECT_GROUPS="external" |
108 | ;; | 108 | ;; |
109 | apalis-imx8|imx8qmlpddr4arm2) | ||
110 | PROJECT_GROUPS="fsl-imx8" | ||
111 | ;; | ||
109 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) | 112 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
110 | PROJECT_GROUPS="toradex" | 113 | PROJECT_GROUPS="toradex" |
111 | ;; | 114 | ;; |
diff --git a/meta-boot2qt-distro/conf/bblayers.conf.fsl-imx8.sample b/meta-boot2qt-distro/conf/bblayers.conf.fsl-imx8.sample new file mode 100644 index 0000000..504577d --- /dev/null +++ b/meta-boot2qt-distro/conf/bblayers.conf.fsl-imx8.sample | |||
@@ -0,0 +1,55 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf | ||
31 | # changes incompatibly | ||
32 | POKY_BBLAYERS_CONF_VERSION = "2" | ||
33 | |||
34 | BBPATH = "${TOPDIR}" | ||
35 | BBFILES ?= "" | ||
36 | BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}" | ||
37 | |||
38 | BBLAYERS ?= " \ | ||
39 | ${BSPDIR}/sources/poky/meta \ | ||
40 | ${BSPDIR}/sources/poky/meta-poky \ | ||
41 | ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-bsp \ | ||
42 | ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-sdk \ | ||
43 | ${BSPDIR}/sources/meta-freescale \ | ||
44 | ${BSPDIR}/sources/meta-freescale-3rdparty \ | ||
45 | ${BSPDIR}/sources/meta-openembedded/meta-oe \ | ||
46 | ${BSPDIR}/sources/meta-openembedded/meta-python \ | ||
47 | ${BSPDIR}/sources/meta-openembedded/meta-networking \ | ||
48 | ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ | ||
49 | ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ | ||
50 | ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \ | ||
51 | ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \ | ||
52 | ${BSPDIR}/sources/meta-boot2qt/meta-fsl-extras \ | ||
53 | ${BSPDIR}/sources/meta-mingw \ | ||
54 | ${BSPDIR}/sources/meta-qt5 \ | ||
55 | " | ||
diff --git a/meta-boot2qt-distro/conf/distro/include/apalis-imx8.conf b/meta-boot2qt-distro/conf/distro/include/apalis-imx8.conf new file mode 100644 index 0000000..d570e3a --- /dev/null +++ b/meta-boot2qt-distro/conf/distro/include/apalis-imx8.conf | |||
@@ -0,0 +1,62 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | include conf/distro/include/fsl.inc | ||
31 | |||
32 | DEPLOY_CONF_NAME = "Toradex Apalis iMX8" | ||
33 | |||
34 | SERIAL_CONSOLE = "115200 ttyLP1" | ||
35 | |||
36 | FSL_EULA_FILE := "${COREBASE}/../meta-fsl-bsp-release/imx/EULA.txt" | ||
37 | |||
38 | RDEPENDS_gstreamer1.0-meta-base_remove_pn-gstreamer1.0-meta-base = " gstreamer1.0-plugins-good-souphttpsrc" | ||
39 | RDEPENDS_gstreamer1.0-meta-base_append_pn-gstreamer1.0-meta-base = " gstreamer1.0-plugins-good-soup" | ||
40 | |||
41 | BBMASK += "\ | ||
42 | meta-fsl-bsp-release/imx/meta-bsp/recipes-browser \ | ||
43 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/bluez5 \ | ||
44 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/nfs-utils \ | ||
45 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/wpa-supplicant \ | ||
46 | meta-fsl-bsp-release/imx/meta-bsp/recipes-core/systemd/systemd_%.bbappend \ | ||
47 | meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/alsa/alsa-lib_%.bbappend \ | ||
48 | meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/pulseaudio \ | ||
49 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/fsl-rc-local \ | ||
50 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/images \ | ||
51 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup \ | ||
52 | meta-fsl-bsp-release/imx/meta-sdk/recipes-graphics/devil \ | ||
53 | meta-fsl-bsp-release/imx/meta-sdk/recipes-qt5/qt5 \ | ||
54 | meta-boot2qt/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend \ | ||
55 | meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend \ | ||
56 | meta-freescale/recipes-graphics/wayland/weston \ | ||
57 | " | ||
58 | |||
59 | KERNEL_MODULE_PACKAGE_SUFFIX ?= "-${@d.getVar('KERNEL_VERSION', True).replace('_','-')}" | ||
60 | EXTRA_OECONF_append_pn-gstreamer1.0-plugins-base = " --disable-introspection" | ||
61 | |||
62 | MACHINE_GSTREAMER_1_0_PLUGIN += "imx-gst1.0-plugin" | ||
diff --git a/meta-boot2qt-distro/conf/distro/include/imx8qmlpddr4arm2.conf b/meta-boot2qt-distro/conf/distro/include/imx8qmlpddr4arm2.conf new file mode 100644 index 0000000..9940d75 --- /dev/null +++ b/meta-boot2qt-distro/conf/distro/include/imx8qmlpddr4arm2.conf | |||
@@ -0,0 +1,67 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | include conf/distro/include/fsl.inc | ||
31 | |||
32 | DEPLOY_CONF_NAME = "NXP iMX8QM" | ||
33 | |||
34 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx" | ||
35 | |||
36 | FSL_EULA_FILE := "${COREBASE}/../meta-fsl-bsp-release/imx/EULA.txt" | ||
37 | |||
38 | RDEPENDS_gstreamer1.0-meta-base_remove_pn-gstreamer1.0-meta-base = " gstreamer1.0-plugins-good-souphttpsrc" | ||
39 | RDEPENDS_gstreamer1.0-meta-base_append_pn-gstreamer1.0-meta-base = " gstreamer1.0-plugins-good-soup" | ||
40 | |||
41 | BBMASK += "\ | ||
42 | meta-fsl-bsp-release/imx/meta-bsp/recipes-browser \ | ||
43 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/bluez5 \ | ||
44 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/nfs-utils \ | ||
45 | meta-fsl-bsp-release/imx/meta-bsp/recipes-connectivity/wpa-supplicant \ | ||
46 | meta-fsl-bsp-release/imx/meta-bsp/recipes-core/systemd/systemd_%.bbappend \ | ||
47 | meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/alsa/alsa-lib_%.bbappend \ | ||
48 | meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/pulseaudio \ | ||
49 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/fsl-rc-local \ | ||
50 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/images \ | ||
51 | meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup \ | ||
52 | meta-fsl-bsp-release/imx/meta-sdk/recipes-graphics/devil \ | ||
53 | meta-fsl-bsp-release/imx/meta-sdk/recipes-qt5/qt5 \ | ||
54 | meta-boot2qt/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend \ | ||
55 | meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend \ | ||
56 | meta-freescale/recipes-graphics/wayland/weston \ | ||
57 | " | ||
58 | |||
59 | SRC_URI_remove_pn-imx-boot = "\ | ||
60 | file://0001-add-board-support-for-DCD-memory-timings.patch \ | ||
61 | file://0002-add-memory-timings-for-Apalis-iMX8.patch \ | ||
62 | " | ||
63 | |||
64 | KERNEL_MODULE_PACKAGE_SUFFIX ?= "-${@d.getVar('KERNEL_VERSION', True).replace('_','-')}" | ||
65 | EXTRA_OECONF_append_pn-gstreamer1.0-plugins-base = " --disable-introspection" | ||
66 | |||
67 | MACHINE_GSTREAMER_1_0_PLUGIN += "imx-gst1.0-plugin" | ||
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx8/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx8/oe-device-extra.pri new file mode 100644 index 0000000..7e7cae3 --- /dev/null +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx8/oe-device-extra.pri | |||
@@ -0,0 +1,5 @@ | |||
1 | QMAKE_CFLAGS_EGL += -DLINUX -DEGL_API_FB | ||
2 | |||
3 | QMAKE_PLATFORM += boot2qt | ||
4 | QT_QPA_DEFAULT_PLATFORM = eglfs | ||
5 | EGLFS_DEVICE_INTEGRATION = eglfs_viv | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 9756906..00c7b01 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -14,6 +14,7 @@ | |||
14 | <remote fetch="git://git.linaro.org/openembedded" name="linaro"/> | 14 | <remote fetch="git://git.linaro.org/openembedded" name="linaro"/> |
15 | <remote fetch="git://git.toradex.com" name="toradex"/> | 15 | <remote fetch="git://git.toradex.com" name="toradex"/> |
16 | <remote fetch="git://github.com/boundarydevices" name="boundary"/> | 16 | <remote fetch="git://github.com/boundarydevices" name="boundary"/> |
17 | <remote fetch="git://github.com/toradex" name="toradex-github"/> | ||
17 | 18 | ||
18 | <project name="poky" | 19 | <project name="poky" |
19 | remote="yocto" | 20 | remote="yocto" |
@@ -36,12 +37,12 @@ | |||
36 | remote="freescale" | 37 | remote="freescale" |
37 | revision="06178400afbd641a6709473fd21d893dcd3cfbfa" | 38 | revision="06178400afbd641a6709473fd21d893dcd3cfbfa" |
38 | path="sources/meta-freescale" | 39 | path="sources/meta-freescale" |
39 | groups="notdefault,external,fsl,toradex,ti,smx6,renesas-gen3,boundary"/> | 40 | groups="notdefault,external,fsl,toradex,ti,smx6,renesas-gen3,boundary,fsl-imx8"/> |
40 | <project name="meta-freescale-3rdparty" | 41 | <project name="meta-freescale-3rdparty" |
41 | remote="freescale" | 42 | remote="freescale" |
42 | revision="9613dbc02ca970122a01c935bc9e5789ced73a9d" | 43 | revision="9613dbc02ca970122a01c935bc9e5789ced73a9d" |
43 | path="sources/meta-freescale-3rdparty" | 44 | path="sources/meta-freescale-3rdparty" |
44 | groups="notdefault,external,fsl,toradex,smx6,boundary"/> | 45 | groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/> |
45 | <project name="meta-ti" | 46 | <project name="meta-ti" |
46 | remote="yocto" | 47 | remote="yocto" |
47 | revision="aca8f5d6ff8a529e00bdeae5b401c791ed6ecb2b" | 48 | revision="aca8f5d6ff8a529e00bdeae5b401c791ed6ecb2b" |
@@ -87,6 +88,11 @@ | |||
87 | revision="42b00061076b2a6e15c1eeed7da6fc14a0dae9d8" | 88 | revision="42b00061076b2a6e15c1eeed7da6fc14a0dae9d8" |
88 | path="sources/meta-boundary" | 89 | path="sources/meta-boundary" |
89 | groups="notdefault,external,boundary"/> | 90 | groups="notdefault,external,boundary"/> |
91 | <project name="meta-fsl-bsp-release" | ||
92 | remote="toradex-github" | ||
93 | revision="d2b0d14c82da830584bc7f43ba1b83097c890454" | ||
94 | path="sources/meta-fsl-bsp-release" | ||
95 | groups="notdefault,external,fsl-imx8"/> | ||
90 | 96 | ||
91 | <project name="nvidia-layer" | 97 | <project name="nvidia-layer" |
92 | remote="playground" | 98 | remote="playground" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index f948ba0..3045e3c 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -56,6 +56,9 @@ BUILDDIRECTORY=${BUILDDIRECTORY:-build-${MACHINE}} | |||
56 | 56 | ||
57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | 57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then |
58 | case ${MACHINE} in | 58 | case ${MACHINE} in |
59 | apalis-imx8|imx8qmlpddr4arm2) | ||
60 | LAYERSCONF="bblayers.conf.fsl-imx8.sample" | ||
61 | ;; | ||
59 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) | 62 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
60 | LAYERSCONF="bblayers.conf.toradex.sample" | 63 | LAYERSCONF="bblayers.conf.toradex.sample" |
61 | ;; | 64 | ;; |