diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-05-30 15:37:13 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-06-05 05:24:22 +0000 |
commit | f140740aa76dbdbeed2c9e0f64f02d47123fb502 (patch) | |
tree | 3922c9e2ea72c53b04766329783ff6418987368f | |
parent | eba463b5c967e091f7e4cf2cbef901da6e5a322f (diff) | |
download | meta-boot2qt-f140740aa76dbdbeed2c9e0f64f02d47123fb502.tar.gz |
Update update-qt5-modules script handle qtlocation
QtLocation now has a submodule which needs special attention.
Change-Id: I570dbf0bab1416954f46a55430ad245fd1e9653c
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rwxr-xr-x | scripts/update-qt5-modules.sh | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh index 38260e6..e6d945f 100755 --- a/scripts/update-qt5-modules.sh +++ b/scripts/update-qt5-modules.sh | |||
@@ -47,6 +47,12 @@ for S in $SHA1S; do | |||
47 | elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then | 47 | elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then |
48 | sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* | 48 | sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* |
49 | echo "qtwebengine (chromium) -> ${SHA1}" | 49 | echo "qtwebengine (chromium) -> ${SHA1}" |
50 | elif [ "${PROJECT}" = "qtlocation" ]; then | ||
51 | sed -i -e "/^SRCREV_qtlocation/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* | ||
52 | echo "qtlocation -> ${SHA1}" | ||
53 | elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then | ||
54 | sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* | ||
55 | echo "qtlocation (mapboxgl) -> ${SHA1}" | ||
50 | elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then | 56 | elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then |
51 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb | 57 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb |
52 | echo "qtquickcompiler -> ${SHA1}" | 58 | echo "qtquickcompiler -> ${SHA1}" |