summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-07 15:54:40 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-08 10:41:27 +0000
commitf6084115b3117c3ba34059df7fea5ca3454610c1 (patch)
tree044d2b2e2d73dda6c983c943d9132835c14022df
parent7f3840f326405c28700a6eaf61fdb3fd2cfb06db (diff)
downloadmeta-boot2qt-f6084115b3117c3ba34059df7fea5ca3454610c1.tar.gz
webengine: Fix slow video with webengine on imx6 devices
Disable texture_rg on imx6 based devices. Yocto image 1.8 has driver, which reports opengl es 3.0 support, however texture_rg does not work properly. Change-Id: Iaeadbfb16bacd3d78d9c660fa02e761e1781b4f3 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch45
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bbappend6
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch b/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch
new file mode 100644
index 0000000..c6380f9
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch
@@ -0,0 +1,45 @@
1From 4903971e1e4b58f03b0f636a1ab494bfbc5d76d4 Mon Sep 17 00:00:00 2001
2From: Michal Klocek <michal.klocek@theqtcompany.com>
3Date: Mon, 7 Dec 2015 15:48:32 +0200
4Subject: [PATCH] Fix slow video with webengine on nitrogen6x
5
6Disable texture_rg on nitrogen6x. Yocto
7image 1.8 has driver which reports opengl es 3.0
8support, however texture_rg does not
9work properly.
10---
11 src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc | 18 ------------------
12 1 file changed, 18 deletions(-)
13
14diff --git a/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc b/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
15index 0ce9980..8963d11 100644
16--- a/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
17+++ b/src/3rdparty/chromium/gpu/command_buffer/service/feature_info.cc
18@@ -1014,24 +1014,6 @@ void FeatureInfo::InitializeFeatures() {
19 }
20 }
21
22- if ((gl_version_info_->is_es3 || gl_version_info_->is_desktop_core_profile ||
23- extensions.Contains("GL_EXT_texture_rg") ||
24- extensions.Contains("GL_ARB_texture_rg")) &&
25- IsGL_REDSupportedOnFBOs()) {
26- feature_flags_.ext_texture_rg = true;
27- AddExtensionString("GL_EXT_texture_rg");
28-
29- validators_.texture_format.AddValue(GL_RED_EXT);
30- validators_.texture_format.AddValue(GL_RG_EXT);
31- validators_.texture_internal_format.AddValue(GL_RED_EXT);
32- validators_.texture_internal_format.AddValue(GL_R8_EXT);
33- validators_.texture_internal_format.AddValue(GL_RG_EXT);
34- validators_.texture_internal_format.AddValue(GL_RG8_EXT);
35- validators_.read_pixel_format.AddValue(GL_RED_EXT);
36- validators_.read_pixel_format.AddValue(GL_RG_EXT);
37- validators_.render_buffer_format.AddValue(GL_R8_EXT);
38- validators_.render_buffer_format.AddValue(GL_RG8_EXT);
39- }
40 UMA_HISTOGRAM_BOOLEAN("GPU.TextureRG", feature_flags_.ext_texture_rg);
41
42 #if !defined(OS_MACOSX)
43--
441.9.1
45
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend
index 3fe90cd..824df6d 100644
--- a/recipes-qt/qt5/qtwebengine_git.bbappend
+++ b/recipes-qt/qt5/qtwebengine_git.bbappend
@@ -20,5 +20,11 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
24
25SRC_URI_append_mx6 = " \
26 file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \
27 "
28
23SRCREV_qtwebengine = "70a376d73718cc4ff8d96f6761b8c1896ca25c23" 29SRCREV_qtwebengine = "70a376d73718cc4ff8d96f6761b8c1896ca25c23"
24SRCREV_chromium = "ec5b3304fc266dfdec7666b8b73d57a3971ea35f" 30SRCREV_chromium = "ec5b3304fc266dfdec7666b8b73d57a3971ea35f"