summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
commit51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32 (patch)
treeb57ff35bf91a67fc0d6c3eb7831ed82f5f575c47 /classes
parent61d552148d797866ed33a9cd5e56477873cf801d (diff)
parente3ef984ac6f5926d7a910eff33bafeb5da6c2ff0 (diff)
downloadmeta-boot2qt-51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32.tar.gz
Merge remote-tracking branch 'origin/fido' into dev
* origin/fido: automotive: update src uris after repos were opened colibri-vf: change partition alignment to 1M Make ABI selection more robust in configure-qtcreator.sh Conflicts: recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/automotive/qtivi_git.bb Change-Id: I86763619f24b40e9ac62a8c1ae84acf4ffeb4be7
Diffstat (limited to 'classes')
-rw-r--r--classes/abi-arch.bbclass41
-rw-r--r--classes/populate_b2qt_qt5_sdk.bbclass4
2 files changed, 43 insertions, 2 deletions
diff --git a/classes/abi-arch.bbclass b/classes/abi-arch.bbclass
new file mode 100644
index 0000000..826fed4
--- /dev/null
+++ b/classes/abi-arch.bbclass
@@ -0,0 +1,41 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# map target architecture to abi architectures used by Qt Creator
23valid_archs = "arm x86 itanium mips ppc sh"
24
25def map_abi_arch(a, d):
26 import re
27
28 valid_archs = d.getVar('valid_archs', True).split()
29
30 if re.match('i.86$', a): return 'x86'
31 elif re.match('x86.64$', a): return 'x86'
32 elif re.match('armeb$', a): return 'arm'
33 elif re.match('aarch64', a): return 'arm'
34 elif re.match('mips(el|64|64el)$', a): return 'mips'
35 elif re.match('p(pc|owerpc)(|64)', a): return 'ppc'
36 elif re.match('sh(3|4)$', a): return 'sh'
37 elif a in valid_archs: return a
38 else:
39 bb.error("cannot map '%s' to a abi architecture" % a)
40
41ABI = "${@map_abi_arch(d.getVar('TARGET_ARCH', True), d)}"
diff --git a/classes/populate_b2qt_qt5_sdk.bbclass b/classes/populate_b2qt_qt5_sdk.bbclass
index d6b2b10..ae88685 100644
--- a/classes/populate_b2qt_qt5_sdk.bbclass
+++ b/classes/populate_b2qt_qt5_sdk.bbclass
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22inherit populate_b2qt_sdk populate_sdk_qt5_base 22inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo
23 23
24SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" 24SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs"
25SDK_MKSPEC = "devices/linux-oe-generic-g++" 25SDK_MKSPEC = "devices/linux-oe-generic-g++"
@@ -65,7 +65,7 @@ create_qtcreator_configure_script () {
65 # add qtcreator configuration script 65 # add qtcreator configuration script
66 install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH} 66 install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH}
67 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 67 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
68 sed -i -e '/^ABI=/c\ABI="${ARCH}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 68 sed -i -e '/^ABI=/c\ABI="${ABI}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
69} 69}
70 70
71create_qtcreator_configure_script_mingw32 () { 71create_qtcreator_configure_script_mingw32 () {