diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-02 13:08:39 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-12 14:12:31 +0000 |
commit | 344c2f97025c6504ec986600498121bb83aaeb8f (patch) | |
tree | 3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-connectivity | |
parent | d9985542d7617b43ec7180c7ade0c4f64db82b42 (diff) | |
download | meta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz |
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes
and bbclasses to meta-boot2qt layer. This makes it easier to include
meta-boot2qt to your own distro layer to get access e.g., QDB and
QBSP recipes that might be useful even without boot2qt distro.
Task-number: QTBUG-65871
Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6
Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-connectivity')
8 files changed, 280 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf.bbappend b/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf.bbappend new file mode 100644 index 0000000..06dc61d --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf.bbappend | |||
@@ -0,0 +1,42 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | |||
32 | CONNMAN_SETTINGS_DIR := "${localstatedir}/lib/connman" | ||
33 | |||
34 | FILES_${PN} += "${CONNMAN_SETTINGS_DIR}/settings" | ||
35 | |||
36 | SRC_URI += "file://settings \ | ||
37 | " | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}/${CONNMAN_SETTINGS_DIR} | ||
41 | install -m 0644 ${WORKDIR}/settings ${D}/${CONNMAN_SETTINGS_DIR}/settings | ||
42 | } | ||
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf/settings b/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf/settings new file mode 100644 index 0000000..edfedd4 --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/connman-conf/connman-conf/settings | |||
@@ -0,0 +1,5 @@ | |||
1 | [global] | ||
2 | OfflineMode=false | ||
3 | |||
4 | [Gadget] | ||
5 | Enable=true | ||
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend b/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend new file mode 100644 index 0000000..fda246a --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend | |||
@@ -0,0 +1,24 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
23 | |||
24 | SRC_URI += "file://0001-disable-connman-when-booting-over-nfs-${PV}.patch" | ||
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch new file mode 100644 index 0000000..f893746 --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | From df70770f33280a915abb413678088a078d82341a Mon Sep 17 00:00:00 2001 | ||
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | ||
3 | Date: Tue, 20 Sep 2016 11:02:50 +0300 | ||
4 | Subject: [PATCH] Disable connman when booting over NFS | ||
5 | |||
6 | --- | ||
7 | src/connman.service.in | 1 + | ||
8 | 1 file changed, 1 insertion(+) | ||
9 | |||
10 | diff --git a/src/connman.service.in b/src/connman.service.in | ||
11 | index 09dfec9..4132cf7 100644 | ||
12 | --- a/src/connman.service.in | ||
13 | +++ b/src/connman.service.in | ||
14 | @@ -6,6 +6,7 @@ RequiresMountsFor=@localstatedir@/lib/connman | ||
15 | After=dbus.service network-pre.target systemd-sysusers.service | ||
16 | Before=network.target multi-user.target shutdown.target | ||
17 | Wants=network.target | ||
18 | +ConditionKernelCommandLine=!root=/dev/nfs | ||
19 | |||
20 | [Service] | ||
21 | Type=dbus | ||
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch new file mode 100644 index 0000000..8b46666 --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- a/src/connman.service.in | ||
2 | +++ b/src/connman.service.in | ||
3 | @@ -7,6 +7,7 @@ | ||
4 | Before=network.target multi-user.target shutdown.target | ||
5 | Wants=network.target | ||
6 | Conflicts=systemd-resolved.service | ||
7 | +ConditionKernelCommandLine=!root=/dev/nfs | ||
8 | |||
9 | [Service] | ||
10 | Type=dbus | ||
11 | |||
diff --git a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch new file mode 100644 index 0000000..9aa9648 --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch | |||
@@ -0,0 +1,96 @@ | |||
1 | From 9cf8fa1c4dae07a6aff194a3632bc499a813d3f8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 9 Sep 2015 13:37:28 +0300 | ||
4 | Subject: [PATCH] Support SYSROOT in c_rehash | ||
5 | |||
6 | update-ca-certificates is ran during image creation, which in turn runs | ||
7 | c_rehash. Since the symlinks in /etc/ssl/certs/ are pointing to absolute | ||
8 | location, c_rehash does not find the actual files. Add support for SYSROOT | ||
9 | environment variable and use it to locate the actual files during image | ||
10 | creation. | ||
11 | |||
12 | Upstream-status: Pending | ||
13 | --- | ||
14 | tools/c_rehash.in | 30 +++++++++++++++++------------- | ||
15 | 1 file changed, 17 insertions(+), 13 deletions(-) | ||
16 | |||
17 | diff --git a/tools/c_rehash.in b/tools/c_rehash.in | ||
18 | index 92cb503..f3d2703 100644 | ||
19 | --- a/tools/c_rehash.in | ||
20 | +++ b/tools/c_rehash.in | ||
21 | @@ -7,6 +7,7 @@ my $dir; | ||
22 | my $prefix; | ||
23 | |||
24 | my $openssl = $ENV{OPENSSL} || "openssl"; | ||
25 | +my $sysroot = $ENV{SYSROOT} || ""; | ||
26 | my $pwd; | ||
27 | my $verbose = 0; | ||
28 | my $symlink_exists=eval {symlink("",""); 1}; | ||
29 | @@ -101,16 +102,17 @@ sub hash_dir { | ||
30 | } | ||
31 | } | ||
32 | FILE: foreach $fname (grep {/\.(pem)|(crt)|(cer)|(crl)$/} @flist) { | ||
33 | + $fullname = $sysroot . readlink($fname); | ||
34 | # Check to see if certificates and/or CRLs present. | ||
35 | - my ($cert, $crl) = check_file($fname); | ||
36 | + my ($cert, $crl) = check_file($fullname); | ||
37 | if(!$cert && !$crl) { | ||
38 | print STDERR "WARNING: $fname does not contain a certificate or CRL: skipping\n"; | ||
39 | next; | ||
40 | } | ||
41 | - link_hash_cert($fname) if($cert); | ||
42 | - link_hash_cert_old($fname) if($cert); | ||
43 | - link_hash_crl($fname) if($crl); | ||
44 | - link_hash_crl_old($fname) if($crl); | ||
45 | + link_hash_cert($fname, $fullname) if($cert); | ||
46 | + link_hash_cert_old($fname, $fullname) if($cert); | ||
47 | + link_hash_crl($fname, $fullname) if($crl); | ||
48 | + link_hash_crl_old($fname, $fullname) if($crl); | ||
49 | } | ||
50 | } | ||
51 | |||
52 | @@ -143,9 +145,10 @@ sub check_file { | ||
53 | |||
54 | sub link_hash_cert { | ||
55 | my $fname = $_[0]; | ||
56 | - my $x509hash = $_[1] || '-subject_hash'; | ||
57 | - $fname =~ s/'/'\\''/g; | ||
58 | - my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fname"`; | ||
59 | + my $fullname = $_[1]; | ||
60 | + my $x509hash = $_[2] || '-subject_hash'; | ||
61 | + $fullname =~ s/'/'\\''/g; | ||
62 | + my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fullname"`; | ||
63 | chomp $hash; | ||
64 | chomp $fprint; | ||
65 | $fprint =~ s/^.*=//; | ||
66 | @@ -176,11 +179,11 @@ sub link_hash_cert { | ||
67 | } | ||
68 | |||
69 | sub link_hash_cert_old { | ||
70 | - link_hash_cert($_[0], '-subject_hash_old'); | ||
71 | + link_hash_cert($_[0], $_[1], '-subject_hash_old'); | ||
72 | } | ||
73 | |||
74 | sub link_hash_crl_old { | ||
75 | - link_hash_crl($_[0], '-hash_old'); | ||
76 | + link_hash_crl($_[0], $_[1], '-hash_old'); | ||
77 | } | ||
78 | |||
79 | |||
80 | @@ -188,9 +191,10 @@ sub link_hash_crl_old { | ||
81 | |||
82 | sub link_hash_crl { | ||
83 | my $fname = $_[0]; | ||
84 | - my $crlhash = $_[1] || "-hash"; | ||
85 | - $fname =~ s/'/'\\''/g; | ||
86 | - my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fname'`; | ||
87 | + my $fullname = $_[1]; | ||
88 | + my $crlhash = $_[2] || "-hash"; | ||
89 | + $fullname =~ s/'/'\\''/g; | ||
90 | + my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fullname'`; | ||
91 | chomp $hash; | ||
92 | chomp $fprint; | ||
93 | $fprint =~ s/^.*=//; | ||
94 | -- | ||
95 | 1.9.1 | ||
96 | |||
diff --git a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend new file mode 100644 index 0000000..bac366d --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend | |||
@@ -0,0 +1,34 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += "file://0001-Support-SYSROOT-in-c_rehash.patch" | ||
32 | |||
33 | PACKAGECONFIG += "perl" | ||
34 | |||
diff --git a/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend b/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend new file mode 100644 index 0000000..e880897 --- /dev/null +++ b/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend | |||
@@ -0,0 +1,47 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_install_append () { | ||
31 | install -d ${D}${includedir}/wpa-supplicant | ||
32 | |||
33 | install -m 0644 ${S}/src/common/wpa_ctrl.c ${D}${includedir}/wpa-supplicant/ | ||
34 | install -m 0644 ${S}/src/common/wpa_ctrl.h ${D}${includedir}/wpa-supplicant/ | ||
35 | |||
36 | install -m 0644 ${S}/src/utils/build_config.h ${D}${includedir}/wpa-supplicant/ | ||
37 | install -m 0644 ${S}/src/utils/common.h ${D}${includedir}/wpa-supplicant/ | ||
38 | install -m 0644 ${S}/src/utils/includes.h ${D}${includedir}/wpa-supplicant/ | ||
39 | install -m 0644 ${S}/src/utils/os.h ${D}${includedir}/wpa-supplicant/ | ||
40 | install -m 0644 ${S}/src/utils/os_unix.c ${D}${includedir}/wpa-supplicant/ | ||
41 | install -m 0644 ${S}/src/utils/trace.h ${D}${includedir}/wpa-supplicant/ | ||
42 | install -m 0644 ${S}/src/utils/wpa_debug.h ${D}${includedir}/wpa-supplicant/ | ||
43 | install -m 0644 ${S}/src/utils/wpabuf.h ${D}${includedir}/wpa-supplicant/ | ||
44 | } | ||
45 | |||
46 | FILES_${PN}-dev += "${includedir}/wpa-supplicant/*" | ||
47 | |||