diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-09-26 10:49:27 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-09-28 08:57:58 +0000 |
commit | f17bc876f9db354c1b996d8b86187ba3404f01fd (patch) | |
tree | cbf9d6e98e6f10f3e9906661e6222e5dc758b695 /meta-boot2qt-distro/recipes-connectivity | |
parent | 1041d4df0e6f1610f2037c31051cda4d37e012e6 (diff) | |
download | meta-boot2qt-f17bc876f9db354c1b996d8b86187ba3404f01fd.tar.gz |
openssl: remove bbappend
patching is no longer needed
Change-Id: Ie56f2d6ee4b7807c9d3743bc03986104eeafdcd7
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-connectivity')
-rw-r--r-- | meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch | 96 | ||||
-rw-r--r-- | meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend | 34 |
2 files changed, 0 insertions, 130 deletions
diff --git a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch deleted file mode 100644 index 9aa9648..0000000 --- a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl/0001-Support-SYSROOT-in-c_rehash.patch +++ /dev/null | |||
@@ -1,96 +0,0 @@ | |||
1 | From 9cf8fa1c4dae07a6aff194a3632bc499a813d3f8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 9 Sep 2015 13:37:28 +0300 | ||
4 | Subject: [PATCH] Support SYSROOT in c_rehash | ||
5 | |||
6 | update-ca-certificates is ran during image creation, which in turn runs | ||
7 | c_rehash. Since the symlinks in /etc/ssl/certs/ are pointing to absolute | ||
8 | location, c_rehash does not find the actual files. Add support for SYSROOT | ||
9 | environment variable and use it to locate the actual files during image | ||
10 | creation. | ||
11 | |||
12 | Upstream-status: Pending | ||
13 | --- | ||
14 | tools/c_rehash.in | 30 +++++++++++++++++------------- | ||
15 | 1 file changed, 17 insertions(+), 13 deletions(-) | ||
16 | |||
17 | diff --git a/tools/c_rehash.in b/tools/c_rehash.in | ||
18 | index 92cb503..f3d2703 100644 | ||
19 | --- a/tools/c_rehash.in | ||
20 | +++ b/tools/c_rehash.in | ||
21 | @@ -7,6 +7,7 @@ my $dir; | ||
22 | my $prefix; | ||
23 | |||
24 | my $openssl = $ENV{OPENSSL} || "openssl"; | ||
25 | +my $sysroot = $ENV{SYSROOT} || ""; | ||
26 | my $pwd; | ||
27 | my $verbose = 0; | ||
28 | my $symlink_exists=eval {symlink("",""); 1}; | ||
29 | @@ -101,16 +102,17 @@ sub hash_dir { | ||
30 | } | ||
31 | } | ||
32 | FILE: foreach $fname (grep {/\.(pem)|(crt)|(cer)|(crl)$/} @flist) { | ||
33 | + $fullname = $sysroot . readlink($fname); | ||
34 | # Check to see if certificates and/or CRLs present. | ||
35 | - my ($cert, $crl) = check_file($fname); | ||
36 | + my ($cert, $crl) = check_file($fullname); | ||
37 | if(!$cert && !$crl) { | ||
38 | print STDERR "WARNING: $fname does not contain a certificate or CRL: skipping\n"; | ||
39 | next; | ||
40 | } | ||
41 | - link_hash_cert($fname) if($cert); | ||
42 | - link_hash_cert_old($fname) if($cert); | ||
43 | - link_hash_crl($fname) if($crl); | ||
44 | - link_hash_crl_old($fname) if($crl); | ||
45 | + link_hash_cert($fname, $fullname) if($cert); | ||
46 | + link_hash_cert_old($fname, $fullname) if($cert); | ||
47 | + link_hash_crl($fname, $fullname) if($crl); | ||
48 | + link_hash_crl_old($fname, $fullname) if($crl); | ||
49 | } | ||
50 | } | ||
51 | |||
52 | @@ -143,9 +145,10 @@ sub check_file { | ||
53 | |||
54 | sub link_hash_cert { | ||
55 | my $fname = $_[0]; | ||
56 | - my $x509hash = $_[1] || '-subject_hash'; | ||
57 | - $fname =~ s/'/'\\''/g; | ||
58 | - my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fname"`; | ||
59 | + my $fullname = $_[1]; | ||
60 | + my $x509hash = $_[2] || '-subject_hash'; | ||
61 | + $fullname =~ s/'/'\\''/g; | ||
62 | + my ($hash, $fprint) = `"$openssl" x509 $x509hash -fingerprint -noout -in "$fullname"`; | ||
63 | chomp $hash; | ||
64 | chomp $fprint; | ||
65 | $fprint =~ s/^.*=//; | ||
66 | @@ -176,11 +179,11 @@ sub link_hash_cert { | ||
67 | } | ||
68 | |||
69 | sub link_hash_cert_old { | ||
70 | - link_hash_cert($_[0], '-subject_hash_old'); | ||
71 | + link_hash_cert($_[0], $_[1], '-subject_hash_old'); | ||
72 | } | ||
73 | |||
74 | sub link_hash_crl_old { | ||
75 | - link_hash_crl($_[0], '-hash_old'); | ||
76 | + link_hash_crl($_[0], $_[1], '-hash_old'); | ||
77 | } | ||
78 | |||
79 | |||
80 | @@ -188,9 +191,10 @@ sub link_hash_crl_old { | ||
81 | |||
82 | sub link_hash_crl { | ||
83 | my $fname = $_[0]; | ||
84 | - my $crlhash = $_[1] || "-hash"; | ||
85 | - $fname =~ s/'/'\\''/g; | ||
86 | - my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fname'`; | ||
87 | + my $fullname = $_[1]; | ||
88 | + my $crlhash = $_[2] || "-hash"; | ||
89 | + $fullname =~ s/'/'\\''/g; | ||
90 | + my ($hash, $fprint) = `"$openssl" crl $crlhash -fingerprint -noout -in '$fullname'`; | ||
91 | chomp $hash; | ||
92 | chomp $fprint; | ||
93 | $fprint =~ s/^.*=//; | ||
94 | -- | ||
95 | 1.9.1 | ||
96 | |||
diff --git a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend b/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend deleted file mode 100644 index bac366d..0000000 --- a/meta-boot2qt-distro/recipes-connectivity/openssl/openssl_1.%.bbappend +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += "file://0001-Support-SYSROOT-in-c_rehash.patch" | ||
32 | |||
33 | PACKAGECONFIG += "perl" | ||
34 | |||