summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-devtools/python
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-devtools/python
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools/python')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend1
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb21
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend11
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend
new file mode 100644
index 0000000..9015f3f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend
@@ -0,0 +1 @@
SRC_URI_remove = "file://python-3.3-multilib.patch"
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb
new file mode 100644
index 0000000..cc091b8
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Virtual Python Environment builder"
2HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43"
6
7PV="15.1.0"
8SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz"
9
10SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716"
11SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/"
14UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/virtualenv-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20inherit setuptools3
21
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend
new file mode 100644
index 0000000..b3a5eb7
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend
@@ -0,0 +1,11 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}