diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-02 13:08:39 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-12 14:12:31 +0000 |
commit | 344c2f97025c6504ec986600498121bb83aaeb8f (patch) | |
tree | 3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-devtools/python | |
parent | d9985542d7617b43ec7180c7ade0c4f64db82b42 (diff) | |
download | meta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz |
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes
and bbclasses to meta-boot2qt layer. This makes it easier to include
meta-boot2qt to your own distro layer to get access e.g., QDB and
QBSP recipes that might be useful even without boot2qt distro.
Task-number: QTBUG-65871
Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6
Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools/python')
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend new file mode 100644 index 0000000..9015f3f --- /dev/null +++ b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend | |||
@@ -0,0 +1 @@ | |||
SRC_URI_remove = "file://python-3.3-multilib.patch" | |||
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb new file mode 100644 index 0000000..cc091b8 --- /dev/null +++ b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Virtual Python Environment builder" | ||
2 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43" | ||
6 | |||
7 | PV="15.1.0" | ||
8 | SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz" | ||
9 | |||
10 | SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716" | ||
11 | SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a" | ||
12 | |||
13 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/" | ||
14 | UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)" | ||
15 | |||
16 | S = "${WORKDIR}/virtualenv-${PV}" | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||
19 | |||
20 | inherit setuptools3 | ||
21 | |||
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend new file mode 100644 index 0000000..b3a5eb7 --- /dev/null +++ b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend | |||
@@ -0,0 +1,11 @@ | |||
1 | SRC_URI_remove = "file://python-3.3-multilib.patch" | ||
2 | |||
3 | # We need to install the python3 binary into the sysroot to let qtivi install that binary | ||
4 | # into the correct location. | ||
5 | # We can't install it directly into ${bindir} as this would be picked up by other recipes | ||
6 | # and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up | ||
7 | # This is a workaround and needs to be replaced by a proper solution discussed here: | ||
8 | # https://bugreports.qt.io/browse/AUTOSUITE-176 | ||
9 | sysroot_stage_all_append_class-nativesdk () { | ||
10 | sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5 | ||
11 | } | ||