summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-multimedia
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-multimedia
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-multimedia')
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch26
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base/fix-gstvolume.patch23
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base_0.10.%.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend31
7 files changed, 204 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch b/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch
new file mode 100644
index 0000000..2c0530e
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch
@@ -0,0 +1,26 @@
1From 804c0ca68e18a3e83ccbf49d0476fce3eb739477 Mon Sep 17 00:00:00 2001
2From: Kari Oikarinen <kari.oikarinen@qt.io>
3Date: Mon, 11 Dec 2017 13:55:27 +0200
4Subject: [PATCH] Increase default playback volume
5
6It is too quiet otherwise on Apalis iMX6.
7---
8 alsactl/init/default | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/alsactl/init/default b/alsactl/init/default
12index 1c84f3e..af41576 100644
13--- a/alsactl/init/default
14+++ b/alsactl/init/default
15@@ -12,7 +12,7 @@
16
17 ENV{ppercent}:="75%"
18 ENV{cpercent}:="75%"
19-ENV{pvolume}:="-20dB"
20+ENV{pvolume}:="5dB"
21 ENV{cvolume}:="12dB"
22 ENV{has_pmaster_vol}:="false"
23
24--
252.11.0
26
diff --git a/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend b/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend
new file mode 100644
index 0000000..ddb5c91
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI_append_apalis-imx6 = "file://0001-Increase-default-playback-volume.patch"
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend
new file mode 100644
index 0000000..f42e121
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_append = " faad"
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base/fix-gstvolume.patch b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base/fix-gstvolume.patch
new file mode 100644
index 0000000..d229e95
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base/fix-gstvolume.patch
@@ -0,0 +1,23 @@
1diff --git a/gst/volume/gstvolume.c b/gst/volume/gstvolume.c
2index 0f5b362..94d03a3 100644
3--- a/gst/volume/gstvolume.c
4+++ b/gst/volume/gstvolume.c
5@@ -314,10 +314,14 @@ volume_update_volume (GstVolume * self, gfloat volume,
6 self->current_mute = FALSE;
7 self->current_volume = volume;
8
9- self->current_vol_i8 = volume * VOLUME_UNITY_INT8;
10- self->current_vol_i16 = volume * VOLUME_UNITY_INT16;
11- self->current_vol_i24 = volume * VOLUME_UNITY_INT24;
12- self->current_vol_i32 = volume * VOLUME_UNITY_INT32;
13+ self->current_vol_i8 =
14+ (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT8);
15+ self->current_vol_i16 =
16+ (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT16);
17+ self->current_vol_i24 =
18+ (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT24);
19+ self->current_vol_i32 =
20+ (gint) ((gdouble) volume * (gdouble) VOLUME_UNITY_INT32);
21
22 passthrough = (self->current_vol_i16 == VOLUME_UNITY_INT16);
23 }
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base_0.10.%.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base_0.10.%.bbappend
new file mode 100644
index 0000000..646faa5
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gst-plugins-base_0.10.%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://fix-gstvolume.patch"
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 0000000..f42e121
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_append = " faad"
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
new file mode 100644
index 0000000..e338316
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_append = " x264"
31FILES_${PN}-x264 += "${datadir}/gstreamer-1.0/presets/*.prs"