diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2018-06-27 10:38:35 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2018-06-28 12:14:34 +0000 |
commit | 651adf5a48ebb74db1f93f6e00cc5f426a194bf9 (patch) | |
tree | 34fda0758f23655b5185023dc84d8eed0ba2328a /meta-boot2qt-distro/recipes-multimedia | |
parent | e794cd92f9f6cfe6334a55974f433de6ea743c15 (diff) | |
download | meta-boot2qt-651adf5a48ebb74db1f93f6e00cc5f426a194bf9.tar.gz |
meta-qt5: update layer
* Includes merged commits from upstream/master & new recipe for
Qt3DStudio runtime libraries
* gsteamer1.0-plugins-bad appends added to meta-boot2qt-distro specific
bbappend as plugins-bad was moved to plugins-good as upstream/master
is built against poky (sumo) and we're still at pyro branch.
* qtbase bbappend updated with new getentropy packageconfig.
Change-Id: I612040526fa73ba8866187c0f6931b2194444b9a
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-multimedia')
-rw-r--r-- | meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | 18 |
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend index f42e121..0271b6d 100644 --- a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend +++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -28,3 +28,19 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | PACKAGECONFIG_append = " faad" | 30 | PACKAGECONFIG_append = " faad" |
31 | |||
32 | inherit qmake5_paths | ||
33 | |||
34 | PACKAGECONFIG[qt5] = '--enable-qt \ | ||
35 | --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \ | ||
36 | --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \ | ||
37 | --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \ | ||
38 | ,--disable-qt,qtbase qtdeclarative qtbase-native' | ||
39 | |||
40 | # The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled | ||
41 | python() { | ||
42 | cur_packageconfig = d.getVar('PACKAGECONFIG',True).split() | ||
43 | if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)): | ||
44 | gl_packageconfig = d.getVar('PACKAGECONFIG_GL',True) | ||
45 | d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig) | ||
46 | } | ||