diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-10-22 15:51:00 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-10-24 08:23:05 +0000 |
commit | 4ee7fff912a0c2bef6a38ba561f9423ba9d2cc33 (patch) | |
tree | 712704a4112aa566093407cda07e511fa3f6aec1 /meta-boot2qt-distro/recipes-qt | |
parent | 7be5774920e168c2cfff9a25a068aa247a474b69 (diff) | |
download | meta-boot2qt-4ee7fff912a0c2bef6a38ba561f9423ba9d2cc33.tar.gz |
qtgamepad: add QtGamePad to the image
And build qt3d with the gamepad support enabled. QtGamePad depends
on libsdl2 which needs adjustment to build without x11.
Change-Id: I03e42136ab4d50d66b0d95f14ad8f21922e03477
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt')
3 files changed, 32 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb index c1d7f26..281d9b6 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb | |||
@@ -54,6 +54,7 @@ RDEPENDS_${PN} += " \ | |||
54 | qtdeclarative-dev \ | 54 | qtdeclarative-dev \ |
55 | qtdeclarative-staticdev \ | 55 | qtdeclarative-staticdev \ |
56 | qtdeviceutilities-dev \ | 56 | qtdeviceutilities-dev \ |
57 | qtgamepad-dev \ | ||
57 | qtgraphicaleffects-dev \ | 58 | qtgraphicaleffects-dev \ |
58 | qtimageformats-dev \ | 59 | qtimageformats-dev \ |
59 | qtlocation-dev \ | 60 | qtlocation-dev \ |
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb index 38bddaa..6b78a82 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb | |||
@@ -46,6 +46,7 @@ RDEPENDS_${PN} += " \ | |||
46 | qtdeclarative \ | 46 | qtdeclarative \ |
47 | qtdeclarative-tools \ | 47 | qtdeclarative-tools \ |
48 | qtdeviceutilities \ | 48 | qtdeviceutilities \ |
49 | qtgamepad \ | ||
49 | qtgraphicaleffects \ | 50 | qtgraphicaleffects \ |
50 | qtimageformats \ | 51 | qtimageformats \ |
51 | qtlocation \ | 52 | qtlocation \ |
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend new file mode 100644 index 0000000..d2906b9 --- /dev/null +++ b/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend | |||
@@ -0,0 +1,30 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | PACKAGECONFIG += "qtgamepad" | ||