diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-11-20 13:43:51 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-11-21 11:43:18 +0000 |
commit | c5a5bce25764de55420664b6896fd76ba5d18f45 (patch) | |
tree | 37946f9fcb4cf9dc9f09e0f693cb2b95a1c1f775 /meta-boot2qt-distro/recipes-qt | |
parent | 41105c273d58293be70f23d8e0ac24f41042d3f0 (diff) | |
download | meta-boot2qt-c5a5bce25764de55420664b6896fd76ba5d18f45.tar.gz |
Remove default expansion parameter from getVarv5.12.0-rc
getVar defaults to expanding the variable, the second True
parameter is unnecessary.
Change-Id: Iafaf179c67ffedaba2946c078c1810a80198cf5e
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt')
4 files changed, 10 insertions, 10 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb index 1afeb7e..8d63166 100644 --- a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb +++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb | |||
@@ -55,11 +55,11 @@ python remove_qt_from_rootfs() { | |||
55 | import subprocess | 55 | import subprocess |
56 | 56 | ||
57 | # remove qtbase and all dependent packages | 57 | # remove qtbase and all dependent packages |
58 | image_rootfs = d.getVar('IMAGE_ROOTFS', True) | 58 | image_rootfs = d.getVar('IMAGE_ROOTFS') |
59 | opkg_conf = d.getVar("IPKGCONF_TARGET", True) | 59 | opkg_conf = d.getVar("IPKGCONF_TARGET") |
60 | opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg") | 60 | opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg") |
61 | opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs) | 61 | opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs) |
62 | opkg_args += d.getVar("OPKG_ARGS", True) | 62 | opkg_args += d.getVar("OPKG_ARGS") |
63 | 63 | ||
64 | cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \ | 64 | cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \ |
65 | (opkg_cmd, opkg_args, 'qtbase') | 65 | (opkg_cmd, opkg_args, 'qtbase') |
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb index f115070..fe2ab16 100644 --- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb +++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | |||
@@ -38,11 +38,11 @@ S = "${WORKDIR}" | |||
38 | 38 | ||
39 | inherit qbsp | 39 | inherit qbsp |
40 | 40 | ||
41 | PV := "${@d.getVar('PV', True).split('+')[0]}" | 41 | PV := "${@d.getVar('PV').split('+')[0]}" |
42 | 42 | ||
43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" | 43 | VERSION_SHORT = "${@d.getVar('PV').replace('.','')}" |
44 | QBSP_NAME = "Automotive ${PV}" | 44 | QBSP_NAME = "Automotive ${PV}" |
45 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" | 45 | QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}" |
46 | QBSP_INSTALLER_COMPONENT = "automotive.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" | 46 | QBSP_INSTALLER_COMPONENT = "automotive.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" |
47 | QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" | 47 | QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" |
48 | 48 | ||
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb index a599e23..c85d3ba 100644 --- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb +++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | |||
@@ -38,11 +38,11 @@ S = "${WORKDIR}" | |||
38 | 38 | ||
39 | inherit qbsp | 39 | inherit qbsp |
40 | 40 | ||
41 | PV := "${@d.getVar('PV', True).split('+')[0]}" | 41 | PV := "${@d.getVar('PV').split('+')[0]}" |
42 | 42 | ||
43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" | 43 | VERSION_SHORT = "${@d.getVar('PV').replace('.','')}" |
44 | QBSP_NAME = "Boot2Qt ${PV}" | 44 | QBSP_NAME = "Boot2Qt ${PV}" |
45 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" | 45 | QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}" |
46 | QBSP_INSTALLER_COMPONENT = "embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" | 46 | QBSP_INSTALLER_COMPONENT = "embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" |
47 | QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" | 47 | QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" |
48 | 48 | ||
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb index 2adad90..79749fc 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb | |||
@@ -34,7 +34,7 @@ PR = "r0" | |||
34 | inherit nativesdk packagegroup | 34 | inherit nativesdk packagegroup |
35 | 35 | ||
36 | python __anonymous() { | 36 | python __anonymous() { |
37 | overrides = d.getVar("OVERRIDES", True).split(":") | 37 | overrides = d.getVar("OVERRIDES").split(":") |
38 | if "mingw32" not in overrides: | 38 | if "mingw32" not in overrides: |
39 | d.appendVar("OVERRIDES", ":linux") | 39 | d.appendVar("OVERRIDES", ":linux") |
40 | } | 40 | } |