summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-support
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-support
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-support')
-rw-r--r--meta-boot2qt-distro/recipes-support/rng-tools/rng-tools/rngd.service9
-rw-r--r--meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend45
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools/rngd.service b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools/rngd.service
new file mode 100644
index 0000000..22c7361
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools/rngd.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Hardware RNG Entropy Gatherer Daemon
3
4[Service]
5ExecStart=@SBINDIR@/rngd -f
6SuccessExitStatus=66
7
8[Install]
9WantedBy=multi-user.target
diff --git a/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend
new file mode 100644
index 0000000..dedddf0
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend
@@ -0,0 +1,45 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31SRC_URI += "\
32 file://rngd.service \
33 "
34
35inherit systemd
36
37do_install_append() {
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
39 install -d ${D}${systemd_unitdir}/system
40 install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system
41 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service
42 fi
43}
44
45SYSTEMD_SERVICE_${PN} = "rngd.service"