diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2018-10-10 13:32:48 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2018-10-14 16:30:13 +0000 |
commit | 3653d75c6f893a218f2444f9b4f71493c7f13d6c (patch) | |
tree | 06df678c879eaa0ab45e991374870b47f1b93671 /meta-boot2qt-distro/recipes-support | |
parent | 3f992f0e90f4b8150394d559ef4ff37a3d953e0b (diff) | |
download | meta-boot2qt-3653d75c6f893a218f2444f9b4f71493c7f13d6c.tar.gz |
rng-tools: update rng-tools .bbappend
poky(sumo) has now a systemd service file with appropriate installation
in recipe, but the rngd.service file itself is still broken using
/dev/urandom as a RNG_DEVICE. Update bbappend, leaving fixed
rngd.service file override in place.
poky commit where systemd service added:
b5fc88b3d35cc97c357ade91f0c9f376e3aed1cf rng-tools: add systemd service
file
init script (leaving systemd broken) was fixed in poky with commit:
b3b7ee4097b42b06f92127ca98663a96284ee185 rng-tools: Fix crazy defaults
Change-Id: I3330718543fd68dd9102d3f4ed3479c23d254321
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-support')
-rw-r--r-- | meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend | 19 |
1 files changed, 2 insertions, 17 deletions
diff --git a/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend index dedddf0..dba4af2 100644 --- a/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend +++ b/meta-boot2qt-distro/recipes-support/rng-tools/rng-tools_5.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2017 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,19 +27,4 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
31 | SRC_URI += "\ | ||
32 | file://rngd.service \ | ||
33 | " | ||
34 | |||
35 | inherit systemd | ||
36 | |||
37 | do_install_append() { | ||
38 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
39 | install -d ${D}${systemd_unitdir}/system | ||
40 | install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system | ||
41 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service | ||
42 | fi | ||
43 | } | ||
44 | |||
45 | SYSTEMD_SERVICE_${PN} = "rngd.service" | ||