diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-01 09:43:22 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-12 12:34:50 +0000 |
commit | ae2d6d14123d0eae08b04e9e31bdd129aff119e6 (patch) | |
tree | 644c68739a558794241095f79a92df1f0b9c4e00 /meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb | |
parent | adc61820f15efe4e57e9089372e55ad20aaf1efb (diff) | |
download | meta-boot2qt-ae2d6d14123d0eae08b04e9e31bdd129aff119e6.tar.gz |
toradex: stop using meta-toradex
All needed toradex recipes are now in meta-fsl-arm-extra
Change-Id: I3eedacd83845087d2369cf4d4b6df2a030d6d283
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb | 76 |
1 files changed, 76 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb new file mode 100644 index 0000000..bb209ad --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb | |||
@@ -0,0 +1,76 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
31 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
32 | DEPENDS = "u-boot-mkimage-native" | ||
33 | |||
34 | PV = "v2.3" | ||
35 | |||
36 | SRC_URI = " \ | ||
37 | file://flash_mmc.scr \ | ||
38 | file://flash_blk.scr \ | ||
39 | " | ||
40 | |||
41 | S = "${WORKDIR}" | ||
42 | |||
43 | inherit deploy | ||
44 | |||
45 | do_mkimage () { | ||
46 | uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ | ||
47 | -n "update script" -d ${WORKDIR}/flash_mmc.scr \ | ||
48 | flash_mmc.img | ||
49 | |||
50 | uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ | ||
51 | -n "update script" -d ${WORKDIR}/flash_blk.scr \ | ||
52 | flash_blk.img | ||
53 | } | ||
54 | |||
55 | addtask mkimage after do_compile before do_install | ||
56 | |||
57 | do_deploy () { | ||
58 | install -d ${DEPLOYDIR} | ||
59 | install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img | ||
60 | install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img | ||
61 | |||
62 | cd ${DEPLOYDIR} | ||
63 | rm -f flash_mmc-${MACHINE}.img | ||
64 | ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img | ||
65 | rm -f flash_blk-${MACHINE}.img | ||
66 | ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img | ||
67 | } | ||
68 | |||
69 | addtask deploy after do_install before do_build | ||
70 | |||
71 | do_compile[noexec] = "1" | ||
72 | do_install[noexec] = "1" | ||
73 | do_populate_sysroot[noexec] = "1" | ||
74 | |||
75 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
76 | COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6|colibri-imx7)" | ||