diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-10-23 13:37:58 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-10-24 08:23:18 +0000 |
commit | 2b21f641158e70ba0b77482ef11eb0ad8ea01bc6 (patch) | |
tree | d0a8acfc5b0d9fa2aff947f97f40c5bd81e57202 /meta-fsl-extras/recipes/u-boot | |
parent | 4ee7fff912a0c2bef6a38ba561f9423ba9d2cc33 (diff) | |
download | meta-boot2qt-2b21f641158e70ba0b77482ef11eb0ad8ea01bc6.tar.gz |
imx7s-warp: bring back kernel with display supportv5.12.0-beta3
Add old kernel recipe from meta-freescale-3rdparty layer that was
removed in sumo branch. It provides support for the display and the
touchscreen. Fix perf build with old kernel sources and use correct
appcontroller.conf after MACHINEOVERRIDES was changed in the machine
config.
Task-number: QTBUG-68899
Change-Id: I6d2cd70951f86a99a8878915ce1bfc598dc95ee0
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch | 22 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend | 1 |
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch new file mode 100644 index 0000000..2c1c70d --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | From d9489c704107e85a0c3ba68211adbca695c88644 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Wed, 13 Sep 2017 09:40:44 +0300 | ||
4 | Subject: [PATCH] use imx7d-warp.dtb | ||
5 | |||
6 | --- | ||
7 | include/configs/warp7.h | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/include/configs/warp7.h b/include/configs/warp7.h | ||
11 | index 2a7789baa2..7b44f85a87 100644 | ||
12 | --- a/include/configs/warp7.h | ||
13 | +++ b/include/configs/warp7.h | ||
14 | @@ -39,7 +39,7 @@ | ||
15 | "ethact=usb_ether\0" \ | ||
16 | "fdt_high=0xffffffff\0" \ | ||
17 | "initrd_high=0xffffffff\0" \ | ||
18 | - "fdt_file=imx7s-warp.dtb\0" \ | ||
19 | + "fdt_file=imx7d-warp.dtb\0" \ | ||
20 | "fdt_addr=" __stringify(CONFIG_SYS_FDT_ADDR)"\0" \ | ||
21 | "optee_addr=" __stringify(CONFIG_OPTEE_LOAD_ADDR)"\0" \ | ||
22 | "boot_fdt=try\0" \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend index f17045d..815244f 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend | |||
@@ -30,4 +30,5 @@ | |||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Updated-kernel-arguments-for-sabre-sd.patch \ | 32 | file://0001-Updated-kernel-arguments-for-sabre-sd.patch \ |
33 | file://0001-use-imx7d-warp.dtb.patch \ | ||
33 | " | 34 | " |