diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-08-07 13:50:26 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-08-19 09:50:23 +0000 |
commit | 304d492506a62cd7a24dbed39f822f442fbe6230 (patch) | |
tree | 0d5330bb9d34e819d436244ae9ca5f7c6e87bf9e /meta-fsl-extras/recipes/u-boot | |
parent | 96ce38cc04b4f8b61751794ce96701631aeb98e4 (diff) | |
download | meta-boot2qt-304d492506a62cd7a24dbed39f822f442fbe6230.tar.gz |
u-boot-fslc: upstream version has been updated
New u-boot version has better handling for video args, so our
patch got simpler.
Change-Id: I90958167d1ff10bca46123915491a5136dfa5fc9
Reviewed-by: aavit <eirik.aavitsland@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch | 58 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-fslc_2015.%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-fslc_2014.%.bbappend) | 0 |
2 files changed, 8 insertions, 50 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch index d6e1e21..928fb8c 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch | |||
@@ -1,68 +1,26 @@ | |||
1 | From ecd64c7926b7aa25b028278666abad582e7cdea8 Mon Sep 17 00:00:00 2001 | 1 | From 15ba0d8f9e2ad8f3024734810088e4caddaaec5a Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@digia.com> | 2 | From: Samuli Piippo <samuli.piippo@digia.com> |
3 | Date: Fri, 9 May 2014 10:23:50 +0300 | 3 | Date: Fri, 9 May 2014 10:23:50 +0300 |
4 | Subject: [PATCH] Updated kernel arguments for sabre sd | 4 | Subject: [PATCH] Updated kernel arguments for sabre sd |
5 | 5 | ||
6 | - detect if hdmi is used and change video arguments accordingly | ||
7 | - disable blanking and cursor blinking | 6 | - disable blanking and cursor blinking |
8 | --- | 7 | --- |
9 | include/configs/mx6sabre_common.h | 21 +++++++++++++++++++++ | 8 | include/configs/mx6sabre_common.h | 2 ++ |
10 | 1 file changed, 21 insertions(+) | 9 | 1 file changed, 2 insertions(+) |
11 | 10 | ||
12 | diff --git a/include/configs/mx6sabre_common.h b/include/configs/mx6sabre_common.h | 11 | diff --git a/include/configs/mx6sabre_common.h b/include/configs/mx6sabre_common.h |
13 | index c81e9e9..9296b9b 100644 | 12 | index a8746a4..251b28b 100644 |
14 | --- a/include/configs/mx6sabre_common.h | 13 | --- a/include/configs/mx6sabre_common.h |
15 | +++ b/include/configs/mx6sabre_common.h | 14 | +++ b/include/configs/mx6sabre_common.h |
16 | @@ -87,6 +87,13 @@ | 15 | @@ -171,6 +171,8 @@ |
17 | /* Command definition */ | 16 | "done\0" \ |
18 | #include <config_cmd_default.h> | ||
19 | |||
20 | +/* I2C Configs */ | ||
21 | +#define CONFIG_CMD_I2C | ||
22 | +#define CONFIG_SYS_I2C | ||
23 | +#define CONFIG_SYS_I2C_MXC | ||
24 | +#define CONFIG_SYS_I2C_SPEED 100000 | ||
25 | +#define CONFIG_I2C_EDID | ||
26 | + | ||
27 | #define CONFIG_CMD_BMODE | ||
28 | #define CONFIG_CMD_BOOTZ | ||
29 | #define CONFIG_CMD_SETEXPR | ||
30 | @@ -119,6 +126,15 @@ | ||
31 | #define EMMC_ENV "" | ||
32 | #endif | ||
33 | |||
34 | +#define VIDEOARGS \ | ||
35 | + "videoargs=" \ | ||
36 | + "i2c dev 1 ; " \ | ||
37 | + "if i2c probe 0x50 ; then " \ | ||
38 | + "setenv video mxcfb0:dev=hdmi,1280x720M@60,if=RGB24 ; " \ | ||
39 | + "else " \ | ||
40 | + "setenv video mxcfb0:dev=ldb,LDB-XGA,if=RGB666 ldb=sin1 ; " \ | ||
41 | + "fi\0" | ||
42 | + | ||
43 | #define CONFIG_EXTRA_ENV_SETTINGS \ | ||
44 | "script=boot.scr\0" \ | ||
45 | "image=zImage\0" \ | ||
46 | @@ -146,7 +162,11 @@ | ||
47 | "fi; " \ | ||
48 | "fi\0" \ | ||
49 | EMMC_ENV \ | ||
50 | + VIDEOARGS \ | ||
51 | "mmcargs=setenv bootargs console=${console},${baudrate} " \ | 17 | "mmcargs=setenv bootargs console=${console},${baudrate} " \ |
52 | + "video=${video} "\ | 18 | "root=${mmcroot} " \ |
53 | + "consoleblank=0 " \ | 19 | + "consoleblank=0 " \ |
54 | + "vt.global_cursor_default=0 " \ | 20 | + "vt.global_cursor_default=0 " \ |
55 | "root=${mmcroot}\0" \ | 21 | VIDEO_ARGS "\0" \ |
56 | "loadbootscript=" \ | 22 | "loadbootscript=" \ |
57 | "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \ | 23 | "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \ |
58 | @@ -155,6 +175,7 @@ | ||
59 | "loadimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}\0" \ | ||
60 | "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \ | ||
61 | "mmcboot=echo Booting from mmc ...; " \ | ||
62 | + "run videoargs; " \ | ||
63 | "run mmcargs; " \ | ||
64 | "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \ | ||
65 | "if run loadfdt; then " \ | ||
66 | -- | 24 | -- |
67 | 1.9.1 | 25 | 1.9.1 |
68 | 26 | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2014.%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2015.%.bbappend index a1a3b27..a1a3b27 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2014.%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_2015.%.bbappend | |||