diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2018-09-26 10:43:26 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-09-28 08:57:46 +0000 |
commit | aa863717a1e24a3c08a94726e95493780ccff1f3 (patch) | |
tree | 51ba08637efc4f99b0caeede3032c10ce6db6aa0 /meta-fsl-extras/recipes/u-boot | |
parent | 168f62cc6d06b205a3ddcb941570103e7910e14d (diff) | |
download | meta-boot2qt-aa863717a1e24a3c08a94726e95493780ccff1f3.tar.gz |
poky: update to 2.5 branch (sumo)
Update yocto from 2.3.4 (pyro) to 2.5.1 (sumo):
- Update poky, meta-openembedded & meta-mingw to sumo branch
- update image classes (obsolete IMAGE_DEPENDS definitions)
- Update bbappends under meta-boot2qt-distro
- Update meta-*-extras layers bbappends & patches
All recipes related to nitrogen6x are fixed here, but this depends
on follow up commits to work correctly.
Task-number: QTBUG-68681
Change-Id: Ic5802c5c1a3989bed746f96f8cf173743ec755bb
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch | 45 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch | 8 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch | 36 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend) | 5 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch | 13 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend (renamed from meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend) | 2 |
6 files changed, 71 insertions, 38 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch index 0343f06..123782e 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch | |||
@@ -1,23 +1,23 @@ | |||
1 | From 554d219b3485402c6992abc0aa32c74e8f251876 Mon Sep 17 00:00:00 2001 | 1 | From 07234c1c0f991a560010672a619740e385778f90 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | 2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> |
3 | Date: Thu, 11 Feb 2016 10:17:51 +0200 | 3 | Date: Thu, 11 Feb 2016 10:17:51 +0200 |
4 | Subject: [PATCH] Add support for KOE tx31d200vm0baa display | 4 | Subject: [PATCH] Add support for KOE tx31d200vm0baa display |
5 | 5 | ||
6 | Used for the cluster demo | 6 | Used for the cluster demo |
7 | --- | 7 | --- |
8 | arch/arm/include/asm/imx-common/fbpanel.h | 27 +++++++++++++++++++++++++++ | 8 | arch/arm/include/asm/imx-common/fbpanel.h | 27 ++++++++++++++++++++ |
9 | board/boundary/nitrogen6_max/nitrogen6_max.c | 1 + | 9 | board/boundary/nitrogen6_max/nitrogen6_max.c | 1 + |
10 | board/boundary/nitrogen6sx/nitrogen6sx.c | 1 + | 10 | board/boundary/nitrogen6sx/nitrogen6sx.c | 1 + |
11 | board/boundary/nitrogen6x/nitrogen6x.c | 1 + | 11 | board/boundary/nitrogen6x/nitrogen6x.c | 1 + |
12 | 4 files changed, 30 insertions(+) | 12 | 4 files changed, 30 insertions(+) |
13 | 13 | ||
14 | diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h | 14 | diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h |
15 | index b6f7af4..b8acdae 100644 | 15 | index f5465c3c80..643cd86e29 100644 |
16 | --- a/arch/arm/include/asm/imx-common/fbpanel.h | 16 | --- a/arch/arm/include/asm/imx-common/fbpanel.h |
17 | +++ b/arch/arm/include/asm/imx-common/fbpanel.h | 17 | +++ b/arch/arm/include/asm/imx-common/fbpanel.h |
18 | @@ -39,6 +39,33 @@ void fbp_enable_fb(struct display_info_t const *di, int enable); | 18 | @@ -116,6 +116,33 @@ void fbp_setup_display(const struct display_info_t *displays, int cnt); |
19 | int fbp_detect_i2c(struct display_info_t const *di); | 19 | .fbtype = FB_##_mode,\ |
20 | void fbp_setup_display(const struct display_info_t *displays, int cnt); | 20 | .fbflags = _flags |
21 | 21 | ||
22 | +/* tx31d200vm0baa == koe */ | 22 | +/* tx31d200vm0baa == koe */ |
23 | +#define IMX_VD_KOE(_mode, _detect, _bus) \ | 23 | +#define IMX_VD_KOE(_mode, _detect, _bus) \ |
@@ -47,44 +47,41 @@ index b6f7af4..b8acdae 100644 | |||
47 | +} | 47 | +} |
48 | + | 48 | + |
49 | /* hdmi settings */ | 49 | /* hdmi settings */ |
50 | #define IMX_VD50_1280_720M_60(_mode, _detect, _bus) \ | 50 | #define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \ |
51 | {\ | 51 | {\ |
52 | diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c | 52 | diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c |
53 | index 337e9b5..ba29aee 100644 | 53 | index 1c4106e735..51bc0bd8f3 100644 |
54 | --- a/board/boundary/nitrogen6_max/nitrogen6_max.c | 54 | --- a/board/boundary/nitrogen6_max/nitrogen6_max.c |
55 | +++ b/board/boundary/nitrogen6_max/nitrogen6_max.c | 55 | +++ b/board/boundary/nitrogen6_max/nitrogen6_max.c |
56 | @@ -568,6 +568,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) | 56 | @@ -497,6 +497,7 @@ int fbp_detect_serializer(struct display_info_t const *di) |
57 | } | 57 | } |
58 | 58 | ||
59 | static const struct display_info_t displays[] = { | 59 | static const struct display_info_t displays[] = { |
60 | + IMX_VD_KOE(LVDS, 0, 2), | 60 | + IMX_VD_KOE(LVDS, 0, 2), |
61 | /* hdmi */ | 61 | /* hdmi */ |
62 | IMX_VD50_1280_720M_60(HDMI, 1, 1), | 62 | VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50), |
63 | IMX_VD50_1920_1080M_60(HDMI, 0, 1), | 63 | VD_1920_1080M_60(HDMI, NULL, 1, 0x50), |
64 | diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c | 64 | diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c |
65 | index cdabcd8..de6582e 100644 | 65 | index dc05042add..3725d63cf3 100644 |
66 | --- a/board/boundary/nitrogen6sx/nitrogen6sx.c | 66 | --- a/board/boundary/nitrogen6sx/nitrogen6sx.c |
67 | +++ b/board/boundary/nitrogen6sx/nitrogen6sx.c | 67 | +++ b/board/boundary/nitrogen6sx/nitrogen6sx.c |
68 | @@ -685,6 +685,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) | 68 | @@ -436,6 +436,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) |
69 | 69 | } | |
70 | 70 | ||
71 | static const struct display_info_t displays[] = { | 71 | static const struct display_info_t displays[] = { |
72 | + IMX_VD_KOE(LVDS, 0, 2), | 72 | + IMX_VD_KOE(LVDS, 0, 2), |
73 | /* hdmi/lcd */ | 73 | /* hdmi/lcd via tfp410 */ |
74 | _IMX_VD_1280_720M_60(LCD, 1, 2, 50, 0), | 74 | VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50), |
75 | _IMX_VD_1920_1080M_60(LCD, 0, 2, 50, 0), | 75 | VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50), |
76 | diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c | 76 | diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c |
77 | index 21d6cd7..b24f2f6 100644 | 77 | index d9f6a829f1..80b102e206 100644 |
78 | --- a/board/boundary/nitrogen6x/nitrogen6x.c | 78 | --- a/board/boundary/nitrogen6x/nitrogen6x.c |
79 | +++ b/board/boundary/nitrogen6x/nitrogen6x.c | 79 | +++ b/board/boundary/nitrogen6x/nitrogen6x.c |
80 | @@ -525,6 +525,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable) | 80 | @@ -359,6 +359,7 @@ void board_pre_enable(const struct display_info_t *di) |
81 | } | 81 | } |
82 | 82 | ||
83 | static const struct display_info_t displays[] = { | 83 | static const struct display_info_t displays[] = { |
84 | + IMX_VD_KOE(LVDS, 0, 2), | 84 | + IMX_VD_KOE(LVDS, 0, 2), |
85 | /* hdmi */ | 85 | /* hdmi */ |
86 | IMX_VD50_1280_720M_60(HDMI, 1, 1), | 86 | VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50), |
87 | IMX_VD50_1920_1080M_60(HDMI, 0, 1), | 87 | VD_1920_1080M_60(HDMI, NULL, 1, 0x50), |
88 | -- | ||
89 | 1.9.1 | ||
90 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch index 9eda199..b0791e9 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 59d272d9df5337bb4bd62a96fc16c8e280c49344 Mon Sep 17 00:00:00 2001 | 1 | From fa2e83db63fe5abdfa00d205301d12e1a271a291 Mon Sep 17 00:00:00 2001 |
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | 2 | From: Mikko Gronoff <mikko.gronoff@qt.io> |
3 | Date: Sun, 23 Apr 2017 21:47:01 +0300 | 3 | Date: Sun, 23 Apr 2017 21:47:01 +0300 |
4 | Subject: [PATCH] set CMA reserved size to 384MB | 4 | Subject: [PATCH] set CMA reserved size to 384MB |
@@ -10,12 +10,12 @@ video decoding cannot work for high resolution videos. | |||
10 | 1 file changed, 1 insertion(+) | 10 | 1 file changed, 1 insertion(+) |
11 | 11 | ||
12 | diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h | 12 | diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h |
13 | index 646c505..ddbb4c5 100644 | 13 | index bd4e54cb67..48114d5739 100644 |
14 | --- a/include/configs/nitrogen6x.h | 14 | --- a/include/configs/nitrogen6x.h |
15 | +++ b/include/configs/nitrogen6x.h | 15 | +++ b/include/configs/nitrogen6x.h |
16 | @@ -28,6 +28,7 @@ | 16 | @@ -33,6 +33,7 @@ |
17 | #define CONFIG_USB_MAX_CONTROLLER_COUNT 2 | 17 | #define CONFIG_USB_MAX_CONTROLLER_COUNT 2 |
18 | #define CONFIG_VIDEO | 18 | |
19 | #define BD_I2C_MASK 7 | 19 | #define BD_I2C_MASK 7 |
20 | +#define BD_CMA "384M" | 20 | +#define BD_CMA "384M" |
21 | 21 | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch new file mode 100644 index 0000000..c5fa923 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 22c5a278b98cf6ea4e4a402bca19d1354ab3c431 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Tue, 25 Sep 2018 16:05:17 +0300 | ||
4 | Subject: [PATCH] Disable build for tools and use mkimage from sysroot | ||
5 | |||
6 | fails when trying to compile with host gcc: unable to execute | ||
7 | 'x86_64-linux-gnu-gcc': No such file or directory | ||
8 | --- | ||
9 | Makefile | 2 +- | ||
10 | scripts/Makefile.lib | 2 +- | ||
11 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/Makefile b/Makefile | ||
14 | index 119ad49eec..022690e26e 100644 | ||
15 | --- a/Makefile | ||
16 | +++ b/Makefile | ||
17 | @@ -698,7 +698,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/) | ||
18 | |||
19 | libs-y := $(sort $(libs-y)) | ||
20 | |||
21 | -u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y))) tools examples | ||
22 | +u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y))) | ||
23 | |||
24 | u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-)))) | ||
25 | |||
26 | diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib | ||
27 | index 80ddb08474..e86c949f08 100644 | ||
28 | --- a/scripts/Makefile.lib | ||
29 | +++ b/scripts/Makefile.lib | ||
30 | @@ -493,5 +493,5 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \ | ||
31 | # --------------------------------------------------------------------------- | ||
32 | MKIMAGEOUTPUT ?= /dev/null | ||
33 | quiet_cmd_mkimage = MKIMAGE $@ | ||
34 | -cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \ | ||
35 | +cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \ | ||
36 | $(if $(KBUILD_VERBOSE:1=), >$(MKIMAGEOUTPUT)) | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend index 013e54b..3b5235f 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -31,4 +31,7 @@ FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | |||
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ | 32 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ |
33 | file://0002-set-CMA-reserved-size-to-384MB.patch \ | 33 | file://0002-set-CMA-reserved-size-to-384MB.patch \ |
34 | file://0003-Disable-build-for-tools.patch \ | ||
34 | " | 35 | " |
36 | |||
37 | DEPENDS += "u-boot-mkimage-native" | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch index 7d8e8ec..02a1e33 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 3fdf74d6934858d04d9e7df7cd24779bf7d9fdbb Mon Sep 17 00:00:00 2001 | 1 | From 3c3c3284727076f4ae751bfc9cadb222423c9a4b Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | 2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> |
3 | Date: Wed, 13 Jan 2016 08:55:41 +0200 | 3 | Date: Wed, 13 Jan 2016 08:55:41 +0200 |
4 | Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display | 4 | Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display |
@@ -8,12 +8,12 @@ Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display | |||
8 | 1 file changed, 6 insertions(+) | 8 | 1 file changed, 6 insertions(+) |
9 | 9 | ||
10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt |
11 | index 7c11f4c..86242b5 100644 | 11 | index f6bf2f5..427d837 100644 |
12 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 12 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt |
13 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 13 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt |
14 | @@ -105,6 +105,12 @@ else | 14 | @@ -130,6 +130,12 @@ if itest.s "x" != "x${disable_msi}" ; then |
15 | setenv bootargs "${bootargs} root=/dev/mmcblk${disk}p${bpart}" | 15 | setenv bootargs ${bootargs} pci=nomsi |
16 | fi | 16 | fi; |
17 | 17 | ||
18 | +if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then | 18 | +if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then |
19 | + setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600 | 19 | + setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600 |
@@ -24,6 +24,3 @@ index 7c11f4c..86242b5 100644 | |||
24 | if itest.s "x" != "x${disable_giga}" ; then | 24 | if itest.s "x" != "x${disable_giga}" ; then |
25 | setenv bootargs ${bootargs} fec.disable_giga=1 | 25 | setenv bootargs ${bootargs} fec.disable_giga=1 |
26 | fi | 26 | fi |
27 | -- | ||
28 | 1.9.1 | ||
29 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend index dafcf84..e4b3730 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2018 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |