diff options
author | Rainer Keller <Rainer.Keller@qt.io> | 2016-05-06 14:09:38 +0200 |
---|---|---|
committer | Rainer Keller <Rainer.Keller@qt.io> | 2016-05-09 09:01:45 +0000 |
commit | e9768164d0328b2eeac5cadd89719df2a4a10928 (patch) | |
tree | 9f8f7a73bbda3abf731b7719d5f7783d05e5e672 /meta-fsl-extras/recipes/u-boot | |
parent | 00026e5b464499e7cc93425150c9f9060791c3a0 (diff) | |
download | meta-boot2qt-e9768164d0328b2eeac5cadd89719df2a4a10928.tar.gz |
Add recovery support to u-boot
Change-Id: I9abe77d04569171cbcadf82e437e23de14322551
Reviewed-by: Gatis Paeglis <gatis.paeglis@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch | 37 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend | 1 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch new file mode 100644 index 0000000..d1f5616 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 33a5a73cd846c0bbf6a507aa4e658c74815eb1d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Rainer Keller <Rainer.Keller@qt.io> | ||
3 | Date: Wed, 4 May 2016 12:49:40 +0200 | ||
4 | Subject: [PATCH] Add recovery support | ||
5 | |||
6 | --- | ||
7 | include/configs/nitrogen6x.h | 7 +++++++ | ||
8 | 1 file changed, 7 insertions(+) | ||
9 | |||
10 | diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h | ||
11 | index bbc613d..9c939e6 100644 | ||
12 | --- a/include/configs/nitrogen6x.h | ||
13 | +++ b/include/configs/nitrogen6x.h | ||
14 | @@ -232,6 +232,11 @@ | ||
15 | "clearenv=if sf probe || sf probe || sf probe 1 ; then " \ | ||
16 | "sf erase 0xc0000 0x2000 && " \ | ||
17 | "echo restored environment to factory default ; fi\0" \ | ||
18 | + "recovery_boot=setenv recovery true ; dtype=mmc ; setenv bootpart 3 ; " \ | ||
19 | + "for disk in 0 1 ; do " \ | ||
20 | + "${dtype} dev ${disk} ; " \ | ||
21 | + "load ${dtype} ${disk}:${bootpart} 10008000 /6x_bootscript && source 10008000 ; " \ | ||
22 | + "done\0" \ | ||
23 | "bootcmd=for dtype in ${bootdevs}" \ | ||
24 | "; do " \ | ||
25 | "if itest.s \"xusb\" == \"x${dtype}\" ; then " \ | ||
26 | @@ -245,6 +250,8 @@ | ||
27 | "&& source 10008000 ; " \ | ||
28 | "done ; " \ | ||
29 | "done; " \ | ||
30 | + "echo Startup failed, running recovery ; " \ | ||
31 | + "run recovery_boot ; " \ | ||
32 | "setenv stdout serial,vga ; " \ | ||
33 | "echo ; echo 6x_bootscript not found ; " \ | ||
34 | "echo ; echo serial console at 115200, 8N1 ; echo ; " \ | ||
35 | -- | ||
36 | 2.7.3 | ||
37 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend index 7487f7d..a012358 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend | |||
@@ -22,4 +22,5 @@ | |||
22 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 22 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
23 | SRC_URI += " \ | 23 | SRC_URI += " \ |
24 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ | 24 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ |
25 | file://0002-Add-recovery-support.patch \ | ||
25 | " | 26 | " |