diff options
author | Yoann Lopes <yoann.lopes@theqtcompany.com> | 2015-06-10 16:29:42 +0200 |
---|---|---|
committer | Eirik Aavitsland <eirik.aavitsland@theqtcompany.com> | 2015-06-19 09:22:28 +0300 |
commit | eb2eb7ce5d43d623d7d4ff1bd7a584feafc38fe8 (patch) | |
tree | 7e9eaacc1412343eb579dda712335725b602a525 /meta-fsl-extras/recipes/u-boot | |
parent | 0cf281fdd678ea57b34bd9c7e5c48dc421d290ae (diff) | |
download | meta-boot2qt-eb2eb7ce5d43d623d7d4ff1bd7a584feafc38fe8.tar.gz |
Increase CMA reserved size on nitrogen6x.
Increased from 256MB (the default) to 384MB. Without this,
HW-accelerated video decoding cannot work for high resolution
videos.
The same might have to be done on other iMX devices.
Change-Id: I202ee246d59ded0343a93b6bdf221bd69fcd22c5
Reviewed-by: Laszlo Agocs <laszlo.agocs@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch (renamed from meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch) | 10 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | 2 |
2 files changed, 7 insertions, 5 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch index d97921c..f42b213 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch | |||
@@ -1,8 +1,10 @@ | |||
1 | From b21614109fb3cca15c4b0d296b3ab6cc1b778e3a Mon Sep 17 00:00:00 2001 | 1 | From b21614109fb3cca15c4b0d296b3ab6cc1b778e3a Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@digia.com> | 2 | From: Yoann Lopes <yoann.lopes@theqtcompany.com> |
3 | Date: Fri, 10 Jan 2014 12:37:20 +0200 | 3 | Date: Wed, 10 Jun 2015 16:36:10 +0100 |
4 | Subject: [PATCH] nitrogen6x: disable console cursor blinking | 4 | Subject: [PATCH] nitrogen6x: update bootargs. |
5 | 5 | ||
6 | - disable console cursor blinking | ||
7 | - set CMA reserved size to 384MB | ||
6 | --- | 8 | --- |
7 | board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 2 +- | 9 | board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 2 +- |
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | 10 | 1 file changed, 1 insertion(+), 1 deletion(-) |
@@ -16,7 +18,7 @@ index d933fa0..2d7c575 100644 | |||
16 | 18 | ||
17 | setenv bootargs $bootargs $fbmem | 19 | setenv bootargs $bootargs $fbmem |
18 | -setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait" | 20 | -setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait" |
19 | +setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 rootwait" | 21 | +setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 cma=384M rootwait" |
20 | 22 | ||
21 | if itest.s x$bootpart == x ; then | 23 | if itest.s x$bootpart == x ; then |
22 | bootpart=1 | 24 | bootpart=1 |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend index 1a0fe52..abbc222 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | |||
@@ -22,6 +22,6 @@ | |||
22 | 22 | ||
23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
24 | SRC_URI += " \ | 24 | SRC_URI += " \ |
25 | file://0001-nitrogen6x-disable-console-cursor-blinking.patch \ | 25 | file://0001-nitrogen6x-update-bootargs.patch \ |
26 | file://0002-nitrogen6x-update.patch \ | 26 | file://0002-nitrogen6x-update.patch \ |
27 | " | 27 | " |