diff options
author | Sami Nurmenniemi <sami.nurmenniemi@qt.io> | 2017-09-18 13:36:27 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-09-18 13:37:50 +0000 |
commit | 425889c267fa79ed371b83bcb1ebb94463c7e9d7 (patch) | |
tree | 98319ef8bc1201c22a5b192fec43797be654079b /meta-fsl-extras/recipes | |
parent | 9ebf006c612686a367aa626c23d08f4963f70784 (diff) | |
download | meta-boot2qt-425889c267fa79ed371b83bcb1ebb94463c7e9d7.tar.gz |
Fix /dev/hwrng on Warp7 devices
Task-number: QTBUG-63188
Change-Id: Ib22ec4894deaf0db955a8446037f4a3057b5c218
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras/recipes')
-rw-r--r-- | meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch | 25 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend | 5 |
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch b/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch new file mode 100644 index 0000000..dbb7995 --- /dev/null +++ b/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 9ffa222dbaa3b11c3b1399192e0abd478fc3b564 Mon Sep 17 00:00:00 2001 | ||
2 | From: Sami Nurmenniemi <sami.nurmenniemi@qt.io> | ||
3 | Date: Mon, 18 Sep 2017 12:45:54 +0300 | ||
4 | Subject: [PATCH 1/1] Fix /dev/hwrng by enabling warp7 crypto-device | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/imx7d-warp.dts | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/imx7d-warp.dts b/arch/arm/boot/dts/imx7d-warp.dts | ||
11 | index ee72690..19aee0e 100755 | ||
12 | --- a/arch/arm/boot/dts/imx7d-warp.dts | ||
13 | +++ b/arch/arm/boot/dts/imx7d-warp.dts | ||
14 | @@ -181,7 +181,7 @@ | ||
15 | }; | ||
16 | |||
17 | &crypto { | ||
18 | - status = "disabled"; | ||
19 | + status = "okay"; | ||
20 | }; | ||
21 | |||
22 | &clks { | ||
23 | -- | ||
24 | 2.7.4 | ||
25 | |||
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend index 534af39..72db716 100644 --- a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend | |||
@@ -31,6 +31,11 @@ SRCBRANCH = "linux_4.1.29" | |||
31 | SRCREV = "881845d84e3c2e58a00b9c36616203d748b7df0e" | 31 | SRCREV = "881845d84e3c2e58a00b9c36616203d748b7df0e" |
32 | LOCALVERSION = "-warp7" | 32 | LOCALVERSION = "-warp7" |
33 | 33 | ||
34 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
35 | SRC_URI += " \ | ||
36 | file://0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch \ | ||
37 | " | ||
38 | |||
34 | do_configure_prepend() { | 39 | do_configure_prepend() { |
35 | echo "CONFIG_NAMESPACES=y" >> ${B}/.config | 40 | echo "CONFIG_NAMESPACES=y" >> ${B}/.config |
36 | echo "CONFIG_FHANDLE=y" >> ${B}/.config | 41 | echo "CONFIG_FHANDLE=y" >> ${B}/.config |