diff options
author | Eirik Aavitsland <eirik.aavitsland@theqtcompany.com> | 2015-05-13 15:44:02 +0200 |
---|---|---|
committer | Eirik Aavitsland <eirik.aavitsland@theqtcompany.com> | 2015-05-28 14:13:39 +0300 |
commit | e8067960ac419c9a47824fa996283d31faa9c309 (patch) | |
tree | 2527ba7b8be52be88a2e45dd785100156a1930e5 /meta-fsl-extras | |
parent | 10c6c4ef744ca122f976be1d4f68713cafc01730 (diff) | |
download | meta-boot2qt-e8067960ac419c9a47824fa996283d31faa9c309.tar.gz |
Toolchain: add static device mkspec, suitable for Qt Creator
The linux-oe-g++ mkspec used by meta-qt5 depends on the user sourcing
the toolchain environment-setup script, which modifies the PATH and
sets a long range of environment variables. That is not a "best
practice" way of use Qt, and does not allow smooth integration of the
toolchain into Qt Creator.
Here, we instead create a static mkspec for the toolchain:
devices/linux-oe-generic-g++. The toolchain recipe will will the
qdevice.pri file with the required compiler flags etc. for the target.
Additionally, we introduce an extra .pri file for device-specific
settings, so they can be shared between the two mkspecs.
Change-Id: Ie5a019524ba6cdddffb71b0c7c28861ddba17fbd
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r-- | meta-fsl-extras/recipes/qt5/qtbase_%.bbappend | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend b/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend deleted file mode 100644 index 11fbab1..0000000 --- a/meta-fsl-extras/recipes/qt5/qtbase_%.bbappend +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | do_configure_prepend_mx6() { | ||
24 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | ||
25 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
26 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | ||
27 | QMAKE_LIBS_EGL += -lEGL | ||
28 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL | ||
29 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL | ||
30 | QMAKE_CFLAGS += \$\$IMX6_CFLAGS | ||
31 | QMAKE_CXXFLAGS += \$\$IMX6_CFLAGS | ||
32 | |||
33 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/../devices/linux-imx6-g++/qeglfshooks_imx6.cpp | ||
34 | |||
35 | load(qt_config) | ||
36 | |||
37 | EOF | ||
38 | } | ||