diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-03-16 09:27:00 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-04-08 12:51:37 +0000 |
commit | 2f745904ddf909956d325594d99840891735556b (patch) | |
tree | ddbc3ce72247e2c09738d7c71ba2aed16f0f12a3 /meta-intel-extras/recipes | |
parent | 9a46c8174a1814a628b63b795b31cf4e181b72a3 (diff) | |
download | meta-boot2qt-2f745904ddf909956d325594d99840891735556b.tar.gz |
NUC: use the common intel-corei7-64 BSP
meta-intel no longer has specific BSPs for each machine, but they
share a common BSP based on the architecture.
Change-Id: Ibbb7b8b2153103367168ea37d904ce23bc245108
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-intel-extras/recipes')
5 files changed, 106 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/grub/grub-efi/grub.cfg b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg new file mode 100644 index 0000000..ca53537 --- /dev/null +++ b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg | |||
@@ -0,0 +1,10 @@ | |||
1 | # Created by meta-b2qt | ||
2 | serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1 | ||
3 | default=boot | ||
4 | timeout=10 | ||
5 | |||
6 | menuentry 'boot' { | ||
7 | linux /boot/bzImage root=LABEL=rootfs | ||
8 | initrd /boot/initramfs | ||
9 | } | ||
10 | |||
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend new file mode 100644 index 0000000..d002240 --- /dev/null +++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
23 | SRC_URI += "file://grub.cfg" | ||
24 | |||
25 | do_deploy_prepend() { | ||
26 | |||
27 | cat > ${WORKDIR}/cfg <<EOF | ||
28 | search.file /boot/grub2/grub.cfg root | ||
29 | set prefix=/boot/grub2 | ||
30 | EOF | ||
31 | } | ||
32 | |||
33 | do_install_append() { | ||
34 | |||
35 | install -d ${D}/boot/grub2/ | ||
36 | install -m 644 ${WORKDIR}/grub.cfg ${D}/boot/grub2/ | ||
37 | } | ||
38 | |||
39 | PACKAGES += "${PN}-config" | ||
40 | FILES_${PN}-config = "/boot/grub2/" | ||
diff --git a/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg new file mode 100644 index 0000000..65ac248 --- /dev/null +++ b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg | |||
@@ -0,0 +1,9 @@ | |||
1 | CONFIG_RTLWIFI=m | ||
2 | CONFIG_RTLWIFI_DEBUG=n | ||
3 | CONFIG_RTL8723AE=m | ||
4 | CONFIG_RTL8192SE=m | ||
5 | CONFIG_RTL8192DE=m | ||
6 | CONFIG_RTL8192CU=m | ||
7 | CONFIG_RTL8192CE=m | ||
8 | CONFIG_RTL8192C_COMMON=m | ||
9 | CONFIG_RTL8188EE=m | ||
diff --git a/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend new file mode 100644 index 0000000..55ac1a2 --- /dev/null +++ b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend | |||
@@ -0,0 +1,25 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
23 | SRC_URI += "\ | ||
24 | file://wlan-realtek.cfg \ | ||
25 | " | ||
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend new file mode 100644 index 0000000..2346521 --- /dev/null +++ b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend | |||
@@ -0,0 +1,22 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | PACKAGECONFIG += "kms" | ||