diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-02-21 14:47:41 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-02-21 13:54:06 +0000 |
commit | 4db78b54773e07e8ac919033fd3dae6e13dc5673 (patch) | |
tree | b2a4e6a04a89674fc25c03a9fc3397cacc35dae2 /meta-intel-extras/recipes | |
parent | 0a77aaa46dce2bdd5be51d2de110eb11217ea1ec (diff) | |
download | meta-boot2qt-4db78b54773e07e8ac919033fd3dae6e13dc5673.tar.gz |
intel: update mesa to 17.0.2
Use recipes from pyro branch to update mesa to 17.0.2, which
has support for the Intel NUCs with Kaby Lake.
Task-number: QTAUTO-798
Change-Id: Ia2402c9acc57f1286b85d4e8eb53b17de7222d01
Reviewed-by: Nikolay Zamotaev <nzamotaev@luxoft.com>
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-intel-extras/recipes')
4 files changed, 110 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch new file mode 100644 index 0000000..e49695b --- /dev/null +++ b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 2f68fcaaf4964e7feeb383f5c26851965cda037c Mon Sep 17 00:00:00 2001 | ||
2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
3 | Date: Tue, 15 Nov 2016 15:20:49 +0200 | ||
4 | Subject: [PATCH] Simplify wayland-scanner lookup | ||
5 | |||
6 | Don't use pkg-config to lookup the path of a binary that's in the path. | ||
7 | |||
8 | Alternatively we'd have to prefix the path returned by pkg-config with | ||
9 | PKG_CONFIG_SYSROOT_DIR. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
13 | --- | ||
14 | configure.ac | 7 +------ | ||
15 | 1 file changed, 1 insertion(+), 6 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index e56e35a..a92005a 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -2020,12 +2020,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then | ||
22 | AC_MSG_ERROR([cannot build egl state tracker without EGL library]) | ||
23 | fi | ||
24 | |||
25 | -PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner], | ||
26 | - WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`, | ||
27 | - WAYLAND_SCANNER='') | ||
28 | -if test "x$WAYLAND_SCANNER" = x; then | ||
29 | - AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner]) | ||
30 | -fi | ||
31 | +AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner]) | ||
32 | |||
33 | # Do per-EGL platform setups and checks | ||
34 | egl_platforms=`IFS=', '; echo $with_egl_platforms` | ||
35 | -- | ||
36 | 2.1.4 | ||
37 | |||
diff --git a/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch new file mode 100644 index 0000000..d2d6755 --- /dev/null +++ b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | Configure checks for compiler to be gcc and then it enables asm_offsets | ||
2 | generation. see | ||
3 | |||
4 | https://cgit.freedesktop.org/mesa/mesa/commit/?id=73c9b4b0e05fc66629ba250846948dc55c0e7a0d | ||
5 | |||
6 | However, we missed the check when enabling this on cross compilation | ||
7 | when architecture for both host and target is x86 | ||
8 | |||
9 | Fixes errors like | ||
10 | ./gen_matypes > matypes.h | ||
11 | /bin/bash: ./gen_matypes: No such file or directory | ||
12 | |||
13 | -Khem | ||
14 | |||
15 | Upstream-Status: Submitted | ||
16 | |||
17 | Index: mesa-12.0.1/configure.ac | ||
18 | =================================================================== | ||
19 | --- mesa-12.0.1.orig/configure.ac | ||
20 | +++ mesa-12.0.1/configure.ac | ||
21 | @@ -732,7 +732,7 @@ test "x$enable_asm" = xno && AC_MSG_RESU | ||
22 | if test "x$enable_asm" = xyes -a "x$cross_compiling" = xyes; then | ||
23 | case "$host_cpu" in | ||
24 | i?86 | x86_64 | amd64) | ||
25 | - if test "x$host_cpu" != "x$target_cpu"; then | ||
26 | + if test "x$host_cpu" != "x$target_cpu" -o "x$acv_mesa_CLANG" = xyes; then | ||
27 | enable_asm=no | ||
28 | AC_MSG_RESULT([no, cross compiling]) | ||
29 | fi | ||
diff --git a/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch b/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch new file mode 100644 index 0000000..0280ee8 --- /dev/null +++ b/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | endianness check is OS wide and not specific to libc | ||
2 | |||
3 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
7 | --- | ||
8 | src/util/u_endian.h | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/util/u_endian.h b/src/util/u_endian.h | ||
12 | index b9d563d..2d5eab9 100644 | ||
13 | --- a/src/util/u_endian.h | ||
14 | +++ b/src/util/u_endian.h | ||
15 | @@ -27,7 +27,7 @@ | ||
16 | #ifndef U_ENDIAN_H | ||
17 | #define U_ENDIAN_H | ||
18 | |||
19 | -#if defined(__GLIBC__) || defined(ANDROID) | ||
20 | +#if defined(__linux__) | ||
21 | #include <endian.h> | ||
22 | |||
23 | #if __BYTE_ORDER == __LITTLE_ENDIAN | ||
24 | -- | ||
25 | 2.1.4 | ||
26 | |||
diff --git a/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb b/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb new file mode 100644 index 0000000..b95f301 --- /dev/null +++ b/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | require recipes-graphics/mesa/${BPN}.inc | ||
2 | |||
3 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \ | ||
4 | file://replace_glibc_check_with_linux.patch \ | ||
5 | file://disable-asm-on-non-gcc.patch \ | ||
6 | file://0001-Use-wayland-scanner-in-the-path.patch \ | ||
7 | " | ||
8 | |||
9 | SRC_URI[md5sum] = "8f808e92b893d412fbd6510e1d16f5c5" | ||
10 | SRC_URI[sha256sum] = "f8f191f909e01e65de38d5bdea5fb057f21649a3aed20948be02348e77a689d4" | ||
11 | |||
12 | #because we cannot rely on the fact that all apps will use pkgconfig, | ||
13 | #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER | ||
14 | do_install_append() { | ||
15 | if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then | ||
16 | sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h | ||
17 | fi | ||
18 | } | ||