diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-04-03 13:46:55 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-04-28 09:13:42 +0000 |
commit | 8521f121d3c7d5ced67abf44dff73021437e7a87 (patch) | |
tree | 96f65080986383e7f23ab73535598bcb31fc5cd1 /meta-nvidia-extras/recipes | |
parent | 88a28e12ca2fabb0fc47a96b4076bf10a0673c5b (diff) | |
download | meta-boot2qt-8521f121d3c7d5ced67abf44dff73021437e7a87.tar.gz |
tegra: update to [4.1.4.0] Vibrante 4.1 Linux Drive CX2
Task-number: QTAUTO-272
Change-Id: I63a564996a363cdd14f14f51a88364f9a9f99d73
Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
Diffstat (limited to 'meta-nvidia-extras/recipes')
6 files changed, 92 insertions, 151 deletions
diff --git a/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend b/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend index f2bdba1..c7730c6 100644 --- a/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend +++ b/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend | |||
@@ -1,7 +1,29 @@ | |||
1 | # Use our kernel instead of yocto which defaults to mainline 3.18 | 1 | # Copyright (c) 2015-2016, NVIDIA CORPORATION. All rights reserved. |
2 | # | ||
3 | # This program is free software; you can redistribute it and/or modify it | ||
4 | # under the terms and conditions of the GNU General Public License, | ||
5 | # version 2, as published by the Free Software Foundation. | ||
6 | # | ||
7 | # This program is distributed in the hope it will be useful, but WITHOUT | ||
8 | # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or | ||
9 | # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for | ||
10 | # more details. | ||
11 | # | ||
12 | # You should have received a copy of the GNU General Public License | ||
13 | # along with this program. If not, see <http://www.gnu.org/licenses/>. | ||
14 | |||
15 | # KERN_DIR holds linux.tar.bz2 | ||
16 | KERN_DIR := "${LNX_TOPDIR}_src/kernel" | ||
17 | # Kernel source is the kernel tarball in PDK | ||
2 | SRC_URI = "file://${KERN_DIR}/linux.tar.bz2" | 18 | SRC_URI = "file://${KERN_DIR}/linux.tar.bz2" |
3 | PV = "3.18" | 19 | PV = "4.4" |
4 | 20 | ||
5 | # Extracting linux.tar.bz2 creates directories | 21 | # Extracting linux.tar.bz2 creates directories |
6 | # <top>/vibrante-oss-src/kernel | 22 | # <top>/vibrante-oss-src/kernel |
7 | S = "${WORKDIR}/vibrante-oss-src/kernel" | 23 | S = "${WORKDIR}/vibrante-oss-src/kernel" |
24 | |||
25 | # Need to pass this to for oe_runmake explicitly for building outside kerneldir | ||
26 | EXTRA_OEMAKE += " -C ${S} O=${B}" | ||
27 | |||
28 | # Apply RT patches | ||
29 | require recipes-kernel/linux/apply-rt-patches.inc | ||
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend index 70ee515..835dfe8 100644 --- a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend +++ b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,43 +27,31 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | do_unpack_append() { | 30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
31 | rm -rf ${STAGING_KERNEL_DIR} | 31 | SRC_URI += "file://0001-Fix-misleading-indentation-error.patch;patchdir=.." |
32 | ln -s ${S} ${STAGING_KERNEL_DIR} | ||
33 | } | ||
34 | 32 | ||
35 | do_kernel_defconfig_prepend () { | 33 | CROSS_COMPILE_PREFIX = "${CROSS_COMPILE}" |
36 | } | ||
37 | 34 | ||
38 | do_compile_prepend () { | 35 | PACKAGES += "kernel-devicetree" |
39 | # cross_compile_exports | 36 | FILES_kernel-devicetree = "/boot/*.dtb" |
40 | export ARCH=${KERNEL_ARCH} | ||
41 | export CROSS_COMPILE=${CROSS_COMPILE} | ||
42 | 37 | ||
43 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config | 38 | RDEPENDS_kernel-base = "kernel-image kernel-devicetree" |
44 | echo "CONFIG_USB_ACM=m" >> ${B}/.config | ||
45 | 39 | ||
46 | make olddefconfig | 40 | python do_patch () { |
41 | bb.build.exec_func('patch_do_patch', d) | ||
47 | } | 42 | } |
48 | 43 | ||
49 | do_install () { | 44 | do_unpack_append() { |
50 | kernel_do_install | 45 | mkdir -p ${STAGING_KERNEL_DIR} |
51 | 46 | rm -rf ${STAGING_KERNEL_DIR} | |
52 | s=$(readlink -m "${S}") | 47 | ln -s ${S} ${STAGING_KERNEL_DIR} |
53 | kernsrc="${STAGING_KERNEL_DIR}" | ||
54 | |||
55 | if [ "${s}" != "${kernsrc}" ]; then | ||
56 | mkdir -p "${kernsrc}" | ||
57 | rm -rf "${kernsrc}" | ||
58 | mv "${S}" "${STAGING_KERNEL_DIR}" | ||
59 | ln -sf "${kernsrc}" "${s}" | ||
60 | fi | ||
61 | } | 48 | } |
62 | 49 | ||
63 | do_deploy() { | 50 | do_install_append() { |
64 | kernel_do_deploy | 51 | kernel_do_install |
52 | install -m 0664 -t ${D}/boot/ ${B}/arch/arm64/boot/dts/*.dtb | ||
65 | } | 53 | } |
66 | 54 | ||
67 | do_compile () { | 55 | dtbs_deploy() { |
68 | kernel_do_compile | 56 | install -m 0664 -t ${DEPLOY_DIR_IMAGE} ${B}/arch/arm64/boot/dts/*.dtb |
69 | } | 57 | } |
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia/0001-Fix-misleading-indentation-error.patch b/meta-nvidia-extras/recipes/linux/linux-nvidia/0001-Fix-misleading-indentation-error.patch new file mode 100644 index 0000000..a344adc --- /dev/null +++ b/meta-nvidia-extras/recipes/linux/linux-nvidia/0001-Fix-misleading-indentation-error.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 33d112e943590020f2cda2a403a755531833b016 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Fri, 31 Mar 2017 09:42:18 +0300 | ||
4 | Subject: [PATCH] Fix misleading-indentation error | ||
5 | |||
6 | error: this 'if' clause does not guard... [-Werror=misleading-indentation] | ||
7 | if (!runlist->active_channels) | ||
8 | --- | ||
9 | nvgpu/drivers/gpu/nvgpu/vgpu/fifo_vgpu.c | 16 ++++++++-------- | ||
10 | 1 file changed, 8 insertions(+), 8 deletions(-) | ||
11 | |||
12 | diff --git a/nvgpu/drivers/gpu/nvgpu/vgpu/fifo_vgpu.c b/nvgpu/drivers/gpu/nvgpu/vgpu/fifo_vgpu.c | ||
13 | index 3e57c67..e2fe4db 100644 | ||
14 | --- a/nvgpu/drivers/gpu/nvgpu/vgpu/fifo_vgpu.c | ||
15 | +++ b/nvgpu/drivers/gpu/nvgpu/vgpu/fifo_vgpu.c | ||
16 | @@ -209,15 +209,15 @@ static int init_runlist(struct gk20a *g, struct fifo_gk20a *f) | ||
17 | if (!runlist->active_channels) | ||
18 | goto clean_up_runlist; | ||
19 | |||
20 | - runlist_size = sizeof(u16) * f->num_channels; | ||
21 | - for (i = 0; i < MAX_RUNLIST_BUFFERS; i++) { | ||
22 | - int err = gk20a_gmmu_alloc_sys(g, runlist_size, | ||
23 | - &runlist->mem[i]); | ||
24 | - if (err) { | ||
25 | - dev_err(d, "memory allocation failed\n"); | ||
26 | - goto clean_up_runlist; | ||
27 | - } | ||
28 | + runlist_size = sizeof(u16) * f->num_channels; | ||
29 | + for (i = 0; i < MAX_RUNLIST_BUFFERS; i++) { | ||
30 | + int err = gk20a_gmmu_alloc_sys(g, runlist_size, | ||
31 | + &runlist->mem[i]); | ||
32 | + if (err) { | ||
33 | + dev_err(d, "memory allocation failed\n"); | ||
34 | + goto clean_up_runlist; | ||
35 | } | ||
36 | + } | ||
37 | mutex_init(&runlist->mutex); | ||
38 | |||
39 | /* None of buffers is pinned if this value doesn't change. | ||
40 | -- | ||
41 | 2.7.4 | ||
42 | |||
diff --git a/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch b/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch deleted file mode 100644 index 5e0e6bf..0000000 --- a/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | build: always build wayland-scanner | ||
2 | |||
3 | The previous idiom for building a cross-compiled Wayland is to build once for | ||
4 | the build host (with --enable-scanner --disable-libraries) to get a | ||
5 | wayland-scanner binary that can then be used in a cross-compile (with | ||
6 | --disable-scanner). The problem with this is that the cross wayland is missing | ||
7 | a wayland-scanner binary, which means you then can't do any Wayland development | ||
8 | on the target. | ||
9 | |||
10 | Instead, always build wayland-scanner for the target and change | ||
11 | --enable/disable-scanner to --with/without-host-scanner. Normal builds use the | ||
12 | default of --without-host-scanner and run the wayland-scanner it just built, and | ||
13 | cross-compiled builds pass --with-host-scanner to use a previously built host | ||
14 | scanner but still get a wayland-scanner to install. | ||
15 | |||
16 | (a theoretically neater solution would be to build two scanners if required (one | ||
17 | to run and one to install), but automake makes this overly complicated) | ||
18 | |||
19 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
20 | Upstream-Status: Submitted | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index c19494f..c2d929b 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -64,16 +64,17 @@ nodist_libwayland_client_la_SOURCES = \ | ||
27 | |||
28 | pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc | ||
29 | |||
30 | -if ENABLE_SCANNER | ||
31 | -wayland_scanner = $(top_builddir)/wayland-scanner | ||
32 | bin_PROGRAMS = wayland-scanner | ||
33 | wayland_scanner_SOURCES = src/scanner.c | ||
34 | wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS) | ||
35 | wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la | ||
36 | -$(BUILT_SOURCES) : wayland-scanner | ||
37 | pkgconfig_DATA += src/wayland-scanner.pc | ||
38 | -else | ||
39 | + | ||
40 | +if HOST_SCANNER | ||
41 | wayland_scanner = wayland-scanner | ||
42 | +else | ||
43 | +$(BUILT_SOURCES) : wayland-scanner | ||
44 | +wayland_scanner = $(top_builddir)/wayland-scanner | ||
45 | endif | ||
46 | |||
47 | protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml | ||
48 | diff --git a/configure.ac b/configure.ac | ||
49 | index c2a804e..de0b02f 100644 | ||
50 | --- a/configure.ac | ||
51 | +++ b/configure.ac | ||
52 | @@ -65,11 +65,11 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[], | ||
53 | [[#include <time.h>]]) | ||
54 | AC_CHECK_HEADERS([execinfo.h]) | ||
55 | |||
56 | -AC_ARG_ENABLE([scanner], | ||
57 | - [AC_HELP_STRING([--disable-scanner], | ||
58 | - [Disable compilation of wayland-scanner])], | ||
59 | - [], | ||
60 | - [enable_scanner=yes]) | ||
61 | +AC_ARG_WITH([host-scanner], | ||
62 | + [AC_HELP_STRING([--with-host-scanner], | ||
63 | + [Use a host wayland-scanner])], | ||
64 | + [], | ||
65 | + [with_host_scanner=no]) | ||
66 | |||
67 | AC_ARG_ENABLE([documentation], | ||
68 | [AC_HELP_STRING([--disable-documentation], | ||
69 | @@ -77,25 +77,23 @@ AC_ARG_ENABLE([documentation], | ||
70 | [], | ||
71 | [enable_documentation=yes]) | ||
72 | |||
73 | -AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes) | ||
74 | +AM_CONDITIONAL(HOST_SCANNER, test "x$with_host_scanner" = xyes) | ||
75 | |||
76 | AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here], | ||
77 | [ ICONDIR=$withval], | ||
78 | [ ICONDIR=${datadir}/icons]) | ||
79 | AC_SUBST([ICONDIR]) | ||
80 | |||
81 | -if test "x$enable_scanner" = "xyes"; then | ||
82 | - PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
83 | - [AC_CHECK_HEADERS(expat.h, [], | ||
84 | - [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
85 | - SAVE_LIBS="$LIBS" | ||
86 | - AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
87 | - [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
88 | - EXPAT_LIBS="$LIBS" | ||
89 | - LIBS="$SAVE_LIBS" | ||
90 | - AC_SUBST(EXPAT_LIBS) | ||
91 | - ]) | ||
92 | -fi | ||
93 | +PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
94 | + [AC_CHECK_HEADERS(expat.h, [], | ||
95 | + [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
96 | + SAVE_LIBS="$LIBS" | ||
97 | + AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
98 | + [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
99 | + EXPAT_LIBS="$LIBS" | ||
100 | + LIBS="$SAVE_LIBS" | ||
101 | + AC_SUBST(EXPAT_LIBS) | ||
102 | + ]) | ||
103 | |||
104 | AC_PATH_PROG(XSLTPROC, xsltproc) | ||
105 | AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"]) | ||
diff --git a/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend b/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend index 463d5a1..5ab7634 100644 --- a/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend +++ b/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,10 +27,8 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := ":${NVLAYER_DIR}/packages:${LNX_TOPDIR}/${PN}:${THISDIR}/${PN}" | 30 | FILESEXTRAPATHS_append := ":${LNX_TOPDIR}_src/wayland" |
31 | 31 | ||
32 | SRC_URI_remove = "file://${NVLAYER_DIR}/packages/wayland-1.8.1-src.tar.gz" | 32 | SRC_URI = "file://wayland-1.11.0-src.tar.gz" |
33 | SRC_URI = "\ | 33 | |
34 | file://wayland-1.8.1-src.tar.gz \ | 34 | DEPENDS_class-target += "wayland-egl" |
35 | file://always-build-scanner.patch \ | ||
36 | " | ||
diff --git a/meta-nvidia-extras/recipes/weston/weston_%.bbappend b/meta-nvidia-extras/recipes/weston/weston_%.bbappend index cfc286f..22f0f11 100644 --- a/meta-nvidia-extras/recipes/weston/weston_%.bbappend +++ b/meta-nvidia-extras/recipes/weston/weston_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,10 +27,6 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" | 30 | PACKAGECONFIG_remove = "kms" |
31 | S = "${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston" | ||
32 | 31 | ||
33 | do_install_prepend() { | 32 | TARGET_CFLAGS += "-DWIN_INTERFACE_CUSTOM" |
34 | mkdir -p ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools | ||
35 | cp ${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston/tools/weston.ini ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools/weston.ini | ||
36 | } | ||