diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-03-31 11:01:04 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-05-12 14:47:11 +0300 |
commit | ae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (patch) | |
tree | acaecd3b089b341f87dd27384bb800c9b497148d /meta-ti-extras | |
parent | 5fcb893d078d718318ca94bf7f284ef35355c152 (diff) | |
download | meta-boot2qt-ae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5.tar.gz |
Build Qt5 and all addons
Use meta-qt5 layer to build Qt5, commercial addons and b2qt addons.
Create new image and toolchain recipes with Qt5 content, so that the
existing image and toolchain remain as-is without Qt5.
Currently support only for imx6 targets.
Change-Id: I398750dd1a62c6ff8ea216cfe364da273d8e9a77
Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r-- | meta-ti-extras/recipes/qt5/qtbase_%.bbappend | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes/qt5/qtbase_%.bbappend b/meta-ti-extras/recipes/qt5/qtbase_%.bbappend new file mode 100644 index 0000000..ada9f02 --- /dev/null +++ b/meta-ti-extras/recipes/qt5/qtbase_%.bbappend | |||
@@ -0,0 +1,33 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | do_configure_prepend_rpi() { | ||
24 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | ||
25 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
26 | |||
27 | QMAKE_LIBS_EGL = -lEGL -lIMGegl -lsrv_um | ||
28 | QMAKE_LIBS_OPENGL_ES2 = -lGLESv2 \$\${QMAKE_LIBS_EGL} | ||
29 | QMAKE_LIBS_OPENVG = -lOpenVG \$\${QMAKE_LIBS_EGL} | ||
30 | |||
31 | load(qt_config) | ||
32 | EOF | ||
33 | } | ||