diff options
author | Andy Nichols <andy.nichols@theqtcompany.com> | 2015-02-18 14:34:17 +0100 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-05-26 12:55:33 +0300 |
commit | 06a8c81b3a0ae818b129638a1d8d4f9b327d8eb2 (patch) | |
tree | 085fd7dee60caebe96efb9d1d81e719eaab9b16a /meta-toradex-extras/recipes | |
parent | 8127be12eb0e119c422f635fb7b8d43b81d2e8c5 (diff) | |
download | meta-boot2qt-06a8c81b3a0ae818b129638a1d8d4f9b327d8eb2.tar.gz |
Fix Linux Kernel 3.18 build with Colibri-VF
The Linux Kernel blacklists GCC 4.8.0 - 4.8.2 because of a
bug. The GCC 4.8.2 provided by Poky has already been patched
for this bug so it is safe to renabled building with GCC 4.8.
GCC Bug:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58854
Change-Id: If3ea442b1dfbef8991c39f8d1326643cf418b1ec
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras/recipes')
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch | 27 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend | 26 |
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch new file mode 100644 index 0000000..43edec3 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 30c67656c09f49608bbadb75e365d1d3da36cc70 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Wed, 18 Feb 2015 14:28:14 +0100 | ||
4 | Subject: [PATCH] Allow builds with GCC 4.8 | ||
5 | |||
6 | --- | ||
7 | arch/arm/kernel/asm-offsets.c | 4 ---- | ||
8 | 1 file changed, 4 deletions(-) | ||
9 | |||
10 | diff --git a/arch/arm/kernel/asm-offsets.c b/arch/arm/kernel/asm-offsets.c | ||
11 | index 2d2d608..6f8e79c 100644 | ||
12 | --- a/arch/arm/kernel/asm-offsets.c | ||
13 | +++ b/arch/arm/kernel/asm-offsets.c | ||
14 | @@ -49,10 +49,6 @@ | ||
15 | #error Your compiler is too buggy; it is known to miscompile kernels. | ||
16 | #error Known good compilers: 3.3, 4.x | ||
17 | #endif | ||
18 | -#if GCC_VERSION >= 40800 && GCC_VERSION < 40803 | ||
19 | -#error Your compiler is too buggy; it is known to miscompile kernels | ||
20 | -#error and result in filesystem corruption and oopses. | ||
21 | -#endif | ||
22 | #endif | ||
23 | |||
24 | int main(void) | ||
25 | -- | ||
26 | 1.9.1 | ||
27 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend new file mode 100644 index 0000000..4f05386 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend | |||
@@ -0,0 +1,26 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
24 | SRC_URI += " \ | ||
25 | file://0001-Allow-builds-with-GCC-4.8.patch \ | ||
26 | " | ||