diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-01 09:43:22 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-12 12:34:50 +0000 |
commit | ae2d6d14123d0eae08b04e9e31bdd129aff119e6 (patch) | |
tree | 644c68739a558794241095f79a92df1f0b9c4e00 /meta-toradex-extras/recipes | |
parent | adc61820f15efe4e57e9089372e55ad20aaf1efb (diff) | |
download | meta-boot2qt-ae2d6d14123d0eae08b04e9e31bdd129aff119e6.tar.gz |
toradex: stop using meta-toradex
All needed toradex recipes are now in meta-fsl-arm-extra
Change-Id: I3eedacd83845087d2369cf4d4b6df2a030d6d283
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras/recipes')
21 files changed, 0 insertions, 533 deletions
diff --git a/meta-toradex-extras/recipes/base-files/base-files/b2qt/fstab b/meta-toradex-extras/recipes/base-files/base-files/b2qt/fstab deleted file mode 100644 index 12e0489..0000000 --- a/meta-toradex-extras/recipes/base-files/base-files/b2qt/fstab +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | # stock fstab - you probably want to override this with a machine specific one | ||
2 | |||
3 | /dev/root / auto defaults 1 1 | ||
4 | proc /proc proc defaults 0 0 | ||
5 | debugfs /sys/kernel/debug debugfs defaults 0 0 | ||
6 | devpts /dev/pts devpts mode=0620,gid=5 0 0 | ||
7 | usbfs /proc/bus/usb usbfs noauto | ||
8 | tmpfs /var/volatile tmpfs defaults 0 0 | ||
9 | tmpfs /run tmpfs mode=0755,nodev,nosuid,strictatime 0 0 | ||
10 | tmpfs /dev/shm tmpfs mode=0777 0 0 | ||
11 | tmpfs /media/ram tmpfs defaults 0 0 | ||
12 | |||
13 | # uncomment this if your device has a SD/MMC/Transflash slot | ||
14 | #/dev/mmcblk0p1 /media/card auto defaults,sync,noauto 0 0 | ||
15 | |||
diff --git a/meta-toradex-extras/recipes/base-files/base-files_3.0.14.bbappend b/meta-toradex-extras/recipes/base-files/base-files_3.0.14.bbappend deleted file mode 100644 index dbeb030..0000000 --- a/meta-toradex-extras/recipes/base-files/base-files_3.0.14.bbappend +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Allow-builds-with-GCC-4.8.patch b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Allow-builds-with-GCC-4.8.patch deleted file mode 100644 index 43edec3..0000000 --- a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Allow-builds-with-GCC-4.8.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 30c67656c09f49608bbadb75e365d1d3da36cc70 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Wed, 18 Feb 2015 14:28:14 +0100 | ||
4 | Subject: [PATCH] Allow builds with GCC 4.8 | ||
5 | |||
6 | --- | ||
7 | arch/arm/kernel/asm-offsets.c | 4 ---- | ||
8 | 1 file changed, 4 deletions(-) | ||
9 | |||
10 | diff --git a/arch/arm/kernel/asm-offsets.c b/arch/arm/kernel/asm-offsets.c | ||
11 | index 2d2d608..6f8e79c 100644 | ||
12 | --- a/arch/arm/kernel/asm-offsets.c | ||
13 | +++ b/arch/arm/kernel/asm-offsets.c | ||
14 | @@ -49,10 +49,6 @@ | ||
15 | #error Your compiler is too buggy; it is known to miscompile kernels. | ||
16 | #error Known good compilers: 3.3, 4.x | ||
17 | #endif | ||
18 | -#if GCC_VERSION >= 40800 && GCC_VERSION < 40803 | ||
19 | -#error Your compiler is too buggy; it is known to miscompile kernels | ||
20 | -#error and result in filesystem corruption and oopses. | ||
21 | -#endif | ||
22 | #endif | ||
23 | |||
24 | int main(void) | ||
25 | -- | ||
26 | 1.9.1 | ||
27 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch deleted file mode 100644 index d92ac62..0000000 --- a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From d57edef022af184015a8ccd87fa9021024513d55 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Fri, 6 Mar 2015 10:14:13 +0100 | ||
4 | Subject: [PATCH] Enable Fusion 7 and 10 multi-touch controller | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi b/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
11 | index 1f43dbe..9194580 100644 | ||
12 | --- a/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
13 | +++ b/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
14 | @@ -214,7 +214,7 @@ | ||
15 | gpios = <&gpio0 30 GPIO_ACTIVE_HIGH /* SO-DIMM 28, Pen down interrupt */ | ||
16 | &gpio0 23 GPIO_ACTIVE_LOW /* SO-DIMM 30, Reset interrupt */ | ||
17 | >; | ||
18 | - status = "disabled"; | ||
19 | + status = "okay"; | ||
20 | }; | ||
21 | |||
22 | /* M41T0M6 real time clock on carrier board */ | ||
23 | -- | ||
24 | 2.3.1 | ||
25 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend deleted file mode 100644 index b696b19..0000000 --- a/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # kernel image files are not needed in the image | ||
31 | RDEPENDS_kernel-base = "" | ||
32 | |||
33 | do_configure_prepend () { | ||
34 | # FunctionFS for adb | ||
35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | ||
36 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
37 | } | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend deleted file mode 100644 index 77ce484..0000000 --- a/meta-toradex-extras/recipes/linux/linux-toradex_4.%.bbappend +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_configure_prepend () { | ||
31 | # FunctionFS for adb | ||
32 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | ||
33 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
34 | echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig | ||
35 | } | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend deleted file mode 100644 index 5352ed7..0000000 --- a/meta-toradex-extras/recipes/linux/linux-toradex_git.bbappend +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # kernel image files are not needed in the image | ||
31 | RDEPENDS_kernel-base = "" | ||
32 | |||
33 | config_script () { | ||
34 | # FunctionFS for adb | ||
35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config | ||
36 | echo "CONFIG_USB_ACM=m" >> ${S}/.config | ||
37 | } | ||
38 | |||
39 | B = "${S}" | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb deleted file mode 100644 index bb209ad..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb +++ /dev/null | |||
@@ -1,76 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
31 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
32 | DEPENDS = "u-boot-mkimage-native" | ||
33 | |||
34 | PV = "v2.3" | ||
35 | |||
36 | SRC_URI = " \ | ||
37 | file://flash_mmc.scr \ | ||
38 | file://flash_blk.scr \ | ||
39 | " | ||
40 | |||
41 | S = "${WORKDIR}" | ||
42 | |||
43 | inherit deploy | ||
44 | |||
45 | do_mkimage () { | ||
46 | uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ | ||
47 | -n "update script" -d ${WORKDIR}/flash_mmc.scr \ | ||
48 | flash_mmc.img | ||
49 | |||
50 | uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ | ||
51 | -n "update script" -d ${WORKDIR}/flash_blk.scr \ | ||
52 | flash_blk.img | ||
53 | } | ||
54 | |||
55 | addtask mkimage after do_compile before do_install | ||
56 | |||
57 | do_deploy () { | ||
58 | install -d ${DEPLOYDIR} | ||
59 | install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img | ||
60 | install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img | ||
61 | |||
62 | cd ${DEPLOYDIR} | ||
63 | rm -f flash_mmc-${MACHINE}.img | ||
64 | ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img | ||
65 | rm -f flash_blk-${MACHINE}.img | ||
66 | ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img | ||
67 | } | ||
68 | |||
69 | addtask deploy after do_install before do_build | ||
70 | |||
71 | do_compile[noexec] = "1" | ||
72 | do_install[noexec] = "1" | ||
73 | do_populate_sysroot[noexec] = "1" | ||
74 | |||
75 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
76 | COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6|colibri-imx7)" | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr deleted file mode 100644 index ee87e85..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | test -n ${interface} || setenv interface mmc | ||
2 | test -n ${drive} || setenv drive 1 | ||
3 | |||
4 | setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200' | ||
5 | setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}' | ||
6 | echo 'enter "run update_uboot" to update the uboot' | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr deleted file mode 100644 index 207c7db..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | #flash_mmc has been renamed to flash_blk, ensure compatibilty when updating from older versions | ||
2 | test -n ${interface} || setenv interface mmc | ||
3 | test -n ${drive} || setenv drive 1 | ||
4 | |||
5 | fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img | ||
6 | source ${loadaddr} | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr deleted file mode 100644 index 3e05a85..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | test -n ${interface} || setenv interface mmc | ||
2 | test -n ${drive} || setenv drive 0 | ||
3 | |||
4 | setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200' | ||
5 | setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}' | ||
6 | echo 'enter "run update_uboot" to update the uboot' | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr deleted file mode 100644 index 0c16652..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | #flash_mmc has been renamed to flash_blk, ensure compatibility when updating from older versions | ||
2 | test -n ${interface} || setenv interface mmc | ||
3 | test -n ${drive} || setenv drive 0 | ||
4 | |||
5 | fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img | ||
6 | source ${loadaddr} | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr deleted file mode 100644 index be8ec8d..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot' | ||
2 | echo 'enter "run update_uboot" to update the uboot' | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr deleted file mode 100644 index e0770a0..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | setenv interface mmc | ||
2 | fatload ${interface} 0:1 ${loadaddr} flash_blk.img | ||
3 | source ${loadaddr} | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch deleted file mode 100644 index b7c7d63..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 94531a3ecaea073316b9e4c341085ce5e277bd9f Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Mon, 27 Oct 2014 14:53:25 +0200 | ||
4 | Subject: [PATCH] Update default args for apalis imx6 | ||
5 | |||
6 | Boot from sd card by default, disable kernel logs from tty1, and | ||
7 | disable cursor blinking. | ||
8 | --- | ||
9 | include/configs/apalis_imx6.h | 15 ++++++++------- | ||
10 | 1 file changed, 8 insertions(+), 7 deletions(-) | ||
11 | |||
12 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | ||
13 | index e7d0d20..a1d425d 100644 | ||
14 | --- a/include/configs/apalis_imx6.h | ||
15 | +++ b/include/configs/apalis_imx6.h | ||
16 | @@ -251,14 +251,14 @@ | ||
17 | "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
18 | |||
19 | #define SD_BOOTCMD \ | ||
20 | - "sdargs=ip=off root=/dev/mmcblk1p2 rw,noatime rootfstype=ext3 " \ | ||
21 | - "rootwait\0" \ | ||
22 | + "drive=2\0" \ | ||
23 | "sdboot=run setup; " \ | ||
24 | - "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \ | ||
25 | + "setenv bootargs ${defargs} ip=off root=/dev/mmcblk${drive}p2 " \ | ||
26 | + "rw,noatime rootfstype=ext3 rootwait ${setupargs} " \ | ||
27 | "${vidargs}; echo Booting from SD card in 8-bit slot...; " \ | ||
28 | - "run sddtbload; load mmc 1:1 ${kernel_addr_r} " \ | ||
29 | + "run sddtbload; load mmc ${drive}:1 ${kernel_addr_r} " \ | ||
30 | "${boot_file} && bootm ${kernel_addr_r} ${dtbparam}\0" \ | ||
31 | - "sddtbload=setenv dtbparam; load mmc 1:1 ${fdt_addr_r} " \ | ||
32 | + "sddtbload=setenv dtbparam; load mmc ${drive}:1 ${fdt_addr_r} " \ | ||
33 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
34 | |||
35 | #define USB_BOOTCMD \ | ||
36 | @@ -278,7 +278,8 @@ | ||
37 | #define FDT_FILE "imx6q-apalis_v1_0-eval.dtb" | ||
38 | #endif | ||
39 | #define CONFIG_EXTRA_ENV_SETTINGS \ | ||
40 | - "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \ | ||
41 | + "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \ | ||
42 | + "run emmcboot ; echo ; echo emmcboot failed ; " \ | ||
43 | "run nfsboot ; echo ; echo nfsboot failed ; " \ | ||
44 | "usb start ;" \ | ||
45 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | ||
46 | @@ -299,7 +300,7 @@ | ||
47 | "|| setenv drive 2; load ${interface} ${drive}:1 " \ | ||
48 | "${kernel_addr_r} flash_blk.img\0" \ | ||
49 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
50 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
51 | + "consoleblank=0 no_console_suspend=1 vt.global_cursor_default=0 " \ | ||
52 | "console=${console},${baudrate}n8\0 " \ | ||
53 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate;" \ | ||
54 | " source ${kernel_addr_r}\0" \ | ||
55 | -- | ||
56 | 1.9.1 | ||
57 | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch deleted file mode 100644 index 0743128..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From 10ebeba59e6fd25352aa44ecd85913126ec45afe Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 24 Feb 2016 15:39:52 +0200 | ||
4 | Subject: [PATCH] colibri imx6: enable sdboot by default | ||
5 | |||
6 | remove console from tty1 | ||
7 | --- | ||
8 | include/configs/colibri_imx6.h | 5 +++-- | ||
9 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h | ||
12 | index c545334..eb0dfa9 100644 | ||
13 | --- a/include/configs/colibri_imx6.h | ||
14 | +++ b/include/configs/colibri_imx6.h | ||
15 | @@ -242,7 +242,8 @@ | ||
16 | |||
17 | #define FDT_FILE "imx6dl-colibri-eval-v3.dtb" | ||
18 | #define CONFIG_EXTRA_ENV_SETTINGS \ | ||
19 | - "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \ | ||
20 | + "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \ | ||
21 | + "run emmcboot ; echo ; echo emmcboot failed ; " \ | ||
22 | "run nfsboot ; echo ; echo nfsboot failed ; " \ | ||
23 | "usb start ;" \ | ||
24 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | ||
25 | @@ -261,7 +262,7 @@ | ||
26 | "setsdupdate=setenv interface mmc; setenv drive 1; mmc rescan; " \ | ||
27 | "load ${interface} ${drive}:1 ${kernel_addr_r} flash_blk.img\0" \ | ||
28 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
29 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
30 | + "consoleblank=0 no_console_suspend=1 " \ | ||
31 | "console=${console},${baudrate}n8\0 " \ | ||
32 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate;" \ | ||
33 | " source ${kernel_addr_r}\0" \ | ||
34 | -- | ||
35 | 1.9.1 | ||
36 | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch deleted file mode 100644 index 501ad33..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | diff -Naur git.orig/include/configs/colibri_imx7.h git/include/configs/colibri_imx7.h | ||
2 | --- git.orig/include/configs/colibri_imx7.h 2016-07-15 12:31:35.915934824 +0300 | ||
3 | +++ git/include/configs/colibri_imx7.h 2016-07-15 12:32:40.867937388 +0300 | ||
4 | @@ -248,7 +248,7 @@ | ||
5 | "${board}/flash_eth.img && source ${loadaddr}\0" \ | ||
6 | "setsdupdate=mmc rescan && setenv interface mmc && " \ | ||
7 | "fatload ${interface} 0:1 ${loadaddr} " \ | ||
8 | - "${board}/flash_blk.img && source ${loadaddr}\0" \ | ||
9 | + "/flash_blk.img && source ${loadaddr}\0" \ | ||
10 | "setup=setenv setupargs " \ | ||
11 | "console=tty1 console=${console}" \ | ||
12 | ",${baudrate}n8 ${memargs} consoleblank=0 ${mtdparts}\0" \ | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch deleted file mode 100644 index b54a4ae..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From f480a948551b0e5592d93cb7a5dc1653de900909 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 24 Feb 2016 16:01:33 +0200 | ||
4 | Subject: [PATCH] colibri vf: remove console from tty1 | ||
5 | |||
6 | --- | ||
7 | include/configs/colibri_vf.h | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h | ||
11 | index b870812..0726fc5 100644 | ||
12 | --- a/include/configs/colibri_vf.h | ||
13 | +++ b/include/configs/colibri_vf.h | ||
14 | @@ -202,7 +202,7 @@ | ||
15 | "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \ | ||
16 | "source ${loadaddr}\0" \ | ||
17 | "setup=setenv setupargs " \ | ||
18 | - "console=tty1 console=${console}" \ | ||
19 | + "console=${console}" \ | ||
20 | ",${baudrate}n8 ${memargs} consoleblank=0\0" \ | ||
21 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
22 | "setusbupdate=usb start && setenv interface usb && " \ | ||
23 | -- | ||
24 | 1.9.1 | ||
25 | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch deleted file mode 100644 index 25476dd..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | diff -Naur git.orig/include/configs/colibri_vf.h git/include/configs/colibri_vf.h | ||
2 | --- git.orig/include/configs/colibri_vf.h 2016-07-15 12:05:41.263873456 +0300 | ||
3 | +++ git/include/configs/colibri_vf.h 2016-07-15 12:06:19.759874976 +0300 | ||
4 | @@ -161,8 +161,8 @@ | ||
5 | "sdargs=root=/dev/mmcblk0p2 rw rootwait\0" \ | ||
6 | "sdboot=run setup; setenv bootargs ${defargs} ${sdargs} " \ | ||
7 | "${setupargs} ${vidargs}; echo Booting from MMC/SD card...; " \ | ||
8 | - "load mmc 0:2 ${kernel_addr_r} /boot/${kernel_file} && " \ | ||
9 | - "load mmc 0:2 ${fdt_addr_r} /boot/${soc}-colibri-${fdt_board}.dtb && " \ | ||
10 | + "load mmc 0:1 ${kernel_addr_r} /${kernel_file} && " \ | ||
11 | + "load mmc 0:1 ${fdt_addr_r} /${soc}-colibri-${fdt_board}.dtb && " \ | ||
12 | "run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \ | ||
13 | |||
14 | #define NFS_BOOTCMD \ | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend deleted file mode 100644 index bdae0b8..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += " \ | ||
32 | file://0001-colibri-vf-remove-console-from-tty1.patch \ | ||
33 | file://0002-colibri-vf-fix-mmc-boot.patch \ | ||
34 | file://0001-colibri-imx7-fix-update-u-boot.patch \ | ||
35 | " | ||
36 | |||
37 | do_compile_append () { | ||
38 | if [ "${MACHINE}" = "colibri-vf" ]; then | ||
39 | oe_runmake u-boot-nand.imx | ||
40 | fi | ||
41 | |||
42 | } | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend deleted file mode 100644 index 45b5fd3..0000000 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += " \ | ||
32 | file://0001-Update-default-args-for-apalis-imx6.patch \ | ||
33 | file://0001-colibri-imx6-enable-sdboot-by-default.patch \ | ||
34 | " | ||