diff options
author | Andy Nichols <andy.nichols@theqtcompany.com> | 2015-02-19 11:33:54 +0100 |
---|---|---|
committer | Andy Nichols <andy.nichols@theqtcompany.com> | 2015-03-31 16:07:54 +0300 |
commit | d9a08a8a9419a1635d4985e75c43263aaab9577d (patch) | |
tree | 4072583ca3ea97f6c6e66e32812daf77a50b1393 /meta-toradex-extras/recipes | |
parent | d799779d19aa8b21e6d8cb6ef0f12a2e34d35794 (diff) | |
download | meta-boot2qt-d9a08a8a9419a1635d4985e75c43263aaab9577d.tar.gz |
Update Colibri-VF recpies to use dizzy
Now uses Linux kernel 3.18
Automaically loads Toradex multi-touch screen driver
Fixes Serial Console and ADB
Change-Id: Idbccb170ddd78992f5b340a96fe5aae5628c6c82
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras/recipes')
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch | 25 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend | 33 |
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch new file mode 100644 index 0000000..d92ac62 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Enable-Fusion-7-and-10-multi-touch-controller.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From d57edef022af184015a8ccd87fa9021024513d55 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Fri, 6 Mar 2015 10:14:13 +0100 | ||
4 | Subject: [PATCH] Enable Fusion 7 and 10 multi-touch controller | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi b/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
11 | index 1f43dbe..9194580 100644 | ||
12 | --- a/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
13 | +++ b/arch/arm/boot/dts/vf-colibri-eval-v3.dtsi | ||
14 | @@ -214,7 +214,7 @@ | ||
15 | gpios = <&gpio0 30 GPIO_ACTIVE_HIGH /* SO-DIMM 28, Pen down interrupt */ | ||
16 | &gpio0 23 GPIO_ACTIVE_LOW /* SO-DIMM 30, Reset interrupt */ | ||
17 | >; | ||
18 | - status = "disabled"; | ||
19 | + status = "okay"; | ||
20 | }; | ||
21 | |||
22 | /* M41T0M6 real time clock on carrier board */ | ||
23 | -- | ||
24 | 2.3.1 | ||
25 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend new file mode 100644 index 0000000..a723ab8 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend | |||
@@ -0,0 +1,33 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
24 | |||
25 | SRC_URI += " \ | ||
26 | file://0001-Enable-Fusion-7-and-10-multi-touch-controller.patch \ | ||
27 | " | ||
28 | |||
29 | config_script () { | ||
30 | # FunctionFS for adb | ||
31 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config | ||
32 | echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${S}/.config | ||
33 | } | ||