diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-09-28 16:44:45 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-10-06 05:57:49 +0000 |
commit | cfebf8586735f4db9c9573c1af9eb1553132c0e8 (patch) | |
tree | 34951b02cfd35498ed524ed8b286ccd25a63d909 /meta-vib4-extras | |
parent | 173cf50e88d53f9cf81c0ac5f2f186834ca3b81f (diff) | |
download | meta-boot2qt-cfebf8586735f4db9c9573c1af9eb1553132c0e8.tar.gz |
tegra: update recipes to work with krogoth
Extra patch needed for linux libc headers to get systemd to build.
../git/src/basic/btrfs-util.c:1122:23: error: 'BTRFS_IOC_QUOTA_RESCAN_WAIT'
undeclared (first use in this function)
Change-Id: Ic4706679cef9b9eef7a333c7a7c3985104be6012
Reviewed-by: Risto Avila <risto.avila@qt.io>
Diffstat (limited to 'meta-vib4-extras')
-rw-r--r-- | meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend | 15 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend (renamed from meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend) | 0 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/linux/linux-nvidia.bbappend | 6 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/weston/weston-nv.bbappend | 32 |
4 files changed, 37 insertions, 16 deletions
diff --git a/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend b/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend deleted file mode 100644 index d7353bc..0000000 --- a/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | # Append --enable-kernel flag to configure flags | ||
2 | # only for target build case. | ||
3 | # We are setting this to kernel 3.18 to keep glibc | ||
4 | # compatbile across all 3.18 series | ||
5 | # We will not support < 3.18 for V4L: | ||
6 | EXTRA_OECONF_append_class-target = " \ | ||
7 | --enable-kernel=3.18 \ | ||
8 | " | ||
9 | |||
10 | # Search $PWD/eglibc-2.18 for additional patches | ||
11 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:" | ||
12 | |||
13 | # Placeholder for patches | ||
14 | SRC_URI_append_class-target = " \ | ||
15 | " | ||
diff --git a/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend b/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend index f2bdba1..f2bdba1 100644 --- a/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend +++ b/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend | |||
diff --git a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend index 07c9646..70ee515 100644 --- a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend +++ b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend | |||
@@ -1,4 +1,3 @@ | |||
1 | |||
2 | ############################################################################ | 1 | ############################################################################ |
3 | ## | 2 | ## |
4 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2016 The Qt Company Ltd. |
@@ -28,6 +27,11 @@ | |||
28 | ## | 27 | ## |
29 | ############################################################################ | 28 | ############################################################################ |
30 | 29 | ||
30 | do_unpack_append() { | ||
31 | rm -rf ${STAGING_KERNEL_DIR} | ||
32 | ln -s ${S} ${STAGING_KERNEL_DIR} | ||
33 | } | ||
34 | |||
31 | do_kernel_defconfig_prepend () { | 35 | do_kernel_defconfig_prepend () { |
32 | } | 36 | } |
33 | 37 | ||
diff --git a/meta-vib4-extras/recipes/weston/weston-nv.bbappend b/meta-vib4-extras/recipes/weston/weston-nv.bbappend new file mode 100644 index 0000000..31b1ad1 --- /dev/null +++ b/meta-vib4-extras/recipes/weston/weston-nv.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_install_prepend() { | ||
31 | mv ${WORKDIR}/prebuilt/* ${WORKDIR}/ | ||
32 | } | ||