summaryrefslogtreecommitdiffstats
path: root/meta-vib4-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-13 13:06:09 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-14 10:22:37 +0000
commitf956591bbe246fae0dc4ed9b6d911bcec526463f (patch)
tree6a0da0066d8b9850cf913287ea55872041c67411 /meta-vib4-extras
parent776b174f4b54f8913933a67392f1cc3fa1085506 (diff)
downloadmeta-boot2qt-f956591bbe246fae0dc4ed9b6d911bcec526463f.tar.gz
Revert "tegra: update to latest vibrante pdk"
Problems with eglfs, so revert back to previous PDK. This reverts commit 323408406d9133a5462a24fea4ec86e649088180. Change-Id: I3ee36809cb823aefdc03f8a24d052c2a76f308db Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-vib4-extras')
-rw-r--r--meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch18
-rw-r--r--meta-vib4-extras/recipes/systemd/systemd_%.bbappend2
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend (renamed from meta-vib4-extras/recipes/weston/weston_%.bbappend)23
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc12
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc10
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc11
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc12
-rw-r--r--meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch105
-rw-r--r--meta-vib4-extras/recipes/weston/weston-nv.bbappend (renamed from meta-vib4-extras/recipes/wayland/wayland_%.bbappend)10
-rw-r--r--meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch13
10 files changed, 85 insertions, 131 deletions
diff --git a/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
new file mode 100644
index 0000000..629ccf4
--- /dev/null
+++ b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
@@ -0,0 +1,18 @@
1diff --git a/configure.ac b/configure.ac
2index 97a29d6..b0e4060 100644
3--- a/configure.ac
4+++ b/configure.ac
5@@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*],
6 -Wno-gnu-variable-sized-type-not-at-end \
7 ])])
8
9-AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
10- [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
11- -flto -ffat-lto-objects])],
12- [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
13 AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
14
15 AS_CASE([$CFLAGS], [*-O[[12345\ ]]*],
16--
172.5.0
18
diff --git a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend
index 53ea1e4..dbeb030 100644
--- a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend
+++ b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend
@@ -27,4 +27,4 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30SRC_URI_remove = "file://0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch" 30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-vib4-extras/recipes/weston/weston_%.bbappend b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
index cfc286f..f892961 100644
--- a/meta-vib4-extras/recipes/weston/weston_%.bbappend
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
@@ -27,10 +27,23 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" 30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31S = "${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston"
32 31
33do_install_prepend() { 32SRC_URI += " \
34 mkdir -p ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools 33 file://wayland-client.pc \
35 cp ${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston/tools/weston.ini ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools/weston.ini 34 file://wayland-cursor.pc \
35 file://wayland-egl.pc \
36 file://wayland-server.pc \
37 file://${PLATFORM_TOPDIR}/include/wayland-egl-core.h \
38 "
39
40FILES_${PN} += "${libdir}/pkgconfig"
41
42WAYLAND_PACKAGES += "wayland-dev"
43
44do_install_append() {
45 install -d ${D}${libdir}/pkgconfig
46 install -m 0776 ${WORKDIR}/*.pc ${D}${libdir}/pkgconfig
47 install -d ${D}${includedir}
48 install -m 0775 ${PLATFORM_TOPDIR}/include/wayland-egl-core.h ${D}${includedir}
36} 49}
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc
new file mode 100644
index 0000000..e639768
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=/usr
3datarootdir=${prefix}/share
4pkgdatadir=/usr/share/wayland
5libdir=/usr/lib
6includedir=/usr/include
7
8Name: Wayland Client
9Description: Wayland client side library
10Version: 1.6.0
11Cflags: -I${includedir}
12Libs: -L${libdir} -lwayland-client
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc
new file mode 100644
index 0000000..36538ad
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc
@@ -0,0 +1,10 @@
1prefix=/usr
2exec_prefix=/usr
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: Wayland Cursor
7Description: Wayland cursor helper library
8Version: 1.6.0
9Cflags: -I${includedir}
10Libs: -L${libdir} -lwayland-cursor
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc
new file mode 100644
index 0000000..dc8393f
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc
@@ -0,0 +1,11 @@
1prefix=/usr
2exec_prefix=/usr
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: wayland-egl
7Description: wayland-egl library
8Version: 9.1.6
9Libs: -L${libdir} -lwayland-egl
10Cflags: -I${includedir}
11
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc
new file mode 100644
index 0000000..dab87b9
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=/usr
3datarootdir=${prefix}/share
4pkgdatadir=/usr/share/wayland
5libdir=/usr/lib
6includedir=/usr/include
7
8Name: Wayland Server
9Description: Server side implementation of the Wayland protocol
10Version: 1.6.0
11Cflags: -I${includedir}
12Libs: -L${libdir} -lwayland-server
diff --git a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch b/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch
deleted file mode 100644
index 5e0e6bf..0000000
--- a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch
+++ /dev/null
@@ -1,105 +0,0 @@
1build: always build wayland-scanner
2
3The previous idiom for building a cross-compiled Wayland is to build once for
4the build host (with --enable-scanner --disable-libraries) to get a
5wayland-scanner binary that can then be used in a cross-compile (with
6--disable-scanner). The problem with this is that the cross wayland is missing
7a wayland-scanner binary, which means you then can't do any Wayland development
8on the target.
9
10Instead, always build wayland-scanner for the target and change
11--enable/disable-scanner to --with/without-host-scanner. Normal builds use the
12default of --without-host-scanner and run the wayland-scanner it just built, and
13cross-compiled builds pass --with-host-scanner to use a previously built host
14scanner but still get a wayland-scanner to install.
15
16(a theoretically neater solution would be to build two scanners if required (one
17to run and one to install), but automake makes this overly complicated)
18
19Signed-off-by: Ross Burton <ross.burton@intel.com>
20Upstream-Status: Submitted
21
22diff --git a/Makefile.am b/Makefile.am
23index c19494f..c2d929b 100644
24--- a/Makefile.am
25+++ b/Makefile.am
26@@ -64,16 +64,17 @@ nodist_libwayland_client_la_SOURCES = \
27
28 pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc
29
30-if ENABLE_SCANNER
31-wayland_scanner = $(top_builddir)/wayland-scanner
32 bin_PROGRAMS = wayland-scanner
33 wayland_scanner_SOURCES = src/scanner.c
34 wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS)
35 wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la
36-$(BUILT_SOURCES) : wayland-scanner
37 pkgconfig_DATA += src/wayland-scanner.pc
38-else
39+
40+if HOST_SCANNER
41 wayland_scanner = wayland-scanner
42+else
43+$(BUILT_SOURCES) : wayland-scanner
44+wayland_scanner = $(top_builddir)/wayland-scanner
45 endif
46
47 protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml
48diff --git a/configure.ac b/configure.ac
49index c2a804e..de0b02f 100644
50--- a/configure.ac
51+++ b/configure.ac
52@@ -65,11 +65,11 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
53 [[#include <time.h>]])
54 AC_CHECK_HEADERS([execinfo.h])
55
56-AC_ARG_ENABLE([scanner],
57- [AC_HELP_STRING([--disable-scanner],
58- [Disable compilation of wayland-scanner])],
59- [],
60- [enable_scanner=yes])
61+AC_ARG_WITH([host-scanner],
62+ [AC_HELP_STRING([--with-host-scanner],
63+ [Use a host wayland-scanner])],
64+ [],
65+ [with_host_scanner=no])
66
67 AC_ARG_ENABLE([documentation],
68 [AC_HELP_STRING([--disable-documentation],
69@@ -77,25 +77,23 @@ AC_ARG_ENABLE([documentation],
70 [],
71 [enable_documentation=yes])
72
73-AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes)
74+AM_CONDITIONAL(HOST_SCANNER, test "x$with_host_scanner" = xyes)
75
76 AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here],
77 [ ICONDIR=$withval],
78 [ ICONDIR=${datadir}/icons])
79 AC_SUBST([ICONDIR])
80
81-if test "x$enable_scanner" = "xyes"; then
82- PKG_CHECK_MODULES(EXPAT, [expat], [],
83- [AC_CHECK_HEADERS(expat.h, [],
84- [AC_MSG_ERROR([Can't find expat.h. Please install expat.])])
85- SAVE_LIBS="$LIBS"
86- AC_SEARCH_LIBS(XML_ParserCreate, expat, [],
87- [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
88- EXPAT_LIBS="$LIBS"
89- LIBS="$SAVE_LIBS"
90- AC_SUBST(EXPAT_LIBS)
91- ])
92-fi
93+PKG_CHECK_MODULES(EXPAT, [expat], [],
94+ [AC_CHECK_HEADERS(expat.h, [],
95+ [AC_MSG_ERROR([Can't find expat.h. Please install expat.])])
96+ SAVE_LIBS="$LIBS"
97+ AC_SEARCH_LIBS(XML_ParserCreate, expat, [],
98+ [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
99+ EXPAT_LIBS="$LIBS"
100+ LIBS="$SAVE_LIBS"
101+ AC_SUBST(EXPAT_LIBS)
102+ ])
103
104 AC_PATH_PROG(XSLTPROC, xsltproc)
105 AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
diff --git a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend b/meta-vib4-extras/recipes/weston/weston-nv.bbappend
index 463d5a1..31b1ad1 100644
--- a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend
+++ b/meta-vib4-extras/recipes/weston/weston-nv.bbappend
@@ -27,10 +27,6 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_append := ":${NVLAYER_DIR}/packages:${LNX_TOPDIR}/${PN}:${THISDIR}/${PN}" 30do_install_prepend() {
31 31 mv ${WORKDIR}/prebuilt/* ${WORKDIR}/
32SRC_URI_remove = "file://${NVLAYER_DIR}/packages/wayland-1.8.1-src.tar.gz" 32}
33SRC_URI = "\
34 file://wayland-1.8.1-src.tar.gz \
35 file://always-build-scanner.patch \
36 "
diff --git a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch b/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch
deleted file mode 100644
index 062da5c..0000000
--- a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: weston-1.5.0/configure.ac
2===================================================================
3--- weston-1.5.0.orig/configure.ac
4+++ weston-1.5.0/configure.ac
5@@ -503,7 +503,7 @@ if test x$wayland_scanner = x; then
6 AC_MSG_ERROR([wayland-scanner is needed to compile weston])
7 fi
8
9-PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
10+#PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
11
12 AC_CONFIG_FILES([Makefile src/version.h src/weston.pc])
13