diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-10-13 13:06:09 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-10-14 10:22:37 +0000 |
commit | f956591bbe246fae0dc4ed9b6d911bcec526463f (patch) | |
tree | 6a0da0066d8b9850cf913287ea55872041c67411 /meta-vib4-extras | |
parent | 776b174f4b54f8913933a67392f1cc3fa1085506 (diff) | |
download | meta-boot2qt-f956591bbe246fae0dc4ed9b6d911bcec526463f.tar.gz |
Revert "tegra: update to latest vibrante pdk"
Problems with eglfs, so revert back to previous PDK.
This reverts commit 323408406d9133a5462a24fea4ec86e649088180.
Change-Id: I3ee36809cb823aefdc03f8a24d052c2a76f308db
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-vib4-extras')
-rw-r--r-- | meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch | 18 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/systemd/systemd_%.bbappend | 2 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend (renamed from meta-vib4-extras/recipes/weston/weston_%.bbappend) | 23 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc | 12 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc | 10 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc | 11 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc | 12 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch | 105 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/weston/weston-nv.bbappend (renamed from meta-vib4-extras/recipes/wayland/wayland_%.bbappend) | 10 | ||||
-rw-r--r-- | meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch | 13 |
10 files changed, 85 insertions, 131 deletions
diff --git a/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch new file mode 100644 index 0000000..629ccf4 --- /dev/null +++ b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | diff --git a/configure.ac b/configure.ac | ||
2 | index 97a29d6..b0e4060 100644 | ||
3 | --- a/configure.ac | ||
4 | +++ b/configure.ac | ||
5 | @@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*], | ||
6 | -Wno-gnu-variable-sized-type-not-at-end \ | ||
7 | ])]) | ||
8 | |||
9 | -AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*], | ||
10 | - [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\ | ||
11 | - -flto -ffat-lto-objects])], | ||
12 | - [AC_MSG_RESULT([skipping -flto, optimization not enabled])]) | ||
13 | AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags") | ||
14 | |||
15 | AS_CASE([$CFLAGS], [*-O[[12345\ ]]*], | ||
16 | -- | ||
17 | 2.5.0 | ||
18 | |||
diff --git a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend index 53ea1e4..dbeb030 100644 --- a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend +++ b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend | |||
@@ -27,4 +27,4 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | SRC_URI_remove = "file://0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
diff --git a/meta-vib4-extras/recipes/weston/weston_%.bbappend b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend index cfc286f..f892961 100644 --- a/meta-vib4-extras/recipes/weston/weston_%.bbappend +++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend | |||
@@ -27,10 +27,23 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" | 30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
31 | S = "${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston" | ||
32 | 31 | ||
33 | do_install_prepend() { | 32 | SRC_URI += " \ |
34 | mkdir -p ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools | 33 | file://wayland-client.pc \ |
35 | cp ${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston/tools/weston.ini ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools/weston.ini | 34 | file://wayland-cursor.pc \ |
35 | file://wayland-egl.pc \ | ||
36 | file://wayland-server.pc \ | ||
37 | file://${PLATFORM_TOPDIR}/include/wayland-egl-core.h \ | ||
38 | " | ||
39 | |||
40 | FILES_${PN} += "${libdir}/pkgconfig" | ||
41 | |||
42 | WAYLAND_PACKAGES += "wayland-dev" | ||
43 | |||
44 | do_install_append() { | ||
45 | install -d ${D}${libdir}/pkgconfig | ||
46 | install -m 0776 ${WORKDIR}/*.pc ${D}${libdir}/pkgconfig | ||
47 | install -d ${D}${includedir} | ||
48 | install -m 0775 ${PLATFORM_TOPDIR}/include/wayland-egl-core.h ${D}${includedir} | ||
36 | } | 49 | } |
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc new file mode 100644 index 0000000..e639768 --- /dev/null +++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=/usr | ||
3 | datarootdir=${prefix}/share | ||
4 | pkgdatadir=/usr/share/wayland | ||
5 | libdir=/usr/lib | ||
6 | includedir=/usr/include | ||
7 | |||
8 | Name: Wayland Client | ||
9 | Description: Wayland client side library | ||
10 | Version: 1.6.0 | ||
11 | Cflags: -I${includedir} | ||
12 | Libs: -L${libdir} -lwayland-client | ||
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc new file mode 100644 index 0000000..36538ad --- /dev/null +++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc | |||
@@ -0,0 +1,10 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=/usr | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: Wayland Cursor | ||
7 | Description: Wayland cursor helper library | ||
8 | Version: 1.6.0 | ||
9 | Cflags: -I${includedir} | ||
10 | Libs: -L${libdir} -lwayland-cursor | ||
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc new file mode 100644 index 0000000..dc8393f --- /dev/null +++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc | |||
@@ -0,0 +1,11 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=/usr | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: wayland-egl | ||
7 | Description: wayland-egl library | ||
8 | Version: 9.1.6 | ||
9 | Libs: -L${libdir} -lwayland-egl | ||
10 | Cflags: -I${includedir} | ||
11 | |||
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc new file mode 100644 index 0000000..dab87b9 --- /dev/null +++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc | |||
@@ -0,0 +1,12 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=/usr | ||
3 | datarootdir=${prefix}/share | ||
4 | pkgdatadir=/usr/share/wayland | ||
5 | libdir=/usr/lib | ||
6 | includedir=/usr/include | ||
7 | |||
8 | Name: Wayland Server | ||
9 | Description: Server side implementation of the Wayland protocol | ||
10 | Version: 1.6.0 | ||
11 | Cflags: -I${includedir} | ||
12 | Libs: -L${libdir} -lwayland-server | ||
diff --git a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch b/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch deleted file mode 100644 index 5e0e6bf..0000000 --- a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | build: always build wayland-scanner | ||
2 | |||
3 | The previous idiom for building a cross-compiled Wayland is to build once for | ||
4 | the build host (with --enable-scanner --disable-libraries) to get a | ||
5 | wayland-scanner binary that can then be used in a cross-compile (with | ||
6 | --disable-scanner). The problem with this is that the cross wayland is missing | ||
7 | a wayland-scanner binary, which means you then can't do any Wayland development | ||
8 | on the target. | ||
9 | |||
10 | Instead, always build wayland-scanner for the target and change | ||
11 | --enable/disable-scanner to --with/without-host-scanner. Normal builds use the | ||
12 | default of --without-host-scanner and run the wayland-scanner it just built, and | ||
13 | cross-compiled builds pass --with-host-scanner to use a previously built host | ||
14 | scanner but still get a wayland-scanner to install. | ||
15 | |||
16 | (a theoretically neater solution would be to build two scanners if required (one | ||
17 | to run and one to install), but automake makes this overly complicated) | ||
18 | |||
19 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
20 | Upstream-Status: Submitted | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index c19494f..c2d929b 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -64,16 +64,17 @@ nodist_libwayland_client_la_SOURCES = \ | ||
27 | |||
28 | pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc | ||
29 | |||
30 | -if ENABLE_SCANNER | ||
31 | -wayland_scanner = $(top_builddir)/wayland-scanner | ||
32 | bin_PROGRAMS = wayland-scanner | ||
33 | wayland_scanner_SOURCES = src/scanner.c | ||
34 | wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS) | ||
35 | wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la | ||
36 | -$(BUILT_SOURCES) : wayland-scanner | ||
37 | pkgconfig_DATA += src/wayland-scanner.pc | ||
38 | -else | ||
39 | + | ||
40 | +if HOST_SCANNER | ||
41 | wayland_scanner = wayland-scanner | ||
42 | +else | ||
43 | +$(BUILT_SOURCES) : wayland-scanner | ||
44 | +wayland_scanner = $(top_builddir)/wayland-scanner | ||
45 | endif | ||
46 | |||
47 | protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml | ||
48 | diff --git a/configure.ac b/configure.ac | ||
49 | index c2a804e..de0b02f 100644 | ||
50 | --- a/configure.ac | ||
51 | +++ b/configure.ac | ||
52 | @@ -65,11 +65,11 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[], | ||
53 | [[#include <time.h>]]) | ||
54 | AC_CHECK_HEADERS([execinfo.h]) | ||
55 | |||
56 | -AC_ARG_ENABLE([scanner], | ||
57 | - [AC_HELP_STRING([--disable-scanner], | ||
58 | - [Disable compilation of wayland-scanner])], | ||
59 | - [], | ||
60 | - [enable_scanner=yes]) | ||
61 | +AC_ARG_WITH([host-scanner], | ||
62 | + [AC_HELP_STRING([--with-host-scanner], | ||
63 | + [Use a host wayland-scanner])], | ||
64 | + [], | ||
65 | + [with_host_scanner=no]) | ||
66 | |||
67 | AC_ARG_ENABLE([documentation], | ||
68 | [AC_HELP_STRING([--disable-documentation], | ||
69 | @@ -77,25 +77,23 @@ AC_ARG_ENABLE([documentation], | ||
70 | [], | ||
71 | [enable_documentation=yes]) | ||
72 | |||
73 | -AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes) | ||
74 | +AM_CONDITIONAL(HOST_SCANNER, test "x$with_host_scanner" = xyes) | ||
75 | |||
76 | AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here], | ||
77 | [ ICONDIR=$withval], | ||
78 | [ ICONDIR=${datadir}/icons]) | ||
79 | AC_SUBST([ICONDIR]) | ||
80 | |||
81 | -if test "x$enable_scanner" = "xyes"; then | ||
82 | - PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
83 | - [AC_CHECK_HEADERS(expat.h, [], | ||
84 | - [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
85 | - SAVE_LIBS="$LIBS" | ||
86 | - AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
87 | - [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
88 | - EXPAT_LIBS="$LIBS" | ||
89 | - LIBS="$SAVE_LIBS" | ||
90 | - AC_SUBST(EXPAT_LIBS) | ||
91 | - ]) | ||
92 | -fi | ||
93 | +PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
94 | + [AC_CHECK_HEADERS(expat.h, [], | ||
95 | + [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
96 | + SAVE_LIBS="$LIBS" | ||
97 | + AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
98 | + [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
99 | + EXPAT_LIBS="$LIBS" | ||
100 | + LIBS="$SAVE_LIBS" | ||
101 | + AC_SUBST(EXPAT_LIBS) | ||
102 | + ]) | ||
103 | |||
104 | AC_PATH_PROG(XSLTPROC, xsltproc) | ||
105 | AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"]) | ||
diff --git a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend b/meta-vib4-extras/recipes/weston/weston-nv.bbappend index 463d5a1..31b1ad1 100644 --- a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend +++ b/meta-vib4-extras/recipes/weston/weston-nv.bbappend | |||
@@ -27,10 +27,6 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | FILESEXTRAPATHS_append := ":${NVLAYER_DIR}/packages:${LNX_TOPDIR}/${PN}:${THISDIR}/${PN}" | 30 | do_install_prepend() { |
31 | 31 | mv ${WORKDIR}/prebuilt/* ${WORKDIR}/ | |
32 | SRC_URI_remove = "file://${NVLAYER_DIR}/packages/wayland-1.8.1-src.tar.gz" | 32 | } |
33 | SRC_URI = "\ | ||
34 | file://wayland-1.8.1-src.tar.gz \ | ||
35 | file://always-build-scanner.patch \ | ||
36 | " | ||
diff --git a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch b/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch deleted file mode 100644 index 062da5c..0000000 --- a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: weston-1.5.0/configure.ac | ||
2 | =================================================================== | ||
3 | --- weston-1.5.0.orig/configure.ac | ||
4 | +++ weston-1.5.0/configure.ac | ||
5 | @@ -503,7 +503,7 @@ if test x$wayland_scanner = x; then | ||
6 | AC_MSG_ERROR([wayland-scanner is needed to compile weston]) | ||
7 | fi | ||
8 | |||
9 | -PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner) | ||
10 | +#PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner) | ||
11 | |||
12 | AC_CONFIG_FILES([Makefile src/version.h src/weston.pc]) | ||
13 | |||