summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtquickcompiler_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-18 15:54:29 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-22 11:08:35 +0000
commit0f967048d5bd99ffacfb9893b76818293aaaa8a0 (patch)
tree26fe07810d3a093e5183cb788c5e982fac20ecd1 /recipes-qt/qt5/qtquickcompiler_git.bb
parent39b77b9a9437f471d00269c3fbf2177d07045386 (diff)
downloadmeta-boot2qt-0f967048d5bd99ffacfb9893b76818293aaaa8a0.tar.gz
Update Qt5 submodules
Moved some of the addon recipes to be under qt5 folder, so that update-qt5-modules.sh script will work for those as well. Using latest revision from meta-qt5 and applied necessary changes to qt5 recipes. Change-Id: I802ca2e4ea67bde10c3b065365d25f1e543da181 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/qt5/qtquickcompiler_git.bb')
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
new file mode 100644
index 0000000..6018770
--- /dev/null
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -0,0 +1,39 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Quick Compiler"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
25
26inherit qt5-module
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \
30 "
31
32SRCREV = "a2eac30f3be41447af1c9f2c3f3c841b68ca4d9c"
33BRANCH = "5.6"
34
35S = "${WORKDIR}/git"
36
37DEPENDS = "qtbase qtdeclarative"
38
39BBCLASSEXTEND = "native nativesdk"