summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtquickcompiler_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-05 15:50:21 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-12 10:11:38 +0000
commitcabaf4ef690ab5dcde901822edfd4fe5067497ac (patch)
treece006f10ef4ee9e36142c9f0a322b72ac3315f8f /recipes-qt/qt5/qtquickcompiler_git.bb
parente91280bbcb99d7f4e3f79c2efe9c1fbc40b144fc (diff)
downloadmeta-boot2qt-cabaf4ef690ab5dcde901822edfd4fe5067497ac.tar.gz
qt5: Upgrade to Qt 5.11.0
QtQuickCompiler is now part of qtdeclarative, separate recipe is no longer needed. Keeping qtquickcompiler.bbclass still for backwards compatibility. Change-Id: I8e6a66b176fc17c4bb161ae4638125238518e22a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtquickcompiler_git.bb')
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
deleted file mode 100644
index 36d2c19..0000000
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \
38 "
39
40SRCREV = "4e05e09f19bac2901cb16bf1229e396930b831ee"
41
42S = "${WORKDIR}/git"
43
44DEPENDS = "qtbase qtdeclarative"
45
46do_install_append() {
47 # Use the EffectivePath instead of installation path
48 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
49}
50
51BBCLASSEXTEND = "native nativesdk"