summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtquickcompiler_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-09-26 13:15:00 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-09-26 13:21:41 +0000
commit545bebca0722c21c4cd61c47260202bda20f2db4 (patch)
tree82503d6da46d47cb63dbb69f70739c710588f750 /recipes-qt/qt5/qtquickcompiler_git.bb
parent81831558b4dfdeb5030d6519f29d9ce122a434ce (diff)
downloadmeta-boot2qt-545bebca0722c21c4cd61c47260202bda20f2db4.tar.gz
qtquickcompiler: fix path for QT_HOST_BINS
Bitbake builds need to use QT_HOST_BINS/get for getting the correct path to the host tools. Change it for qtquickcompiler.prf so that project can use CONFIG+=qtquickcompiler without need to have CONFIG+=no_qtquickcompiler_depend as well. Change-Id: I5196e06f249531833fccca6b0b6a213016270ab6 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtquickcompiler_git.bb')
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
index e684364..ae3e87f 100644
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -43,4 +43,9 @@ S = "${WORKDIR}/git"
43 43
44DEPENDS = "qtbase qtdeclarative" 44DEPENDS = "qtbase qtdeclarative"
45 45
46do_install_append() {
47 # Use the EffectivePath instead of installation path
48 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
49}
50
46BBCLASSEXTEND = "native nativesdk" 51BBCLASSEXTEND = "native nativesdk"