diff options
author | Gordan Markuš <gordan.markus@pelagicore.com> | 2017-01-12 10:12:15 +0100 |
---|---|---|
committer | Dominik Holland <dominik.holland@pelagicore.com> | 2017-02-10 06:55:33 +0000 |
commit | d3b2f4c81168f55aaa19454e92943386a97b35af (patch) | |
tree | 00d820717524c25058c1c6d324a4967d314adc87 /recipes-qt | |
parent | 7ba2b7099f526203d2a904afd7a7f1779185f928 (diff) | |
download | meta-boot2qt-d3b2f4c81168f55aaa19454e92943386a97b35af.tar.gz |
AM: Add appman tools to automotive nativesdk
Task-number: QTAUTO-274
Change-Id: I467e93dc25a314cda0a4c35fe990c2b1274bc251
Reviewed-by: Gordan Markus <gordan.markus@pelagicore.com>
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
4 files changed, 58 insertions, 3 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index 3b54890..c4f1eb4 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -29,16 +29,18 @@ | |||
29 | 29 | ||
30 | DESCRIPTION = "Qt component for application lifecycle management" | 30 | DESCRIPTION = "Qt component for application lifecycle management" |
31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71" |
33 | 33 | ||
34 | inherit qt5-module | 34 | inherit qt5-module |
35 | require recipes-qt/qt5/qt5-git.inc | 35 | require recipes-qt/qt5/qt5-git.inc |
36 | 36 | ||
37 | SRCREV = "be9e9a37c2cd848cfdbb97990e0047f1a0834a8a" | 37 | SRCREV = "74d8bb0c8590dec7d6106781b1aa460756425d8f" |
38 | 38 | ||
39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | 39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ |
40 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 40 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
41 | |||
41 | RDEPENDS_${PN} = "libcrypto ${PN}-tools" | 42 | RDEPENDS_${PN} = "libcrypto ${PN}-tools" |
43 | RDEPENDS_${PN}_remove_mingw32 = "libcrypto" | ||
42 | 44 | ||
43 | EXTRA_QMAKEVARS_PRE += "\ | 45 | EXTRA_QMAKEVARS_PRE += "\ |
44 | ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ | 46 | ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ |
@@ -55,3 +57,12 @@ do_install_append() { | |||
55 | FILES_${PN} += "\ | 57 | FILES_${PN} += "\ |
56 | /opt/am \ | 58 | /opt/am \ |
57 | " | 59 | " |
60 | |||
61 | BBCLASSEXTEND += "nativesdk" | ||
62 | |||
63 | DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale" | ||
64 | DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale" | ||
65 | |||
66 | EXTRA_QMAKEVARS_PRE_class-nativesdk += "\ | ||
67 | -config tools-only \ | ||
68 | " | ||
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb index e74dd92..94bf48d 100644 --- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb +++ b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb | |||
@@ -34,6 +34,6 @@ LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | |||
34 | 34 | ||
35 | inherit populate_b2qt_qt5_sdk | 35 | inherit populate_b2qt_qt5_sdk |
36 | 36 | ||
37 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host" | 37 | TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host" |
38 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ | 38 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \ |
39 | packagegroup-b2qt-automotive-qt5-toolchain-target" | 39 | packagegroup-b2qt-automotive-qt5-toolchain-target" |
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb new file mode 100644 index 0000000..acae372 --- /dev/null +++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Host packages for B2Qt automotive Qt5 SDK" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | PR = "r0" | ||
33 | |||
34 | inherit nativesdk packagegroup qtquickcompiler | ||
35 | |||
36 | RDEPENDS_${PN} += "\ | ||
37 | nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \ | ||
38 | nativesdk-qtapplicationmanager-tools \ | ||
39 | " | ||
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend index 78106f8..d79bf57 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend | |||
@@ -33,5 +33,10 @@ SRC_URI += "\ | |||
33 | file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ | 33 | file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \ |
34 | " | 34 | " |
35 | 35 | ||
36 | PACKAGECONFIG += "openssl" | ||
37 | PACKAGECONFIG_remove_mingw32 += "openssl" | ||
38 | |||
39 | PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl" | ||
40 | |||
36 | fakeroot do_generate_qt_environment_file_mingw32() { | 41 | fakeroot do_generate_qt_environment_file_mingw32() { |
37 | } | 42 | } |