diff options
author | Kalle Viironen <kalle.viironen@digia.com> | 2014-02-21 12:08:34 +0200 |
---|---|---|
committer | Kalle Viironen <kalle.viironen@digia.com> | 2014-02-21 12:08:39 +0200 |
commit | a68e1ea9b2904f7c69330e534da877cf19376219 (patch) | |
tree | b3b6b17eea9ae44206226cc7d47f42841883020f /recipes/adbd | |
parent | 48f7d2b6ef3939417a1bf291a82fa36660b213e6 (diff) | |
parent | ee2541cf756ddada9bd008b148267e2836d42450 (diff) | |
download | meta-boot2qt-a68e1ea9b2904f7c69330e534da877cf19376219.tar.gz |
Merge branch 'stable' into releaseQtEE_v2.0.0
* stable: (34 commits)
udev: disable udev-cache also for beagleboard
busybox: use ifplugd to enable hotplug networking
Move libgl workaround to libsdl
imx53: change to correct GPU driver package
emulator: don't build mesa with llvm anymore
Fix emulator hdd image building
emulator: alsa config to allow multiple source to play audio
hunspell: use multple checksums for hunspell srcs
Changes to init script
Add script to initialize yocto build env
Add missing copyright headers
Update copyright year to 2014
adb: use modprobe to load dependency modules
udev: disable udev-cache on beaglebone
Add support for BeagleBone Black
Recipe for hunspell
upgrade emulator components
gpu-viv-bin-mx6q: remove dependency to mesa
rpi: disable bbappend from meta-raspberrypi
Install all kernel modules
...
Change-Id: I7adca9894ee35092d546babb1926edbf06300feb
Diffstat (limited to 'recipes/adbd')
-rw-r--r-- | recipes/adbd/adbd.bb | 22 | ||||
-rwxr-xr-x | recipes/adbd/files/adb-init | 2 | ||||
-rw-r--r-- | recipes/adbd/files/raspberrypi/adb-init | 21 |
3 files changed, 44 insertions, 1 deletions
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb index aa8f5e9..1feb7c3 100644 --- a/recipes/adbd/adbd.bb +++ b/recipes/adbd/adbd.bb | |||
@@ -1,3 +1,25 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
1 | DESCRIPTION = "Android Debug Bridge Daemon" | 23 | DESCRIPTION = "Android Debug Bridge Daemon" |
2 | HOMEPAGE = "http://developer.android.com/tools/help/adb.html" | 24 | HOMEPAGE = "http://developer.android.com/tools/help/adb.html" |
3 | SECTION = "devel" | 25 | SECTION = "devel" |
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init index e88df23..6faed60 100755 --- a/recipes/adbd/files/adb-init +++ b/recipes/adbd/files/adb-init | |||
@@ -8,7 +8,7 @@ SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | |||
8 | 8 | ||
9 | case "$1" in | 9 | case "$1" in |
10 | start) | 10 | start) |
11 | insmod $(busybox find /lib/modules/$(uname -r) -name "g_ffs.ko") idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL} | 11 | modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL} |
12 | mkdir -p /dev/usb-ffs | 12 | mkdir -p /dev/usb-ffs |
13 | chmod 770 /dev/usb-ffs | 13 | chmod 770 /dev/usb-ffs |
14 | mkdir -p /dev/usb-ffs/adb | 14 | mkdir -p /dev/usb-ffs/adb |
diff --git a/recipes/adbd/files/raspberrypi/adb-init b/recipes/adbd/files/raspberrypi/adb-init new file mode 100644 index 0000000..8910e0e --- /dev/null +++ b/recipes/adbd/files/raspberrypi/adb-init | |||
@@ -0,0 +1,21 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | DAEMON=/usr/bin/adbd | ||
4 | |||
5 | case "$1" in | ||
6 | start) | ||
7 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
8 | ;; | ||
9 | stop) | ||
10 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
11 | ;; | ||
12 | restart) | ||
13 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
14 | sleep 1 | ||
15 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
16 | ;; | ||
17 | *) | ||
18 | echo "Usage: $0 {start|stop|restart}" | ||
19 | exit 1 | ||
20 | esac | ||
21 | exit 0 | ||