diff options
author | David Schulz <david.schulz@theqtcompany.com> | 2016-01-05 09:15:54 +0100 |
---|---|---|
committer | David Schulz <david.schulz@theqtcompany.com> | 2016-01-14 13:39:24 +0000 |
commit | 3b0f70a63d303af37dc1a77670eea12cfc364975 (patch) | |
tree | ec630531b46c77fb53685804df7addfbb2194f57 /recipes/gdb | |
parent | b8376daee8272602f55e0bdb58dac18511109d1d (diff) | |
download | meta-boot2qt-3b0f70a63d303af37dc1a77670eea12cfc364975.tar.gz |
Use prebuild windows python to create a python enabled gdb.
Change-Id: I3cb97636ed064a1e9fd2a45f8fe0b12edba52428
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'recipes/gdb')
-rw-r--r-- | recipes/gdb/gdb-cross-canadian_7.8.1.bbappend | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/gdb/gdb-cross-canadian_7.8.1.bbappend b/recipes/gdb/gdb-cross-canadian_7.8.1.bbappend new file mode 100644 index 0000000..7e73d41 --- /dev/null +++ b/recipes/gdb/gdb-cross-canadian_7.8.1.bbappend | |||
@@ -0,0 +1,31 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python" | ||
24 | RDEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python" | ||
25 | EXTRA_OECONF_append_sdkmingw32 = " --with-python" | ||
26 | |||
27 | do_install_append_sdkmingw32() { | ||
28 | mkdir -p ${D}${bindir}/lib | ||
29 | cp -r ${STAGING_DIR_HOST}${exec_prefix}/lib/python2.7/* -d ${D}${bindir}/lib | ||
30 | cp ${STAGING_DIR_HOST}${exec_prefix}/bin/python27.dll ${D}${bindir} | ||
31 | } | ||