summaryrefslogtreecommitdiffstats
path: root/recipes/initramfs-basic/init-basic.bb
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-21 10:37:05 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-23 11:18:52 +0000
commit769ae5571a5501cbe9c3b12c560a3e6916bff4ca (patch)
tree33c5254310011553b5cbaa2d0303920ab0df6da1 /recipes/initramfs-basic/init-basic.bb
parentf6af3a3551f3cb6c90aa05d90941c6140a674279 (diff)
downloadmeta-boot2qt-769ae5571a5501cbe9c3b12c560a3e6916bff4ca.tar.gz
NUC: Use custom image layout
This patch adds a new image class 'image_dd', by default it has an empty boot partition. image_dd_efi extends this class to support Intel NUC board. The layout of a generated image is a prerequisite for OSTree integarion. Image generated by 'hddimg' produces rootfs.img (ext3 filesystem file) and then "live" boots it from initramfs by mounting rootfs.img via loop device. For OTA integration we need to access contents of rootfs.img already from boot loader. The custom 'image_nuc_efi' layout allow for fully atomic updates on EFI based system, by keeping GRUB-EFI binary on a dedicated EFI system partition (ESP). OSTree currently is not fully atomic on EFI systems, but with this setup we use GRUB-BIOS code path in OSTree, which is atomic. After EFI firmware has loaded the GRUB-EFI binary, everything else is done on rootfs parition. One limitation from the above scenario is that you would need to update /EFI/BOOT/bootx64.efi (GRUB-EFI) binary manually. Not sure how common it is to update a boot loader binary on a deployed system, but its not impossible. Change-Id: Ibf2840aecd548000372131c4ded5cffa11ff1b0f Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes/initramfs-basic/init-basic.bb')
-rw-r--r--recipes/initramfs-basic/init-basic.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/initramfs-basic/init-basic.bb b/recipes/initramfs-basic/init-basic.bb
new file mode 100644
index 0000000..674e683
--- /dev/null
+++ b/recipes/initramfs-basic/init-basic.bb
@@ -0,0 +1,34 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22SUMMARY = "Simple init script that mounts root filesystem by label."
23LICENSE = "CLOSED"
24SRC_URI = "file://init.sh"
25
26S = "${WORKDIR}"
27
28do_install () {
29 install -m 0755 ${WORKDIR}/init.sh ${D}/init
30}
31
32inherit allarch
33
34FILES_${PN} += "/init"