summaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm-common.bb
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-02-21 12:08:34 +0200
committerKalle Viironen <kalle.viironen@digia.com>2014-02-21 12:08:39 +0200
commita68e1ea9b2904f7c69330e534da877cf19376219 (patch)
treeb3b6b17eea9ae44206226cc7d47f42841883020f /recipes/llvm/llvm-common.bb
parent48f7d2b6ef3939417a1bf291a82fa36660b213e6 (diff)
parentee2541cf756ddada9bd008b148267e2836d42450 (diff)
downloadmeta-boot2qt-a68e1ea9b2904f7c69330e534da877cf19376219.tar.gz
Merge branch 'stable' into releaseQtEE_v2.0.0
* stable: (34 commits) udev: disable udev-cache also for beagleboard busybox: use ifplugd to enable hotplug networking Move libgl workaround to libsdl imx53: change to correct GPU driver package emulator: don't build mesa with llvm anymore Fix emulator hdd image building emulator: alsa config to allow multiple source to play audio hunspell: use multple checksums for hunspell srcs Changes to init script Add script to initialize yocto build env Add missing copyright headers Update copyright year to 2014 adb: use modprobe to load dependency modules udev: disable udev-cache on beaglebone Add support for BeagleBone Black Recipe for hunspell upgrade emulator components gpu-viv-bin-mx6q: remove dependency to mesa rpi: disable bbappend from meta-raspberrypi Install all kernel modules ... Change-Id: I7adca9894ee35092d546babb1926edbf06300feb
Diffstat (limited to 'recipes/llvm/llvm-common.bb')
-rw-r--r--recipes/llvm/llvm-common.bb22
1 files changed, 0 insertions, 22 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
deleted file mode 100644
index 192919e..0000000
--- a/recipes/llvm/llvm-common.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "Helper script for OE's llvm support"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
5"
6
7SRC_URI = "file://llvm-config"
8
9ALLOW_EMPTY_${PN} = "1"
10SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
11
12llvm_common_sysroot_preprocess() {
13 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
15}
16
17do_install_virtclass-native() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
20}
21
22BBCLASSEXTEND = "native"