summaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm-common.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-01-23 13:36:37 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-01-30 12:16:59 +0200
commit20a3734c0da057a51aadc89e3dba163367611dc5 (patch)
treed12c2482dc7faccd3cb25220ac1d22d8173c70e9 /recipes/llvm/llvm-common.bb
parentc3918d45cd6ae9601d99bf695d8672f2fc7f1f1e (diff)
downloadmeta-boot2qt-20a3734c0da057a51aadc89e3dba163367611dc5.tar.gz
upgrade emulator components
- kernel 3.10 - LLVM 3.3 - mesa 9.1.6 Change-Id: Ib15c6826ab480e39e4efb7a16d42030b55ad6c3b Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
Diffstat (limited to 'recipes/llvm/llvm-common.bb')
-rw-r--r--recipes/llvm/llvm-common.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
deleted file mode 100644
index 0e20600..0000000
--- a/recipes/llvm/llvm-common.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Helper script for OE's llvm support"
24LICENSE = "MIT"
25LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
26 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
27"
28
29SRC_URI = "file://llvm-config"
30
31ALLOW_EMPTY_${PN} = "1"
32SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
33
34llvm_common_sysroot_preprocess() {
35 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
36 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
37}
38
39do_install_virtclass-native() {
40 install -d ${D}${bindir}
41 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
42}
43
44BBCLASSEXTEND = "native"