summaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-03 13:27:16 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-04 09:30:10 +0000
commit1ee4cd208f7283c3c932b8fa4f94f2de27116ac1 (patch)
tree4270f74092e7864fc7e08a965d1f26538444c940 /recipes/perl
parente0ac6aee3ae45a70115ae9fb7227d0f4a1ff837d (diff)
downloadmeta-boot2qt-1ee4cd208f7283c3c932b8fa4f94f2de27116ac1.tar.gz
perl: use relocatable path in the wrapper
Instead of using $OECORE_NATIVE_SYSROOT environment variable, that require sourcing the environment-setup-xxx script, use the SDKPATHNATIVE path that gets relocated during sdk installation. Change-Id: Ife7f84b3bb92d1492e96e9a65fd9cec4555aaecc Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl_5.%.bbappend24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/perl/perl_5.%.bbappend b/recipes/perl/perl_5.%.bbappend
new file mode 100644
index 0000000..22ce2a8
--- /dev/null
+++ b/recipes/perl/perl_5.%.bbappend
@@ -0,0 +1,24 @@
1##############################################################################
2##
3## Copyright (C) 2015 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22do_install_append_class-nativesdk () {
23 sed -i -e 's|$OECORE_NATIVE_SYSROOT/|${SDKPATHNATIVE}|g' ${D}${bindir}/perl
24}