summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-uenv-script.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 13:19:11 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:32 +0300
commit2395137acb37e56a85c1b78bad86a58d9c04e54d (patch)
tree2c0fb13cd3b737607271b5bd6a14a5bdaa5108eb /recipes/u-boot/u-boot-uenv-script.bb
parent01603689e8dd2d3c5be0f41d41b3543452903f03 (diff)
downloadmeta-boot2qt-2395137acb37e56a85c1b78bad86a58d9c04e54d.tar.gz
Move meta-beagleboard specific files to separate layer
Create new layer for recipes and files that required only when meta-beagleboard layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: I5e50067b8b6c7d480d3808a24e8acc2ace07b04b Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'recipes/u-boot/u-boot-uenv-script.bb')
-rw-r--r--recipes/u-boot/u-boot-uenv-script.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb
deleted file mode 100644
index b15dd1f..0000000
--- a/recipes/u-boot/u-boot-uenv-script.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "U-Boot script to start up BeagleBone Black"
24LICENSE = "CLOSED"
25PR = "r0"
26
27COMPATIBLE_MACHINE = "(beaglebone)"
28PV = "20140225"
29
30SRC_URI = "file://uEnv.txt"
31
32inherit deploy
33
34do_deploy () {
35 install -d ${DEPLOYDIR}
36 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
37
38 cd ${DEPLOYDIR}
39 rm -f uEnv-${MACHINE}.txt
40 ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
41}
42
43addtask deploy after do_install before do_build
44
45do_compile[noexec] = "1"
46do_install[noexec] = "1"
47do_populate_sysroot[noexec] = "1"
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"