summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-uenv-script.bb
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:33 +0300
committerKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:40 +0300
commitbfb97bc3cc517c42647f5f8b1308bb7b1f4c76f1 (patch)
tree534bfaffc99f288f395297c625e284fea6e50401 /recipes/u-boot/u-boot-uenv-script.bb
parenta68e1ea9b2904f7c69330e534da877cf19376219 (diff)
parent03be9b83d45659d0d98fa1bf69853e0aa297ed32 (diff)
downloadmeta-boot2qt-00fcaf13fc101f77968e1aead813a8aaf43aaca1.tar.gz
Merge branch 'stable' into releaseQtEE_v2.1.0
* stable: wpa-supplicant: include headers and sources for external usage bootfs: need to use fakeroot for tar'ing sdk: include bluez4-dev package to sdk Create boot.tar.gz as part of the image build image: include CA certificates to image adbd: use network connection in imx53qsb sdk: libcap is required for QtWebEngine Include licenses to the image adbd: make switching between usb and ethernet easier use package groups for image content Create only tar.gz image type Change from dylan to dora brach in README mkcard: remove recipe for mkcard Change-Id: Id56ca219d05f2f833a4de3fc3ca057c5cf50a562
Diffstat (limited to 'recipes/u-boot/u-boot-uenv-script.bb')
-rw-r--r--recipes/u-boot/u-boot-uenv-script.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb
new file mode 100644
index 0000000..b15dd1f
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "U-Boot script to start up BeagleBone Black"
24LICENSE = "CLOSED"
25PR = "r0"
26
27COMPATIBLE_MACHINE = "(beaglebone)"
28PV = "20140225"
29
30SRC_URI = "file://uEnv.txt"
31
32inherit deploy
33
34do_deploy () {
35 install -d ${DEPLOYDIR}
36 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
37
38 cd ${DEPLOYDIR}
39 rm -f uEnv-${MACHINE}.txt
40 ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
41}
42
43addtask deploy after do_install before do_build
44
45do_compile[noexec] = "1"
46do_install[noexec] = "1"
47do_populate_sysroot[noexec] = "1"
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"