diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-03-25 13:41:19 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-03-26 12:42:51 +0200 |
commit | 13c0a0c319524012c2b6cc7aa92d6b5f487d4d58 (patch) | |
tree | 67a4277cb54768ea1bf4ec71d7369d3d15bf75c3 /recipes/u-boot/u-boot-uenv-script.bb | |
parent | ac491beed785edeea0e8ae3d883864ab521da6b0 (diff) | |
download | meta-boot2qt-13c0a0c319524012c2b6cc7aa92d6b5f487d4d58.tar.gz |
Create boot.tar.gz as part of the image build
Each machine config defines what is included in the boot.tar.gz
package. For beaglebone, include the uEnv.txt u-boot script that
is used to start up the device.
Change-Id: Ia509dd61c789fda53889cea8ea9221cfa8b469a9
Reviewed-by: Andy Nichols <andy.nichols@digia.com>
Diffstat (limited to 'recipes/u-boot/u-boot-uenv-script.bb')
-rw-r--r-- | recipes/u-boot/u-boot-uenv-script.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb new file mode 100644 index 0000000..b15dd1f --- /dev/null +++ b/recipes/u-boot/u-boot-uenv-script.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "U-Boot script to start up BeagleBone Black" | ||
24 | LICENSE = "CLOSED" | ||
25 | PR = "r0" | ||
26 | |||
27 | COMPATIBLE_MACHINE = "(beaglebone)" | ||
28 | PV = "20140225" | ||
29 | |||
30 | SRC_URI = "file://uEnv.txt" | ||
31 | |||
32 | inherit deploy | ||
33 | |||
34 | do_deploy () { | ||
35 | install -d ${DEPLOYDIR} | ||
36 | install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt | ||
37 | |||
38 | cd ${DEPLOYDIR} | ||
39 | rm -f uEnv-${MACHINE}.txt | ||
40 | ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt | ||
41 | } | ||
42 | |||
43 | addtask deploy after do_install before do_build | ||
44 | |||
45 | do_compile[noexec] = "1" | ||
46 | do_install[noexec] = "1" | ||
47 | do_populate_sysroot[noexec] = "1" | ||
48 | |||
49 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||