diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2013-10-22 14:32:56 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2013-10-24 15:42:05 +0300 |
commit | 713306041324f18fd546fbf99cd7d15ec1eeb6f2 (patch) | |
tree | a4d29129910aa0a2f4bb6980aa12a0db3954bde8 /recipes | |
parent | f35bcc5ed220e748241c1e06bcd1ab6a7c99e10d (diff) | |
download | meta-boot2qt-713306041324f18fd546fbf99cd7d15ec1eeb6f2.tar.gz |
Sound support for Raspberry Pi
Load appropriate kernel module and setup correct alsa configuration.
Sound is routed to HDMI by default, so include amixer util
that can be used to switch to analog output:
amixer cset numid=3 1
Change-Id: I1a975992a45ea2a11ce44ded8b1649488e676341
Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/alsa/alsa-state.bbappend | 1 | ||||
-rw-r--r-- | recipes/alsa/alsa-state/raspberrypi/asound.conf | 9 | ||||
-rw-r--r-- | recipes/images/b2qt-embedded-image.bb | 1 |
3 files changed, 11 insertions, 0 deletions
diff --git a/recipes/alsa/alsa-state.bbappend b/recipes/alsa/alsa-state.bbappend new file mode 100644 index 0000000..72d991c --- /dev/null +++ b/recipes/alsa/alsa-state.bbappend | |||
@@ -0,0 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
diff --git a/recipes/alsa/alsa-state/raspberrypi/asound.conf b/recipes/alsa/alsa-state/raspberrypi/asound.conf new file mode 100644 index 0000000..83f7f9a --- /dev/null +++ b/recipes/alsa/alsa-state/raspberrypi/asound.conf | |||
@@ -0,0 +1,9 @@ | |||
1 | pcm.!default { | ||
2 | type hw | ||
3 | card 0 | ||
4 | } | ||
5 | |||
6 | ctl.!default { | ||
7 | type hw | ||
8 | card 0 | ||
9 | } | ||
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb index 6dc4f1f..feb1cfd 100644 --- a/recipes/images/b2qt-embedded-image.bb +++ b/recipes/images/b2qt-embedded-image.bb | |||
@@ -52,6 +52,7 @@ IMAGE_INSTALL += "\ | |||
52 | liberation-fonts \ | 52 | liberation-fonts \ |
53 | tslib \ | 53 | tslib \ |
54 | tslib-calibrate \ | 54 | tslib-calibrate \ |
55 | alsa-utils-amixer \ | ||
55 | ${GSTREAMER_EXTRA_INSTALL} \ | 56 | ${GSTREAMER_EXTRA_INSTALL} \ |
56 | ${TOOLS_EXTRA_INSTALL} \ | 57 | ${TOOLS_EXTRA_INSTALL} \ |
57 | ${MACHINE_EXTRA_INSTALL} \ | 58 | ${MACHINE_EXTRA_INSTALL} \ |