diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2013-05-23 13:40:02 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2013-05-24 09:37:08 +0300 |
commit | d24768d9e4a3a150daeff869ad5b96e585c17795 (patch) | |
tree | 019d7b4ac1a4ff34c0ff0f11acd0f89ea05e52d7 /recipes | |
parent | 0b1d0a80aa7e89ac080ab84dc3e84737e26c0c5c (diff) | |
download | meta-boot2qt-d24768d9e4a3a150daeff869ad5b96e585c17795.tar.gz |
u-boot: change beagleboard's default resolution to 800x600
Also increase VRAM for omapfb so that we can run EGL
in flip mode.
Change-Id: I452cc6512706d373e196d76e8e9a30fa3e738235
Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
Diffstat (limited to 'recipes')
-rw-r--r-- | recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch | 49 | ||||
-rw-r--r-- | recipes/u-boot/u-boot-beagleboard_2011.09.bbappend | 4 |
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch b/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch new file mode 100644 index 0000000..c4d5658 --- /dev/null +++ b/recipes/u-boot/u-boot-beagleboard/0001-beagle-change-default-resolution-and-increase-VRAM-f.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 8c84c554583c516918ce9185bd03bc1d984bf49c Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Thu, 23 May 2013 14:37:10 +0300 | ||
4 | Subject: [PATCH] beagle: change default resolution and increase VRAM for fb0 | ||
5 | |||
6 | --- | ||
7 | include/configs/omap3_beagle.h | 5 ++++- | ||
8 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h | ||
11 | index 1cc46dc..6a812ba 100644 | ||
12 | --- a/include/configs/omap3_beagle.h | ||
13 | +++ b/include/configs/omap3_beagle.h | ||
14 | @@ -224,7 +224,7 @@ | ||
15 | "optargs=\0" \ | ||
16 | "camera=none\0" \ | ||
17 | "vram=12M\0" \ | ||
18 | - "dvimode=640x480MR-16@60\0" \ | ||
19 | + "dvimode=800x600MR-16@60\0" \ | ||
20 | "defaultdisplay=dvi\0" \ | ||
21 | "mmcdev=0\0" \ | ||
22 | "mmcroot=/dev/mmcblk0p2 ro\0" \ | ||
23 | @@ -240,6 +240,7 @@ | ||
24 | "buddy2=${buddy2} "\ | ||
25 | "camera=${camera} "\ | ||
26 | "vram=${vram} " \ | ||
27 | + "omapfb.vram=0:${vram} " \ | ||
28 | "omapfb.mode=dvi:${dvimode} " \ | ||
29 | "omapdss.def_disp=${defaultdisplay} " \ | ||
30 | "root=${mmcroot} " \ | ||
31 | @@ -250,6 +251,7 @@ | ||
32 | "buddy=${buddy} "\ | ||
33 | "camera=${camera} "\ | ||
34 | "vram=${vram} " \ | ||
35 | + "omapfb.vram=0:${vram} " \ | ||
36 | "omapfb.mode=dvi:${dvimode} " \ | ||
37 | "omapdss.def_disp=${defaultdisplay} " \ | ||
38 | "root=${nandroot} " \ | ||
39 | @@ -263,6 +265,7 @@ | ||
40 | "mpurate=${mpurate} " \ | ||
41 | "buddy=${buddy} "\ | ||
42 | "vram=${vram} " \ | ||
43 | + "omapfb.vram=0:${vram} " \ | ||
44 | "omapfb.mode=dvi:${dvimode} " \ | ||
45 | "omapdss.def_disp=${defaultdisplay} " \ | ||
46 | "root=${ramroot} " \ | ||
47 | -- | ||
48 | 1.7.10.4 | ||
49 | |||
diff --git a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend new file mode 100644 index 0000000..28c08bc --- /dev/null +++ b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | SRC_URI += " \ | ||
3 | file://0001-beagle-change-default-resolution-and-increase-VRAM-f.patch \ | ||
4 | " | ||